LINUX.ORG.RU
решено ФорумAdmin

CentOS 7: отключить обновление пакета

 , ,


0

0

UPD: Нашел решение сам:
Добавить exclude=qt-mobility в yum.conf

Есть пакет qt-mobility.i686 0:1.2.2-0.4.20120224git.fc19, который стоит из реп Fedora 19. При обновлении, yum пытается обновить его до qt-mobility-1.2.2-0.16.20140317git169da60c.el7.x86_64 из epel. Вот ошибка:

Error: Package: qtwebkit-2.3.3-3.fc19.i686 (@fedora19-updates)
           Requires: libQtSensors.so.1
           Removing: qt-mobility-1.2.2-0.4.20120224git.fc19.i686 (@fedora19)
               libQtSensors.so.1
           Updated By: qt-mobility-1.2.2-0.16.20140317git169da60c.el7.x86_64 (epel)
               Not found
Error: Package: qtwebkit-2.3.3-3.fc19.i686 (@fedora19-updates)
           Requires: libQtLocation.so.1
           Removing: qt-mobility-1.2.2-0.4.20120224git.fc19.i686 (@fedora19)
               libQtLocation.so.1
           Updated By: qt-mobility-1.2.2-0.16.20140317git169da60c.el7.x86_64 (epel)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Может есть способ убрать обновление для этого пакета? Он мне нужен для Skype.

Ответ на: комментарий от alpha

Все, спасибо. Нашел решение сам:
Добавить exclude=qt-mobility в yum.conf

nobodyabc ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.