LINUX.ORG.RU

64
Всего сообщений: 903

DIY «Собери свой роутер»

На фото самосборный роутер. Стоит матплата из серии pc engines, 2 mpcie модуля Mikrotik для обеспечения wifi сети 5Ghz и 2.4 Ghz. Загружается и работает на openwrt ( хотя любой линукс поддерживается тоже ). Из напильника - пришлось просверлить 3 доп. отверстия для антенны ( непонятно почему не сделали это по умолчанию ). Как бонус можно добавить еще 2 ethernet порта через mcpie карту.

Цена получилась немного больше стоимости топовых роутеров.

>>> Просмотр (1139x873, 1791 Kb)

 

Jopich1 ()

OpenWRT и Unifi AP LR

Все та же кухня, но:
1. Системник переехал на подоконник
2. Оживленный Asus eeepc-1101ha (Fedora 24 minimal + openbox)
3. Главный герой: Ubiquiti Unifi AP LR со слетевшей стоковой прошивкой.
4. Матрешка
5. Конфетки «Коровка»

В неспешном режиме, со множеством пыток и попыток ставлю OpenWRT на Unifi. Стоковые обкирпичивают пациента. Перевел в режим просто точки, ибо весь функционал роутера не требуется. Имел ли кто опыт в данной связке? На данный момент добился работы только в режиме 11g.

>>> Просмотр (4608x2592, 2995 Kb)

 , ,

v0mqfish ()

Корпусируем BPi R1 (ака Lamobo-R1)

Просили рассказать что и как, как приедет железяка. Собственно, спустя полтора месяца приехала. Брал на адиэкспрессе, рассказываю.

TL;DR: Косяков в дизайне навалом, акриловый корпус убог, OpenWRT пашет с QoS'ами и VLAN'ами, при правильном приготовлении - лютый вин.

Теперь подробнее. Что мне не понравилось - нет в комплекте IPX<-->SMA косичек и антенн. Для меня не критично, я человек запасливый, но для многих может оказаться шоустоппером.

Вот все, что приехало

Начнем с хорошего. Бредкомовский свитч, которого я опасался внезапно работает, и вроде бы неплохо. Есть VLAN'ы, QoS и прочие радости. Есть поддержка всего этого добра в транке OpenWRT. OpenWRT вообще на выхлопе генерит образ для SD карточки, что не может не радовать. Ядро 3.18.6, мейнлайн. Работает SATA, есть разъем для LiPo батарейки. Если вырубают на даче свет - у этой штуки, считайте, встроенный бесперебойник. rtl8192cu завелся без проблем, в том числе и в режиме точки доступа в N режиме с полосой 40Mhz, сигнал отличный.

Корпус из акрила убог. Очень Убог.

Я даже не стал снимать защитную пленку с акрила, так что если кому нужен такой корпус - отдам ровно за столько, засколько сам взял у китайцев.

Теперь о косяках.

  • Аккумулятор (в комплекте нет, сойдет любой LiIon на 3.7 В) сажается в XH-2 2.54mm разъем. Если HDD воткнут - аккум уже не воткнуть, надо разбирать. Положение разъема очень неудачное. В стоковом корпусе под него нет места.
  • Жесткий диск не вытащить не снимая боковую стенку корпуса.
  • Питание исключительно через microusb разъем. Нет ОТК на этих содомитов. Даже если разъем протянет 2А (В жидком азоте если только), (грубо) 500мА жрет зарядка аккума, 500мА по спекам что-то воткнутое в USB (а их там у нас 2, считая OTG), еще 500-600мА жесткий диск. И это не считая broadcom'овского свитча с интегрированной физикой. 5 гигабитных портов это вам не диодиком мигнуть и сам SoC. Впрочем, при питании через microusb у меня даже жесткий диск не раскрутился из-за падения на проводах. Поскреб напильником плату, подпаял JST шнурок, все заработало.
  • Родной корпус не обеспечивает нормального охлаждения свитча, а он греется весьма, даже без трафика. Гигабит же!
  • Плата крайне тонкая и будет деформироваться, особенно под весом жесткого диска!
  • Sysupgrade на OpenWRT при загрузке с SD (ext4) не работает. squashfs образ не делает по дефолту rw оверлея, с этим еще предстоит разобраться.
  • Пин который управляет питанием HDD по дефолту в режиме «вход», в нем и остается, HDD без хаков не раскручивается.

С этим надо было как-то бороться, потому я быстро и решительно взял припасенный для другого проекта корпус из люминия и начал экзекучию. Посадил 3 отрезных диска для гравера, покрылся стружкой - но сделал вырез для ethernet'ов сбоку. На оба microusb забил - все равно на мейнлайне inventra'вский musb заводится с кровавыми патчами и без DMA.

Разметил боковую стенку, засверлил и смотрировал туда два SMA разъема. Встали как родные.

Далее по месту засверлил корпус, нарезал резьбу и вкрутил стойки, шедшие в комплекте. С обратной стороны торчащую резьбу срезал гравером и подшлифовал, чтобы не торчало.

Все, конструкцию можно собирать. Свитч расположен снизу, потому я в этом месте сделал охлаждение на корпус. Заодно еще одна точка опоры в центре - не будет так прогибаться от жесткого диска. Так как одного USB мне показалось мало, а хаб был под рукой только на 4 (мало) и 13 портов, после процедуры укорочения кабеля приклеил на двусторонний скотч 13-портовый хаб.

TODO:

  • Починить sysupgrade.
  • Вывести уровень заряда батареи на dashboard в OpenWRT
  • Подобрать и вывести разъем для питания и батареи на торец. Есть шальная мысля заюзать PS/2 со старой материнки, который с клеплением к корпусу, на него же вывести и UART. Но это надо будет еще думать.
  • Настроить OpenVPN, pppoe, и прочие радости жизни, прогнать iperf.
  • Придумать для чего использоваться место на этом жестком диске. Пока напрашивается туда повесить apt-cacher или squid.

Задавайте свои вопросы. Больше фоток - тут http://pics.ncrmnt.org/index.php?album=junk/lamobo-r1/ Качество некоторых фоток фиговое - их снимал на голову ведьмы старый китафон.

>>> Просмотр (2000x1124, 757 Kb)

 , ,

ncrmnt ()

5 вольт - не влезай убьёт!

Долго использовал старый нетбук в качестве домашнего сервера, точки доступа. Но стал барахлить и блок питания и аккумулятор и usb. Попробовал сделать замену из легендарного роутера tp-link mr3020 и уложиться в 5 вольт для питания нового сервера, т.к. именно пятивольтовые зарядки доступны везде и найти замену в случае выхода из строя не составит проблем.

Но, как оказалось, главная проблема - это подбор блока питания и вообще организация электропитания. Ещё влияет длина провода, сечение, качество соединения и прочее. Испортил дюжину зарядок, которые могут тянуть роутер с флешкой плюс adsl модем (~1-2A + 1A). Даже самые дешёвые могут пару дней/недель тянуть оба устройства, но потом начинаются сбои, появляется запах у блока питания, и странные волны, уже явно недостаточных милиампер. Подскажите что в них нужно менять, чтобы вернуть в работу.

На серваке последняя версия Openwrt 14.09 с поддержкой из коробки ipv6, pppoe. Т.е без задействования флешки можно поднять сеть pppoe с поддержкой ipv6 (провайдер даёт подсеть глобальную). Ещё на сервере ftp, samba, mini_http, transmission, p910 (принт-сервер с лазерным принтером). На всех домашних устройствах глобальный ipv6, что с учётом повсеместно серых ipv4 большой плюс. У кого-то даже виден сайт на серваке http://poshat.dhis.org (ipv6).

Openwrt 14.09 более стабильна и заточена под ipv6. Сложности были с поиском в путаном wiki нужных опций для ipv6.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'wan'
	option ifname 'eth0'
	option proto 'pppoe'
	option username '***'
	option password '***'
	option ipv6 '1'
	option mtu '1452'
	option accept_ra '1'
	option send_rs '1'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config interface 'wlan'
	option proto 'static'
	option ipaddr '192.168.1.11'
	option netmask '255.255.255.0'
	option ip6assign '64'

Стоит всё это чудо приблизительно в центре квартиры на шкафу, для наилучшего WiFi сигнала повсюду. Если стану уверен, что всё работает стабильно, то конечно буду думать как ещё загрузить сервачок ( вебкамера, DLNA, rsync и прочее).

>>> Просмотр (768x1365, 410 Kb)

 , ,

poshat ()

220 вольт, Luci, OpenWRT и сильно кастомная хардваря

Собственно, приспичило сделать себе на даче сделать для небольшой нагрузки розетки, которые можно включать/выключать/ребутить с компа. Покопавшись в хламе откопал релешки, тайни2313, и старенький wl520gu, куда вполне себе можно залить OpenWRT. Все это я укомплектовал парой самодельных печаток, щедро покрытых полиуретаном, и запихнул в пластиковый короб, который на аллюминиевых уголках уходит под полку, и становится вообще невидим. От него до розеток все идет в коробах. Итого, в коробе присутствуют: Блок реле, винтовая колодка для разводки 220 вольт, плата с attiny2313, 9-вольтовый блок питания (кишки оного). Пятивольтового не оказалось под рукой. зато валялся самопальный ненужный dc-dc настраиваемый на LM2596, его я туда и воткнул. Так же там сидит роутер. USB гнездо я отпаял, и поставил туда хаб. С боку я влепил гнездо под плавкий предохранитель (рыжее, советское).

У чипа brcm47xx, который стоит в wl520gU есть неприятный баг в кремнии, из-за которого нельзя работать с 1.1 usb девайсами - все повисает после пары транзакций. Говорят, проблема из-за того, что какой-то там клок неправильный идет на 1.1. Потому я поставил 2.0 хаб (под рукой оказался только самопальный брейкаут хаба Fe1.1s, который собирал для тестов этой микросхемы, сильно привередливая, как оказалось, работоспособность очень здорово зависит от положения развязки по питанию). Хаб делает TT (transaction translation) и бага успешно обходится.

Собственно, внутрь 2313 зашивается vusb стек и три строчки кастомного кода, уложился в 1700 байт из 2кб, а на хосте начинается шаманство. Так как писать под каждый проект заново комманд-лайн утилиту на С задалбывает, я заюзал lualibusb, и написал вот такой костыль: https://github.com/nekromant/lunartool он берет на себя рутину типа матчинга по vid/pid, разруливания случаев нескольких устройств, парсинг комманд-лайн опций и прочую рутину. А сам же код добавляется в виде аплетов вот такого содержания: https://github.com/nekromant/lunartool/blob/master/applets/pw-ctl.lua и это превращается в простую утилиту командной строки. Так как в самом OpenWRT активно юзается lua для LuCi, оверхед был минимальным, и я уместился в 3300 кбайт из 4х мегабайт флеша. Заниматься любовью с extroot совершенно не хочется, ибо гемор при обновлениях. Достаточно залогиниться по ссх, и вуоля:

pw-ctl --on=1
pw-ctl --off=4
pw-ctl --reboot=1

Ну и в виде последнего изыска, я наваял небольшой апликейшн для LuCi чтобы можно было щелкать питанием через веб гуй. Собственно он, и страшненький код его и представлены на скриншоте. LuCi с его cbi штукой оказался очень приятной и удобной. Жалко только документирован сам cbi не особенно хорошо, приходится в сырцы подглядывать.

В планах заменить хаб на более цивильный, выпилить dc-dc и блок 220-->9 вольт и заменить на один блок 220-->5.

Вот и все, осталось только смонтировать до конца.

>>> Просмотр (3000x1080, 495 Kb)

 , , , ,

AiFiLTr0 ()

Микро-серверная

Сегодня установили шкаф, в котором соорудил микро-серверную.

Итого имеется:

- Toshiba Satellite A40 на котором крутится Убунту 11.04. Так как петли вылетели, решено было монитор вывести на дверцу шкафа для вывода всякой полезной инофрмации. На данные момент стоят скринлеты часов и погоды. Ноут ремотно управляется по ssh/RDP/веб-клиентом Трансмиссии. Шары с NAS подключены по nfs.

- Promise Smartstore NS4300n в котором стоят 4 диска WD 750Gb RE2 в двух RAID1 массивах. Шары раздаются по ftp/smb/nfs

- Buffalo WHR-G54S с OpenWRT. Кастомная прошивка стоит по причине того, что у прова Инет по PPPoE плюс внутренние сервера.

В квартире наконец то стало тихо по ночам. :-)

>>> Просмотр (1339x2897, 343 Kb)

 , , , ,

Mr_Alone ()