LINUX.ORG.RU

Какое ядро вы используете?

 


0

1
  1. 4.0-4.6518 (47%)

    ********************************************************************************************************************************************************************************************************************************************************************************************************************************

  2. Версия ядра меня не особо волнует287 (26%)

    *********************************************************************************************************************************************************************************

  3. Стабильное ядро самой последней версии279 (26%)

    ****************************************************************************************************************************************************************************

  4. 3.1-3.19212 (19%)

    **********************************************************************************************************************************

  5. Самосборное ядро83 (8%)

    ***************************************************

  6. 2.6-3.039 (4%)

    ************************

  7. Стороннее ядро на одном из этих (pf, liqorix и т.д.)38 (3%)

    ***********************

  8. Старше версии 2.629 (3%)

    *****************

  9. Нестабильное ядро самой последней версии29 (3%)

    *****************

Всего голосов: 1514, всего проголосовавших: 1094



Проверено: beastie ()

Зависит от того, где я его использую. Для рабочих машин, серверов — LTS; для домашних и офисных машин — последнее релизное. Патчсет дистровый (гентушный), или ванильное, никаких извращений.

r3lgar ★★★★★ ()

Добавьте: Стабильное ядро самой последней версии

Очевидно же, свежайший stable с kernel.org, самый явный вариант, но ты его не указал, чем ты думал?

l-_-l ()

Плохой опрос. Надо разбить то, что до 2.6.32 и с него.
Ибо там совместимость glibc дропнута.
Ну и содомию 'старше 2.6' убрать

mittorn ★★★★★ ()

Самосборное ядро

А оно типа версий не имеет?

Стороннее ядро на одном из этих (pf, liqorix и т.д.)

То есть, внезапно от применения патча версия меняется, и это другой пункт?

А если и патч применил и собрал сам (как обычно и делается), сразу три отмечать? И при этом ещё и версия особо не волнует…

Наркоманский какой-то опрос. Не так давно был более внятный с адекватными вариантами. Ну да без версий. Ну так версия и меняется в репозитории и на kernel.org, и обновляется…

Psych218 ★★★★★ ()

ЯННП

Что есть «Стабильное ядро самой последней версии»? Последнее ядро из репов дистра? Дык оно может быть 3.1-3.19 (стабильный Debian) и 4.0-4.6 (Ubuntu), например.

Radjah ★★★★★ ()

Ну ок…

4.0-4.6

Стабильное ядро самой последней версии

Версия ядра меня не особо волнует

Отметил эти три, потому что на данный момент они все соответствуют действительности.

Psych218 ★★★★★ ()

Если я использую стандартное ядро дистрибутива, какой вариант мне выбрать? Поддерживаю комментатора выше, наркоманский опрос.

unixnik ★★★★★ ()

Самосборное ядро — это как? Неопределенной версии?

a1batross ★★★★★ ()
Ответ на: комментарий от mittorn

Надо разбить то, что до 2.6.32 и с него.

А как же 2.4.37 и 2.6.18? Весьма попсовые вещи.

andrew667 ★★★★★ ()

uname -a

15.5.0 Darwin Kernel Version 15.5.0: Tue Apr 19 18:36:36 PDT 2016; root:xnu-3248.50.21~8/RELEASE_X86_64 x86_64

Как-то забыли вариант для тех, у кого ядра совсем нестандартные.

MuZHiK-2 ★★★★ ()

3.10.17 стабильная ветка Slackware

Hasek ★★ ()

Я использую последнее доступное в «стабильной» ветке генты, это ядро с версией в интервале 4.0—4.6, самосборное, с гентушными патчами. Мне что, три пункта выбирать?

XMs ★★★★★ ()

Что Марк Убунточке пошлёт - то и использую.

Ros ()

Версия ядра, наличие патчей и самосборность — пересекающиеся множества, в опросе сравнивают мягкое с тёплым (мультивыбор проблемы не решает). beastie, зойчем ты такое подтвердил?

sudopacman ★★★★★ ()
Последнее исправление: sudopacman (всего исправлений: 1)

я так понимаю, что «самосборное ядро» - это отдельная опция, не зависящая от версии. поэтому тыкнула его тоже. ибо какое бы ни было ядро, я подгоняю его под железку и нужды системы. ядра в стандартных дистрибутивах сильно тяжёлые, расчитанные на то, чтобы работало на любой машине. там много ненужного, а нужного иногда, наоборот, нет. иногда патчу ядро, если железяка сильно кривая и оно просто так не хочет работать. по работе тоже приходилось этим заниматься.

Iron_Bug ★★★★ ()

Версия ядра меня не особо волнует

ilinsky ★★★★★ ()

Ядро собираю сам. Из исходников последнего стабильного.
Собственно говоря, не особенно выкаблучиваясь - отключаю неиспользуемые на моих машинках модули и драйверы.

Pronin ★★★★ ()

Версия ядра меня не особо волнует

root@akamanah-PC:/home/akamanah# uname -r
4.4.0-25-generic

Т.е. стандартное дистрибутивное.

Akamanah ★★★★★ ()

Конечно же самое свежее из штабильных. Так Линус велит. Да и какой смысл пользовать старые ядра?

Lavos ★★★★★ ()

Версия волнений меня не особо ядрует

darkenshvein ★★★★★ ()
Ответ на: комментарий от Psych218

Наркоманский

Нет ничего более наркоманского, чем ЛОР.

ozzee ()

А вариант для пофигистов «Ядро из репозитория моей ОС»?

RiseOfDeath ★★★★ ()

Хорошо, что мультивыбор.

В цифрах —

4.0-4.6

По смыслу —

стабильное ядро самой последней версии

Причём не из репозиториев, а

самосборное

, а среди накладываемых патчей, помимо всего прочего, есть -pf.

intelfx ★★★★★ ()

Какое в генте приходит, то и стоит, я особо не заморачиваюсь

Satou ★★★★ ()

Последний стабильный дарвин, конечно. На убунте так же, но дистрибутивное.

Deleted ()

Версия ядра меня не особо волнует

3.1-3.19

Andrew ★★★ ()
Ответ на: комментарий от Lavos

Да и какой смысл пользовать старые ядра?

Чтобы сетевуха не отваливалась, например. Или какие там еще регрессии бывают. Предпочитаю всё кроме нужной прикладухи держать говном мамонта.

Andrew ★★★ ()
Последнее исправление: Andrew (всего исправлений: 2)
Ответ на: комментарий от sudopacman

А я откуда знаю? Не юзерское это дело над этим вопросом голову ломать. Линусу виднее. Выпустил свежак - значит надо обновлять.

Lavos ★★★★★ ()

Не знаю (не интересовался) какое ядро стоит в дома в фоторамке. (Sony с Android) больше дома нигде Linux нет, увы.

robot12 ★★★★★ ()
Ответ на: комментарий от Lavos

Да и какой смысл пользовать старые ядра?

бывает, что новое просто нельзя поставить на железку. она либо старая, либо слабомощная, либо патчить надо сурово под специфическое железо. всякий там эмбеддед иногда вообще 2.6 использует до сих пор. если дыр в безопасности нет, то и нет смысла ковырять. работает и работает.

Iron_Bug ★★★★ ()
Ответ на: комментарий от gnomosek

Смотря какая логика у автора. Традиционно старшая версия - та, у которой циферка выше. Но есть прослойка людей, для кого старший = более старый, и логика в этом тоже есть :)

l0stparadise ★★★★★ ()

Голосовал за «не особо волнует». На данный момент - 4.4.что-то там. Размаскируют что-то новое - обновится само.

l0stparadise ★★★★★ ()

3.16 стандартное из дистрибутива.

Polugnom ★★★★★ ()

На mainline для отлова багов.

feanor ★★★ ()
uname -r
4.6.2-gentoo

Это должно быть два разных опроса. Мне подошли сразу три варианта: стабильное ядро последней версии, 4.0-4.6 (4.6 и есть же последняя стабильная, правильно?) и самосборное (или это версия такая? самосборная - это как?).

BattleCoder ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.