LINUX.ORG.RU

Сообщения troorl

 

[Android][перевод] Русская терминология,

Форум — Development

Нужно как-то адаптировать кусок западной документации по андроиду. Беда в том, что русскоязычных изданий почти нет, а в электронном виде - нет совсем. Все, что я нашел - это оглавление какой-то книги http://www.bhv.ru/books/full_contents.php?id=187679 и статьи на ibm.com

Поэтому, прошу вас помочь утрясти некоторые названия, а то читаю - и слезы из глаз льются рекой.

Activity - Активность?
Shared Preference(s) - Общие Настройки? Общие Предпочтения?
Listener - без понятия
Layout - Разметка?
Control - Виджет? Элемент управления?
View - Представление?
Screen - Экран?
Data persistence - Постоянство данных?
Framework - Фреймворк?

Проблема для меня неожиданная, потому что я никогда даже не думал о том, как все это должно переводиться. В то же время, не хочется строгать тупую кальку.

troorl ()

[Vala] Кому-нибудь удалось подружить Monodevelop и libafrodite?

Форум — Development

Собрал, скопировал в /usr/lib - нифига. Поставил пакет из natty - нифига. При открытии проекта на Vala в консоли появляется следующая строчка:

Cannot update Vala parser database because libafrodite (VTG) is not installed: http://code.google.com/p/vtg/

Пока мне в гугле не удалось найти никаких свидетельств, что у кого-то получилось лучше. Но разработчики говорят, что должно работать.

 ,

troorl ()

[Gtk] Как изменить курсор мышки над определенным виджетом?

Форум — Development

Допустим, есть виджет, любой. Как сделать, чтобы курсор мышки при наведении на него менялся? Пока у меня получилось сделать такой трюк только для окна. Судя по документации, для этого у виджета должно быть GdkWindow. У EventBox оно есть (по крайней мере, я так думал), даже get_has_window() возвращает true. Но само окно там null. В общем, я ничего не понимаю. Еще более странно, что при наведении на ссылки внутри Label, у которого, по идее, нет GdkWindow, курсор меняется.

troorl ()

[Gtk][Webkit] Сильно течет память при использовании WebView

Форум — Development

Все очень просто. С каждой загрузкой строки в WebView используемая процессом память растет. Уже делал тестовый прототип с зацикленной загрузкой больших строк, смотрел на Gwibber - да, течет. Лазил в свойства, отключал enable-page-cache, не помогает.
Есть идеи, что с этим можно сделать? Очевидно, оно зачем-то хранит все строки, которые в него загружаются.

troorl ()

[CSS] z-index не работает.

Форум — Web-development

Есть два элемента, которые перекрываются. Нужно, чтобы content перекрыл tri, а не наоборот. Но z-index не дает никакого эффекта. Проверялось в вебките и ФФ. Что посоветуете?

<div>
  <div class="tri">
  </div>
  <div class="content">
    some text
  </div>
</div>
	.tri {
		z-index: 0;
		position: absolute;
		width: 20px;
		height: 20px;
		background-color: brown;
		
	}
	.content {
		z-index: 2;
		background-color: red;
		margin-left: 10px;
	}
troorl ()

[Gtk] Как называется этот желтенький виджет?

Форум — Development

В некоторых приложениях есть такие желтые панели:
http://rghost.ru/1771588/image.png
http://rghost.ru/1771599/image.png

Это стандартный виджет? Если да, то как он называется?

troorl ()

Онлайновый UML-редактор без флеша

Форум — Development

Видел парочку таких, все страшные и неюзабельные. Если кто-то видел что-то лучше - просьба поделиться.

troorl ()

libsoup и принудительная аутентификация

Форум — Development

Как авторизовать сессию по запросу сервера, пишут везде. А вот как принудительно послать данные на аутентификацию? На тот случай, когда юзерам и анонимусам выдают разный ответ и аутентификация не обязательна.

troorl ()

[Gtk] Пропадает курсор в GtkTextView

Форум — Development

Есть у меня программа, в которой есть TextView. Была замечена странность: при установке ее из исходников, пропадал текстовый курсор в области ввода (только в TextView, в GtkEntry все хорошо). Но при этом та же программа, собранная из тех же исходников, НО установленная из deb-пакета, такой проблемы не имела.

После выхода новой версии курсора не видно и после установки из пакета. У меня совершенно нет идей на этот счет. Откуда может взяться такая странная проблема?

troorl ()

valadoc.org умер?

Форум — Development

Я в замешательстве и не знаю, что делать. Единственный, пусть и очень плохой, источник документации по vala, исчез. Что делать? К кому обращаться?

А может он не единственный и есть зеркала? Или он переехал, а мне забыли сказать?

 ,

troorl ()

[Gtk] Наложение одного виджета на другой

Форум — Development

Есть обычный виджет, который запакован в HBox. Мне нужно поверх него на какой-то позиции показывать другой виджет. Как это можно сделать? Я смотрю на GtkFixed, но мне пока не удалось сделать так, чтобы нижний виджет растягивался в своем HBox.

troorl ()

[Gnome] Размер значков в трее

Форум — Desktop

Что и как нужно сделать, чтобы в гномовском трее значки не увеличивались по мере увеличения толщины панели?

troorl ()

Сервис для локализации приложений

Форум — Development

Нужно что-то вроде https://translations.launchpad.net , только не такое запутанное и монструозное. Хочу просто залить на него po-шаблон и дальше переводить этот шаблон на разные языки совместно с другими людьми.

troorl ()

[PPA] Помогите сделать правильный deb-пакет

Форум — Development

Значит, все я сделал как положено, по debuild -kключ все собирается без проблем. Теперь мне надо собрать source package для заливки в PPA. Делаю debuild -kключ -S - все прекрасно, появляются все нужные файлы. Но вот это все потом не собирается, когда я делаю pbuilder build ../*.dsc. Оно долго шуршит, скачивает пакеты, что-то там развертывает, но в итоге выдает мне:

E: pbuilder-satisfydepends failed.
Если посмотреть чуть выше, то ему не нравятся зависимости, которые я указал в Build-Depends:
dpkg: dependency problems prevent configuration of pbuilder-satisfydepends-dummy:
 pbuilder-satisfydepends-dummy depends on debhelper (>= 7); however:
  Package debhelper is not installed.
 pbuilder-satisfydepends-dummy depends on valac (>= 0.7.3); however:
  Package valac is not installed.
 pbuilder-satisfydepends-dummy depends on libgtk2.0-dev (>= 2.12); however:
  Package libgtk2.0-dev is not installed.
 pbuilder-satisfydepends-dummy depends on python; however:
  Package python is not installed.
dpkg: error processing pbuilder-satisfydepends-dummy (--install):
 dependency problems - leaving unconfigured
Собственно, чего ему надо? Вот строчка из control-файла:
Build-Depends: debhelper (>= 7), valac (>=0.7.3), libgtk2.0-dev (>=2.12), python
Что здесь не так?

troorl ()

Ну пока...

Форум — Talks

Я не знаю, что сегодня сдохло в лесу, но это 100% было что-то жирное и вонючее. Что случилось с голландцами - фиг его знает, наверное то же самое, что и с португальцами, и с хорватами... Короче ваша сборная заслужено победила, показала классный футбол и все дела.

А поскольку я имел неосторожность рискнуть своим профилем, оставляю вас в качестве регистрата и разлогиниваюсь. Пока :(

>>>

troorl ()

[Слабо?]Если Россия сегодня пройдёт голландцев

Форум — Talks

Я разлогинюсь навсегда. А теперь хочу узнать, чем готовы рискнуть особо озабоченные визави.

>>>

troorl ()

Дайте инвайт на лепру

Форум — Talks

troorl @ ukr.net

по-хорошему прошу

>>>

troorl ()

2 lester_dev && lester

Форум — Talks

Вы по сути одно и то же? :)

>>>

troorl ()

[жж]Растительность в носу

Форум — Talks

Что вы делаете с волосами в носу? Стрижёте, выщипываете или что-то ещё?

ps. JB, я не стебусь, мне действительно интересно

>>>

troorl ()

Постапокалиптика

Форум — Talks

Что вы считаете эталоном жанра? Фильмы, книги. И не обязательно "пост-".

>>>

troorl ()

RSS подписка на новые темы