LINUX.ORG.RU

Вышла новая версия Geany

 , ,


0

2

18 июня разработчики представили новую версию легковесного редактора Geany — 1.22.

Некоторые из изменений:

  • Переделана поддержка тем. Старые темы и файлы для подсветки синтаксиса не совместимы с новой версией редактора.
  • Обновлен движок редактирования Scintilla до версии 2.29.
  • Полная поддержка PCRE-совместимых регулярных выражений для поиска и замены.
  • Добавлена поддержка синтаксиса для Objective-C от Elias Pschernig.
  • Возможность открытия сессии по умолчанию (если активирована соответствующая опция).
  • Исправлены ошибки в распознавании неформатированных строк (raw strings) в C/C++.
  • Улучшена поддержка встраиваемых в HTML типов данных.
  • Добавлены следующие переводы: арабский, индонезийский, литовский, монгольский, новонорвежский, словацкий.
  • Обновлены переводы.

Детальный список изменений можно прочитать в примечании к выпуску.

Изменение версии
Много пользователей обращало внимание разработчиков на то, что по их мнению номер версии не соответствует зрелости проекта. После непродолжительной дискуссии они решили переименовать версию 0.22 в 1.22.

>>> Скачать

>>> Подробности

★★★★★

Проверено: post-factum ()

Когда это был релиз? Предыдущая версия же 0.21

ms-dos32 ()

Ну, а говорили, что всё сделали, и развиваться уже некуда.

post-factum ★★★★★ ()

годно, хотя по мне они с kate на 90% копируют друг друга

alltiptop ★★★★★ ()

Замечательный редактор. Очень радует, что потихоньку продолжает развиваться.

eliriand ★★ ()

почему есть поддержка джаваскрипта а кофи скрипта нету

punya ★★ ()

Надо будет поставить попробовать. На работе привык к Notepad++.

Toll ★★ ()

норвежский с новым письменным стандартом

Никакой это не новый письменный стандарт, а «норвежский (nynorsk)». См. http://ru.wikipedia.org/wiki/Nynorsk

anonymous ()

Зачем оно нужно, когда есть емакс?

AiFiLTr0 ★★★★★ ()
Ответ на: комментарий от punya

потому что «кофи скрипт» не стандарт, не?

ZuBB ★★★★★ ()
Ответ на: комментарий от alltiptop

в кате есть один жырный минус — kdelibs

ZuBB ★★★★★ ()
Ответ на: комментарий от anonymous

извините, в норвежском языковедении не силен

ZuBB ★★★★★ ()
Ответ на: комментарий от ZuBB

в сабже есть минус гораздо жирнее — gtk

Reset ★★★★★ ()

Вышла новая версия Geany

пусть зайдёт обратно

lazyklimm ★★★★★ ()
Ответ на: комментарий от ZuBB

Не работает, но kdelibs+qt это нормальный _настраиваемый_ внешний вид + человеческие файловые диалоги.

Reset ★★★★★ ()

Ну нельзя же так с версиями - меня чуть дед Кондрат не посетил!

alex-w ★★★★★ ()
Ответ на: комментарий от frozenix

А, до него же еще GTK 3 не добралось, у вас все еще впереди

frozenix ★★★ ()

PCRE-совместимых регулярных выражений

perl-compatible regular expressions-совместимых регулярных выражений

перл-совместимых регулярные выражения-совместимых регулярных выражений

да это даже круче, чем CD-диски! или IT-технологии!

anonymous ()
Ответ на: комментарий от Reset

Не работает, но kdelibs+qt это нормальный _настраиваемый_ внешний вид + человеческие файловые диалоги.

на вкус и цвет фломастеры разные. ктото может и не гонится за блестящими перделками.

Последний раз файловые диалоги в кде видел в версии 3.5.x. Как они выглядят сейчас не знаю. Знаю что в хромиуме диалог очень даже ничего (но он вроде как самописный)

ZuBB ★★★★★ ()
Ответ на: комментарий от ZuBB

Настраиваемость и удобные файловые диалоги это уже «блестящие перделки»?

Reset ★★★★★ ()
Ответ на: комментарий от alltiptop

тем кто не пользуется кде-софтом ради kate нужно тянуть еще сотню метров кделиб

ZuBB ★★★★★ ()
Ответ на: комментарий от AiFiLTr0

Зачем оно нужно, когда есть емакс?

С ним уже не нужно заниматься нетрадиционной любовью, чтобы заставить понимать хоткеи в другой раскладке?

metar ★★★ ()
Ответ на: комментарий от Reset

для меня жтк-диалоги вполне удобны. если под настраивамостью вы имеете ввиду миллион тем, то мне както пофиг. я переключаю темы раз в году.

ZuBB ★★★★★ ()

Старые темы и файлы для подсветки синтаксиса не совместимы с новой версией редактора.

Заметил сегодня, долго матюгался на этих уродов, переделывая темы подсветки синтаксиса.

Улучшена поддержка встраиваемых в HTML типов данных.

Не знаю, но мне понравился диалог выбора цвета - помог в редактировании файла подсветки.

Eddy_Em ☆☆☆☆☆ ()

1.22

Кстати, не 1.22, а 0.21-2

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от ZuBB

Я не про темы, а про расположение тулбаров, значки на тулбарах, подписи, расположение панелек и прочее прочее прочее.

Reset ★★★★★ ()
Ответ на: комментарий от ZuBB

не знаю насчет стандартизации но мне для разработки нужен кофи скрипт. реализации его подсветки и автокомплита свободны. пойду фича реквест сделаю =)

punya ★★ ()
Ответ на: комментарий от ZuBB

Один раз стянул и ладно, если с интернетом не очень большие проблемы, как часто качаешь например фильмы или сколько у людей в среднем музыки на компе? Если с жирными файлопомойками люди жалуются на лишний вес библиотек кде, моно и прочего то это не иначе как психоз, который надо лечить.

alltiptop ★★★★★ ()
Ответ на: комментарий от ZuBB

извините, в норвежском языковедении не силен

Вам дело говорят, поправьте, пожалуйста. Этот язык принято переводить как «новонорвежский», хотя перевод не очень хорош. Раньше это называлось, если память не изменяет, Риксмол в противоположность «датскому» Букмолу.

Vudod ★★★★★ ()
Ответ на: комментарий от alltiptop

жирными файлопомойками

vv@crusader ~ $ df -h
Filesystem            Size  Used Avail Use% Mounted on
rootfs                 74G   67G  7,0G  91% /
/dev/root              74G   67G  7,0G  91% /
rc-svcdir             1,0M  100K  924K  10% /lib/rc/init.d
udev                   10M  240K  9,8M   3% /dev
none                  1,3G  482M  781M  39% /dev/shm
vv@crusader ~ $ 

а вообще да, вы правы. но иногда попадаются такие перфекционисты как я которые не хотят тянуть лишнего метра в систему если на это нет веской причины

ZuBB ★★★★★ ()

По теме --- очкнь рад за Geany. Удобный и адекватный редактор. Всегда на него возвращаюсь, хотя регулярно пользуюсь чем-то ещё. В kate не хватает горячих клавиш запуска, приходится мышью елозить в коммандную строку, что не удобно.

Vudod ★★★★★ ()

Отличный легкий редактор на gtk. Рад, что он живой

Guerin ()
Ответ на: комментарий от Vudod

после подтверждения редактировать новость возможности нету. по крайней мере у меня

ZuBB ★★★★★ ()
Ответ на: комментарий от metar

ты чо, в танке? в емакс 24 уже фсё работает. с разморозкой!

anonymous ()

Отлично.

[вброс]куда лучше чем неюзабельные vim и emacs[/вброс]

Debasher ★★★★★ ()

Поддержка тем? Не знал, что была.

С версией напугали, я уж решил, что антиквариатом пользуюсь.

Надеюсь, сделали выбор директории по умолчанию в поиске (нервирует, что он ставит текущую директорию и каждый раз приходится выбирать корень проекта)

ForwardToMars ()

Надо было им просто выпустить 1.0 и не париться. А то теперь первая цифра совсем потеряла смысл и люди станут говорить просто Geany 22, прочем и раньше уже так фактически было.

Vudod ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.