LINUX.ORG.RU

NetworkManager 0.9

 ,


0

1

Вышедшая накануне стабильная версия 0.9 NetworkManager стала важной вехой в разработке этого приложения для управления сетевыми соединениями в Linux.

Подготовив к релизу версию 0.8 в феврале этого года, разработчики заявляли, что версия 0.9 будет готова уже в марте, но не тут то было — официальный анонс состоялся лишь в конце августа, но зато версия 0.9 содержит большое количество изменений, в том числе и существенных, о которых подробнее далее.

Наиболее существенное и судьбоносное изменение — упрощение D-Bus API, которое привело к нарушению совместимости как API, так и ABI с предыдущими версиями.

С одной стороны, изменение API направлено на упрощение коммуникации с NetworkManager для сторонних приложений, в частности осуществляющих конфигурацию и мониторинг сетевых соединений. Как отмечено в руководстве по миграции с NetworkManager 0.8 на NetworkManager 0.9, преимущества от упрощения архитектуры с лихвой компенсируют затраты на обновление кода клиентов.

Однако с другой стороны, внесённые изменения требуют быстрой реакции со стороны разработчиков, использовавших этот API в своих проектах, чтобы не произошло неприятных курьёзов, когда в роллинг-релиз дистрибутивы придёт обновление до NetworkManager 0.9, а аплеты, виджеты и плагины, использовавшие D-Bus API NetworkManager, ещё не будут его поддерживать, что приведёт к массовым сбоям и жалобам.
Также очевидно, что нарушение совместимости API вынудит пользователей после обновления NetworkManager до версии 0.9 отказаться от приложений, использовавших API NetworkManager, но разработка которых была приостановлена или заброшена.

Подробно об изменениях в D-Bus API в вышеупомянутом руководстве по миграции.

Среди прочих изменений:

  • все соединения и конфигурация осуществляются теперь при помощи NetworkManager;
  • возможность хранения паролей в пользовательской сессии или NetworkManager'ом;
  • пароли теперь могут запрашиваться каждый раз;
  • поддержка быстрого переключения пользователей;
  • возможность установки ограничений на использование соединений для одного и более пользователей;
  • поддержка «802.1X Certificate subject matching» для большей безопасности;
  • требуется wpa_supplicant 0.7 или выше;
  • лучшая поддержка AP roaming с использованием nl80211;
  • поддержка мобильных широкополосных устройств Intel WiMAX;
  • поддержка GObject Introspection в libnm-glib и libnm-util;
  • новые аплеты для GNOME Shell и Ubuntu's Indicator.

Исходный код

>>> Подробности

★★★

Проверено: JB ()

У него уже есть curses-клиент? Там фиг разберешься в настройках из консоли.

vurdalak ★★★★★ ()

сколько пользовался этой поделкой, столько негативных эмоций от неё. но, может, виновата убунта, конечно.

pyometra ★★★★★ ()

>привело к нарушению совместимости как API, так и ABI с предыдущими версиями

Традиционно.

Deleted ()
Ответ на: комментарий от AlexCones

Да уже давненько. Только вроде бы оно во вкладке DSL.

h31 ★★★★ ()
Ответ на: комментарий от unikum

> В арчике уже есть.

Удваиваю, сегодня приплыло. :)

bsdfun ★★★★★ ()
Ответ на: комментарий от petyanamlt

"- Кто обисравься? - Невистка. - Та ее дома нема! - Та оттуда ветром несэ"

Как-то так рассуждаешь.

LongLiveUbuntu ★★★★★ ()

В Gnome 2.30 всегда норм работала. Много раз выручала, особенно, когда в инет надо было выйти с 3G-модема.

f0b ()

>поддержка быстрого переключения пользователей;

я джва года этого ждал

Turbid ★★★★★ ()

> Наиболее существенное и судьбоносное изменение — упрощение D-Bus API, которое привело к нарушению совместимости как API, так и ABI с предыдущими версиями.

Сразу в квотезы!

spacel0rd ()
Ответ на: комментарий от LongLiveUbuntu

О_о Как? Всю жизню настраивал ппой через pppoeconf и pppoe. Это можно сделать через NetworМанагер?

AlexCones ★★★ ()
Ответ на: комментарий от AlexCones

>>О_о Как? Всю жизню настраивал ппой через pppoeconf и pppoe. Это можно сделать через NetworМанагер?

ну да!

anykey_mlya ()

Md5-challenge уже заработал нормально? Или опять всё через wpa-supplicant делать?

Dragomir ()
Ответ на: комментарий от Dragomir

Если Вы про MD5-аутентификацию, то это есть уже более полугода.
У моего провайдера как раз такая проверка подлинности. Раньше запускал wpa_supplicant демоном из консоли, а потом подключался дефолтной записью «System eth0» (DHCP, без защиты).
Нынче зимой в какой-то обнове появилась рабочая MD5-аутентификация (раньше работало некорректно). Версия NM была 0.8. Собственно, сейчас именно ею и пользуюсь (ЕМНИП, 0.8.4).

carasin ★★★★★ ()

Это поделие уже научилось не опускать ethX, с которого поднимается pppoe?

thesis ★★★★★ ()
Ответ на: комментарий от thesis

Это как?
Раньше настраивал pppoe (ещё в Ф12) посредством nm-applet'а, всё отлично фурычило: и инет, и локалка.

carasin ★★★★★ ()
Ответ на: комментарий от carasin

С пару месяцев назад пробовал - опускало локалку при дозвоне.

thesis ★★★★★ ()

Со стандартными сетевыми конфигурациями сие чудо справляется неплохо. Но вот стоит создать бридж, как начинаются чудеса.

В результате, приходится это чудо вырубать нафиг, править ручками конфиги и по старинке запускать network :)

anonymous ()

На ЛОРе появился cut? O_o

madgnu ★★★★★ ()

не нужен!

Это мерзкое поделие не нужно, сколько пользуюсь не разу не было нормальной работы с wi-fi сетями, постоянно какие-то проблемы которые мешают заниматься работой, вместо чего приходиться заниматься их решением.

anonymous ()

Сколько я с ним на***лся в своё время...

Всегда если ставлю бубунту, то первым делом сношу это поделие и настраиваю по-кошерному.

Nao ★★★★★ ()
Ответ на: не нужен! от anonymous

> сколько пользуюсь не разу не было нормальной работы с wi-fi сетями, постоянно какие-то проблемы которые мешают заниматься работой, вместо чего приходиться заниматься их решением.

Вот-вот. Я поставил wicd и забыл NM как страшный сон.

Nao ★★★★★ ()
Ответ на: комментарий от pyometra

сколько пользовался этой поделкой, столько негативных эмоций от неё. но, может, виновата убунта, конечно.

В федоре не меньше.

Поэтому после установки системы NM идёт в первых рядах на йух вместе с mono.

vadiml ★★★★★ ()
Ответ на: комментарий от Nao

Где Вы глюки берёте? На обычных сетках, маршрутизаторах и 3Г-модемах работает на ура, начиная с Ubuntu 9.10 (не помню какая там венсия была, кажется 0.7).

vilisvir ★★★★★ ()
Ответ на: комментарий от thesis

Я правильно понимаю, что вы пытаетесь настроить проводное соединения? (PPPoE=Point-to-Point over Ethernet, right?)

carasin ★★★★★ ()
Ответ на: комментарий от adriano32

>Так на в общем то на оффсайте написано

Я не спорю, но странно, что главная фича по совместительству является багом.

spacel0rd ()

Только вчера опять мучался с ним на федоре, есть wi-fi точка доступа, все её видят, оффтопик видит, андроид видит, даже мертвый симбиан видит. Но NM то не такой как все, он то особенный, не видит, подключается только как к скрытой сети. Проблема не большая, терпеть можно, но таких мелочей набирается гора.

anonymous ()

А у меня он всегда работал и не припомню, чтобы подводил. Да, Убунта и Дебьян.

timur_dav ☆☆☆☆☆ ()
Ответ на: комментарий от vadiml

Поэтому после установки

системы NM идёт в первых рядах на йух вместе с mono.

Такая же фигня с убунту :D

pyometra ★★★★★ ()
Ответ на: комментарий от Nao

Nao

Всегда если ставлю бубунту, то первым делом сношу это поделие и настраиваю по-кошерному.

Я только думал поставить себе, но после того, как увидел, что эта ересь тянет polkit|consolekit, забыл про эту идею

do0dlez ★★ ()
Ответ на: комментарий от Nao

А я - наоборот - даже не знаю, как пришлось бы извращаться с беспроводными сетями, если б не NM/nm-applet. Коллега-вендузятнег люто-бешено фапает на эту тулзу с сожалением о том, что под вантуз аналога нет.

carasin ★★★★★ ()
Ответ на: комментарий от vadiml

А что у Вас в Федоре не заводится с NM? Да и mono вроде как по умолчанию не ставится (или, может, у меня это от того, что я кастомизирую устанавливаемые пакеты).

carasin ★★★★★ ()

man ifup man ifdown

anonymous ()
Ответ на: комментарий от Nao

> Я поставил wicd и забыл NM как страшный сон.

Поддерживаю. Wicd - хорошая штука.

cipher ★★★★★ ()
Ответ на: комментарий от Dragomir

Когда я отсылал им просьбу подправить вики на предмет настройки соединения в Федоре (в NM ещё не было нормальной поддержки MD5), они вроде как откликнулись. Но всё так и осталось только на словах.

carasin ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.