<!DOCTYPE html>
<html lang=ru>
<head>
  <link href='https://fonts.googleapis.com/css?family=Open+Sans:600&amp;subset=latin,cyrillic' rel='stylesheet'
        type='text/css'>
  <link rel="stylesheet" type="text/css" href="/tango/combined.css?20170704-2135">

<link rel="yandex-tableau-widget" href="/manifest.json" />
<meta name="referrer" content="always">

<script type="text/javascript">
  /*!
  * $script.js Async loader & dependency manager
  * https://github.com/ded/script.js
  * (c) Dustin Diaz, Jacob Thornton 2011
  * License: MIT
  */
(function(e,d,f){typeof f.module!="undefined"&&f.module.exports?f.module.exports=d():typeof f.define!="undefined"&&f.define=="function"&&f.define.amd?define(e,d):f[e]=d()})("$script",function(){function y(f,e){for(var h=0,g=f.length;h<g;++h){if(!e(f[h])){return E}}return 1}function x(d,c){y(d,function(b){return !c(b)})}function w(p,k,h){function c(b){return b.call?b():K[b]}function q(){if(!--d){K[e]=1,f&&f();for(var b in I){y(b.split("|"),c)&&!x(I[b],c)&&(I[b]=[])}}}p=p[D]?p:[p];var g=k&&k.call,f=g?k:h,e=g?p.join(""):k,d=p.length;return setTimeout(function(){x(p,function(b){if(G[b]){return e&&(J[e]=1),G[b]==2&&q()}G[b]=1,e&&(J[e]=1),v(!L.test(b)&&H?H+b+".js":b,q)})},0),w}function v(h,g){var b=N.createElement("script"),a=E;b.onload=b.onerror=b[z]=function(){if(b[B]&&!/^c|loade/.test(b[B])||a){return}b.onload=b[z]=null,a=1,G[h]=2,g()},b.async=1,b.src=h,M.insertBefore(b,M.firstChild)}var N=document,M=N.getElementsByTagName("head")[0],L=/^https?:\/\//,K={},J={},I={},H,G={},F="string",E=!1,D="push",C="DOMContentLoaded",B="readyState",A="addEventListener",z="onreadystatechange";return !N[B]&&N[A]&&(N[A](C,function u(){N.removeEventListener(C,u,E),N[B]="complete"},E),N[B]="loading"),w.get=v,w.order=function(f,e,h){(function g(a){a=f.shift(),f.length?w(a,g):w(a,e,h)})()},w.path=function(b){H=b},w.ready=function(f,d,h){f=f[D]?f:[f];var g=[];return !x(f,function(b){K[b]||g[D](b)})&&y(f,function(b){return K[b]})?d():!function(b){I[b]=I[b]||[],I[b][D](d),h&&h(g)}(f.join("|")),w},w},this);</script>

<!--[if lt IE 9]>
  <script src="/webjars/html5shiv/3.7.2/html5shiv.min.js" type="text/javascript"></script>
<![endif]-->

<script type="text/javascript">
  $script('/webjars/jquery/1.12.3/jquery.min.js', 'jquery');

  $script.ready('jquery', function() {
    $script('/js/plugins.js?20170704-2135', 'plugins');
    $script('/js/lor.js?20170704-2135', 'lorjs');
  });

  $script('/js/highlight.pack.js', 'hljs', function() { hljs.initHighlightingOnLoad(); });
</script>
<title>Oracle открыла код инструментария для создания контейнеров — Open Source — Новости</title>
<meta property="og:title" content="Oracle открыла код инструментария для создания контейнеров" >

<meta property="og:image" content="https://www.linux.org.ru/img/good-penguin.png">
  <meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@wwwlinuxorgru">
<meta property="og:description" content="Компания Oracle  открыла  три инструмента для создания изолированных контейнеров:  crashcart, smith и railcar. Smith написан на Go, а crashcart и railcar -- на Rust. Коды открыты под двойной лицензией: UPL (универсальная пермиссивная лицензия) и Apac...">
<meta property="og:url" content="https://www.linux.org.ru/news/opensource/13526785">

<link rel="canonical" href="https://www.linux.org.ru/news/opensource/13526785">

<link rel="Previous" id="PrevLink" href="/news/opensource/13524792" title="strace 4.18">
<link rel="alternate" title="Comments RSS" href="/news/opensource/13526785?output=rss" type="application/rss+xml">
<script type="text/javascript">
  $script.ready('lorjs', function() { initNextPrevKeys(); });
  
    $script('/js/realtime.js', "realtime");
    $script.ready('realtime', function() {
        startRealtimeWS(13526785, "/news/opensource/13526785", 13526868, "wss://www.linux.org.ru:9000/");
    });
  </script>
<link rel="search" title="Search L.O.R." href="/search.jsp">
<meta name="referrer" content="always">

<base href="https://www.linux.org.ru/">

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">
<meta name="viewport" content="initial-scale=1.0">
</head>
<body>
<div id="hd">
  <a id="sitetitle" href="/">LINUX.ORG.RU</a>

  <div class="menu">
    <div id="loginGreating">
      <div id="regmenu" class="head">
          <a href="https://www.linux.org.ru/register.jsp">Регистрация</a> -
          <a id="loginbutton" href="https://www.linux.org.ru/login.jsp">Вход</a>
        </div>

        <form method=POST action="https://www.linux.org.ru//ajax_login_process" style="display: none" id="regform">
          <input type="hidden" name="csrf" value="hvtNcChwJHGov9aMAAbz/w==">
<label>Имя: <input type=text name=nick size=15 placeholder="nick или email" autocapitalize="off"></label>
          <label>Пароль: <input type=password name=passwd size=15></label>
          <input type=submit value="Вход">
          <input id="hide_loginbutton" type="button" value="Отмена">
        </form>
      </div>

    <ul>
      <li><a href="/news/">Новости</a></li>
      <li><a href="/gallery/">Галерея</a></li>

      <li><a href="/forum/">Форум</a></li>
      <li><a href="/tracker/">Трекер</a></li>
      <li><a href="/search.jsp">Поиск</a></li>
    </ul>
  </div>
</div>
<div style="clear: both"></div>
<div id="bd">
<div class=messages itemscope itemtype="http://schema.org/Article">

<article class=msg id="topic-13526785">
<header>
    <div class="msg-top-header">
    <span itemprop="articleSection">
      <a href="/news/">Новости</a> —
      <a href="/news/opensource/">Open Source</a>
      </span>
      </span>
    </div>

    <h1 itemprop="headline">
      <a href="/news/opensource/13526785">Oracle открыла код инструментария для создания контейнеров</a>
      </h1>

    <p class="tags"><i class="icon-tag"></i>&nbsp;<a class=tag rel=tag href="/tag/oracle">oracle</a>, <a class=tag rel=tag href="/tag/%D0%BA%D0%BE%D0%BD%D1%82%D0%B5%D0%B9%D0%BD%D0%B5%D1%80%D1%8B">контейнеры</a></p></header>

  <div class="msg-container">

    <div class="fav-buttons">
        <a id="favs_button" href="#"><i class="icon-star"></i></a><br><span
              id="favs_count">0</span><br>
        <a id="memories_button" href="#"><i class="icon-eye"></i></a><br><span
              id="memories_count">1</span>
      </div>
    <div class="msg_body">
  <div itemprop="articleBody">
      <p>Компания Oracle <a href="https://blogs.oracle.com/developers/three-new-open-source-container-utilities">открыла</a> три инструмента для создания изолированных контейнеров:  crashcart, smith и railcar. Smith написан на Go, а crashcart и railcar&nbsp;&mdash; на Rust. Коды открыты под двойной лицензией: UPL (универсальная пермиссивная лицензия) и Apache 2.0.</p><p>
          &gt;&gt;&gt; <a href="https://blogs.oracle.com/developers/three-new-open-source-container-utilities">Подробности</a></p>
      </div>
<footer>

<div class="userpic"><img class="photo" src="/photos/150771:131126036.jpg" alt="" width=150 height=150 ></div><div class=sign >
  <a rel="author"itemprop="creator" href="/people/batya/profile">batya</a> <span class="stars"></span><br>
  <time datetime="2017-07-06T16:55:24.744+03:00" itemprop="dateCreated">06.07.2017 16:55:24</time><span class="sign_more">
  <br>Проверено: <a  href="/people/anonymous_incognito/profile">anonymous_incognito</a>
        (<time datetime="2017-07-06T17:05:44.561+03:00" itemprop="datePublished">06.07.2017 17:05:44</time>)
      </span>
</div>
</footer>

    <div class=reply>
          <div class="social-buttons">
            <a target="_blank" style="text-decoration: none"
               href="https://twitter.com/intent/tweet?text=Oracle+%D0%BE%D1%82%D0%BA%D1%80%D1%8B%D0%BB%D0%B0+%D0%BA%D0%BE%D0%B4+%D0%B8%D0%BD%D1%81%D1%82%D1%80%D1%83%D0%BC%D0%B5%D0%BD%D1%82%D0%B0%D1%80%D0%B8%D1%8F+%D0%B4%D0%BB%D1%8F+%D1%81%D0%BE%D0%B7%D0%B4%D0%B0%D0%BD%D0%B8%D1%8F+%D0%BA%D0%BE%D0%BD%D1%82%D0%B5%D0%B9%D0%BD%D0%B5%D1%80%D0%BE%D0%B2&amp;url=https%3A%2F%2Fwww.linux.org.ru%2Fnews%2Fopensource%2F13526785&amp;hashtags=%D0%BB%D0%BE%D1%80">
              <img src="/img/twitter.png" width=16 height=16 alt="Share on Twitter" title="Share on Twitter">
            </a>
          </div>
          <ul id="topicMenu">
          <li><a href="comment-message.jsp?topic=13526785">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>
            <li><a href="/news/opensource/13526785">Ссылка</a></li>
          </ul>
        </div>
      </div>
</div>
</article>

<script type="text/javascript">
  $script.ready('lorjs', function() {
    initStarPopovers();
  });
</script>
<div class="nav">
  <div class="grid-row">
    <div class="grid-3-1">
      <table>
        <tr valign=middle>
          <td style="padding-right: 5px">
              <a href="/news/opensource/13524792" rel=prev>←</a>
            </td>
            <td align=left valign=top class="hideon-phone">
              <a href="/news/opensource/13524792" rel=prev>
                strace 4.18</a>
            </td>
          </tr>
      </table>
    </div>
    <div class="grid-3-2">
    </div>
    <div class="grid-3-3">
      </div>
  </div>
  </div><div class="comment" id="comments" style="padding-top: 0.5em">

<div style="text-align: center; margin-top: 0.5em; margin-bottom: 1em; height: 91px" id="interpage-adv">
  </div>
  <script type="text/javascript">
    $script.ready('lorjs', function () {
      var ads = [
        {
          type: 'img',
          src: '/adv/miran-e3.gif',
          href: 'https://miran.ru/services/dedicated/?utm_source=linux.org.ru&utm_medium=banner&utm_campaign=dedicated'
        }
      ];

      init_interpage_adv(ads);
    });
  </script>

<article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13526825" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/101414:-82100397.jpg" width="150" height="150"></div><div class="msg_body message-w-userpic"><p>Ну зачем подтверждать новости если ТС поленился написать больше двух строк?</p><div class="sign"><a itemprop="creator" href="/people/subwoofer/profile">subwoofer</a> <span class="stars">★★★★★</span> (<time datetime="2017-07-06T17:11:07.268+03:00" itemprop="commentTime">06.07.2017 17:11:07</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13526785&amp;replyto=13526825">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/opensource/13526785?cid=13526825">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13526858" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/127056:405838115.jpg" width="149" height="145"></div><div class="msg_body message-w-userpic"><p>Go, Rust. Сейчас начнется.</p><div class="sign"><a itemprop="creator" href="/people/SyntaxError/profile">SyntaxError</a> <span class="stars"></span> (<time datetime="2017-07-06T17:25:45.477+03:00" itemprop="commentTime">06.07.2017 17:25:45</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13526785&amp;replyto=13526858">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/opensource/13526785?cid=13526858">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13526868" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/31557:1420231511.png" width="150" height="108"></div><div class="msg_body message-w-userpic"><p>Офигеть новости пошли, про три скрипта каких-то. Мельчаем.</p><div class="sign"><a itemprop="creator" href="/people/MuZHiK-2/profile">MuZHiK-2</a> <span class="stars">★★★</span> (<time datetime="2017-07-06T17:28:32.290+03:00" itemprop="commentTime">06.07.2017 17:28:32</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13526785&amp;replyto=13526868">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/opensource/13526785?cid=13526868">Ссылка</a></li></ul></div></div></div></article></div>

<div id="realtime" style="display: none"></div>

<div class="nav">
  <div class="grid-row">
    <div class="grid-3-1">
      <table>
        <tr valign=middle>
          <td style="padding-right: 5px">
              <a href="/news/opensource/13524792" rel=prev>←</a>
            </td>
            <td align=left valign=top class="hideon-phone">
              <a href="/news/opensource/13524792" rel=prev>
                strace 4.18</a>
            </td>
          </tr>
      </table>
    </div>
    <div class="grid-3-2">
      <a title="Новости - Open Source"
         href="/news/opensource/">
          Open Source</a>
    </div>
    <div class="grid-3-3">
      </div>
  </div>
  </div></div>

<section id="related-topics">
    <h2>Похожие темы</h2>

    <div id="related-topics-list">
      <ul>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/openoffice/6335249">Oracle передает код OpenOffice.org в руки фонда Apache</a> (2011)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/redhat/10547049">Red Hat открыл код Calamari</a> (2014)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/java/6070004">Gosu — язык программирования для JVM</a> (2011)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/opensource/4532260">Oracle остановила принадлежавший Sun проект Darkstar</a> (2010)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/proprietary/5225533">Oracle закрывает проект OpenSolaris</a> (2010)
            </li>
          </ul>
      <ul>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/opensource/7762788">Открыт исходный код Kylo</a> (2012)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/opensource/12268916">Исходный код JavaScript-движка ChakraCore выложен на GitHub</a> (2016)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/opensource/12882080">NetBeans передаётся в руки фонда Apache</a> (2016)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/talks/5414438">[патентосрач][Java RIP!!!]Google считает это некрасиво со стороны Oracle</a> (2010)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/java/7085246">Открыт исходный код UI компонентов JavaFX™</a> (2011)
            </li>
          </ul>
      </div>
  </section>
</div>
<footer id="ft">

<p id="ft-info">
  <a href="/about">О Сервере</a> -
  <a href="/help/rules.md">Правила форума</a> -
  <a href="/help/lorcode.md">Правила разметки</a><br>
  <a href="https://www.linux.org.ru/">https://www.linux.org.ru/</a>
</p>

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-2184304-1']);
  _gaq.push(['_setCustomVar', 1, 'Authorized', 'false']);
  _gaq.push(['_setCustomVar', 2, 'Style', 'tango']);
  _gaq.push(['_setSiteSpeedSampleRate', 10]);
  _gaq.push(['_gat._forceSSL']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = 'https://ssl.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

</footer>
</body></html>
