LINUX.ORG.RU

Re: kchmviewer 0.1

ну и английский тоже поддерживается :)

anonymous ()

Re: kchmviewer 0.1

Простой kchm както полутше будит... http://kde-apps.org/content/show.php?content=21837 он както более к kde прикручен чем это поделле

его лутше назвать QchmViewer а не KchmViewer....

но тоже неплохое...

anonymous ()

Re: kchmviewer 0.1

2Автор:
Наверное лучше использовать chmlib, который установлен в системе.
Вот патч

---CUT-HERE---
diff -Nutr kchmviewer.old/src/src.pro kchmviewer/src/src.pro
--- kchmviewer.old/src/src.pro  2005-04-13 23:28:13.000000000 +0400
+++ kchmviewer/src/src.pro      2005-04-18 21:42:02.395713168 +0400
@@ -35,8 +35,8 @@
            kchmtextencoding.cpp \
            froglogic_getopt.cpp \
            iconstorage.cpp
-LIBS += ../chmlib-0.35/src/.libs/libchm.a
-INCLUDEPATH += ../chmlib-0.35/src
+LIBS += /usr/lib/libchm.a
+INCLUDEPATH += /usr/include
 TARGET = ../bin/kchmviewer
 CONFIG += debug \
 warn_on \
---CUT-HERE---

А зависимости проверять менеджером пакетов.

anonymous ()

Re: kchmviewer 0.1

Отлично. Спасибо автору! То, что на KDE не слишком завязано - это даже плюс.

anonymous ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

Ну если КДЕ не нужно, то можно и xchm пользывать - нет необходимости qt держать в системе. А по сути - не хватает табов (не увидел на скриншотах) и очевидно kparts не поддерживается... Может имеет смысл слиться с kchm?

anonymous ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

Честно говоря, мне кажется что kchm все же получше будет(для KDE пользователей) - kio && kparts && мои фиксы для chmlib (кстати советую автору kchmviewer взять их, там много ошибок поправлено) && KHTML. Единственное в чем эта программа лучше - это search. Я обязательно сделаю это, но только после диплома :( А вообще идея объединить проекты не лишена здравого смысла, хотя не очень понятно что значит "объединить" в данном контексте? Можно взять ту или иную базу и совместно развивать ее.

bd ()
Ответ на: Re: kchmviewer 0.1 от bd

Re: kchmviewer 0.1

Ну под объединением я подразумевал не слияние сырцов, а слияние фич. Поиск это действительно хорошо, но интеграция с КДЕ тоже немаловажна. Поэтому думаю есть смысл сделать один отличный просмотрщик используя наработки и опыт авторов.

anonymous ()
Ответ на: Re: kchmviewer 0.1 от bd

Re: kchmviewer 0.1

Причем не обязательно брать за основу ту или иную базу - можно создать новую на основе опыта написания двух проектов, ведь, как говорится, нет предела совершенству :-)

anonymous ()

Re: kchmviewer 0.1

Правда проект на QT должен быть гибче... чтоб там был выдбор собрать с подержкой KDE и поиметь с этим дополнительные фичи и интеграцию с KDE...

и собрать только на основе QT пусть без kio.. и ещё какихто интеграшок... но вполне юзабельный...

anonymous ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

Скажите вот, а как этот kchm завести? Собираться - собирается, а файлы не открывает.Нажимаешь открыть - и ничего.chmlib установлен, да и он с собой его тоже несёт.Ебилдов для него нет.

Midael ★★★★★ ()

Re: kchmviewer 0.1

Автор:
Плз, Сделай другой скриншот не с уголовным кодексом. А то как то страшновато стало :))

Atlant ★★★★★ ()
Ответ на: Re: kchmviewer 0.1 от Atlant

Re: kchmviewer 0.1

Автора здесь нет! Я запостил новость -- наткнулся на релиз случайно на фрешмите. Автору пишите на адрес указанный на сайте.

anonymous ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

Запаришься его ставить.
FC3, вроде не старый дист, но kchmviewer завязан на новые библиотеки. qmake ентот.

[root@igor src]# rpm -ivh qmake-3.3.3-6.i486.rpm
error: Failed dependencies:
qt-devel < 6:3.3.2-3 conflicts with qmake-3.3.3-6.i486


[root@igor MyDownloads]# rpm -ivh qt-devel-3.3.4-0.fc3.0.i386.rpm
error: Failed dependencies:
qt = 1:3.3.4-0.fc3.0 is needed by qt-devel-3.3.4-0.fc3.0.i386
[root@igor MyDownloads]# rpm -Uvh qt-devel-3.3.4-0.fc3.0.i386.rpm
error: Failed dependencies:
qt = 1:3.3.4-0.fc3.0 is needed by qt-devel-3.3.4-0.fc3.0.i386
qt-devel = 1:3.3.3-8 is needed by (installed) qt-designer-3.3.3-8.i386
[root@igor MyDownloads]# ls *rpm
epiphany-1.4.4-4.i386.rpm epiphany-devel-1.4.4-4.i386.rpm qt-3.3.4-0.fc3.0.i386.rpm qt-devel-3.3.4-0.fc3.0.i386.rpm qt-devel-3.3.4-10.0.3.kde.i386.rpm
[root@igor MyDownloads]# rpm -Uvh qt-3.3.4-0.fc3.0.i386.rpm
error: Failed dependencies:
qt = 1:3.3.3-8 is needed by (installed) qt-devel-3.3.3-8.i386
qt = 1:3.3.3-8 is needed by (installed) qt-MySQL-3.3.3-8.i386
qt = 1:3.3.3-8 is needed by (installed) qt-ODBC-3.3.3-8.i386
[root@igor MyDownloads]# rpm -e qt-devel-3.3.3-8.i386
error: Failed dependencies:
qt-devel >= 1:3.3.3 is needed by (installed) kdelibs-devel-3.3.0-5.i386
qt-devel = 1:3.3.3-8 is needed by (installed) qt-designer-3.3.3-8.i386
[root@igor MyDownloads]# rmp -e kdelibs-devel-3.3.0-5.i386
bash: rmp: command not found
[root@igor MyDownloads]# rpm -e kdelibs-devel-3.3.0-5.i386
error: Failed dependencies:
kdelibs-devel >= 3.3.0 is needed by (installed) kdebase-devel-3.3.0-8.i386
kdelibs-devel is needed by (installed) kdenetwork-devel-3.3.0-5.i386
kdelibs-devel >= 6:3.3.0 is needed by (installed) kdepim-devel-3.3.0-2.i386
kdelibs-devel is needed by (installed) kdesdk-devel-3.3.0-1.i386
kdelibs-devel >= 6:3.3.0 is needed by (installed) kdevelop-3.1.0-2.i386
[root@igor MyDownloads]#

anonymous ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

> его лутше назвать QchmViewer а не KchmViewer....

Т.е. он, фактически, сделан для Qt, а не для KDE?
Это радует. Не люблю тяжелые desktop-среды, и больше предпочитаю Qt, чем Gtk.

VladimirP ★★★ ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

А зачем это надо, если в КДЕ и так chm конкуерор показывает?

anonymous ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

>Запаришься его ставить.

открой для себя apt4rpm или yum, ламо.

anonymous ()
Ответ на: Re: kchmviewer 0.1 от VladimirP

Re: kchmviewer 0.1

> Не люблю тяжелые desktop-среды, и больше предпочитаю Qt, чем Gtk.

Ну да, оставить от KDE только kdelibs как всегда религия не позволяет.

А про гораздо более приятный gnochm даже не вспоминают :)

AP ★★★★★ ()
Ответ на: Re: kchmviewer 0.1 от AP

Re: kchmviewer 0.1

> оставить от KDE только kdelibs

А на кой его оставлять, когда можно от KDE ничего не оставлять?

VladimirP ★★★ ()
Ответ на: Re: kchmviewer 0.1 от VladimirP

Re: kchmviewer 0.1

тебе 18690K жалко? выкинь порнуху и проапгрейдь свой гиговый винт

anonymous ()

Re: kchmviewer 0.1

Вообще интересно, с одной стороны kchmviewer открывает некоторые файлы, которые не позубам остальным viewer'ам, включая kchm. С другой стороны, в локали UTF8 не открываются файлы с русскими именами. Но само существование программы радует.

kenneth ★★★ ()

Re: kchmviewer 0.1

1. Зачем? При наличии-то kchm 2. Патч уже постили, так ещё пожелание - никаких статических линковок - это как минимум некошерно.

a1s2d3 ()

Re: kchmviewer 0.1

Штука перспективная, но глюкавая. 3/4 моих chm'ок просмотреть не смогла. Оглавление показывает нормально, а вот кроме стартовой страницы ничего отобразить не может, либо брехню отображает... Бум искать и фиксить - понравилась мне эта программулина :)

anonymous ()
Ответ на: Re: kchmviewer 0.1 от bd

Re: kchmviewer 0.1

от автора kchmviewer, всем сразу.

1. Табы там есть, их даже видно на скриншотах.

2. Интеграция с KDE будет - это лишь вопрос времени. Сегодня завершен переход на autoconf/automake, без которого это достаточно сложно. При этом обязательно останется и будет поддерживаться Qt-only версия, поскольку хотелось бы работать на handheld devices.

3. xchm неплох, но совершенно не дружит с русскими текстами. Проблемы с кодировкой, не показывает TOC и не ищет.

4. Программа изначально предполагалась для использования теми, у кого на машине УЖЕ стоит qt. Безусловно, это глупо - ставить Qt только для данной программы. Но при этом скорее всего у Вас стоит GTK, и Вы вполне можете собрать какой-нибуть chmsee, xchm или GnoCHM. Если же у Вас нет ни Qt ни GTK - видимо, Вам и эта вещь не особенно понадобится.

5. Не вижу смысла сливаться с kchm. Зачем?

6. (автору KCHM) сравнивал сорцы chmlib в двух проектах вручную. Изменения нашел незначительные, и только в lzx распаковке. Не вижу смысла их вливать до тех пор, пока мне не попадется валидный chm файл, который не разбирается chmlib без них.

> Правда проект на QT должен быть гибче... чтоб там был выдбор собрать с подержкой KDE и поиметь с этим дополнительные фичи и интеграцию с KDE...

так и будет.

7. Завязки на старые библиотеки уже исправлены в CVS версии. Новая выйдет через неделю, как из отпуска вернусь.

8. Добавлю опцию у конфигуры, чтобы собираться с системной chmlib. Этого не будет по умолчанию из-за невозможности проверить версию установленной libchm кроме как по filename.

anonymous ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

И еще. kchmviewer должен показывать ВСЕ .chm файлы, которые показывает виндовый hh. При этом во ВСЕХ файлах он должен правильно определять кодировку. Если это не так - шлите багрепорты.

(исключение - китайский язык. почему-то с ним пока проблемы)

http://kchmviewer.sourceforge.net

anonymous ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

Дейсвительно показывает те chm-ы, которые остальные вьюверы отказывались крутить!!!

kott ★★★★★ ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

Kchm рулит по любому - все имеющиеся у меня чмошки(числом несколько сот) отлично показывает... В то числе и весом по 50-60 мегакило. В чем руль изобретать велосипед?

anonymous ()
Ответ на: Re: kchmviewer 0.1 от anonymous

Re: kchmviewer 0.1

Потому что некоторым kde не в кайф... Если б kchm мог собираться как для kde, так и в "чистом виде", то было бы отлично. А так - слишком тесно завязано.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.