LINUX.ORG.RU

nginx 1.17.7

 


0

1

Состоялся очередной релиз в текущей mainline-ветке веб-сервера nginx. В ветке 1.17 идёт активная разработка, в то время как в текущую стабильную ветку (1.16) вносятся только исправления ошибок.

  • Исправление: на старте или во время переконфигурации мог произойти segmentation fault, если в конфигурации использовалась директива rewrite с пустой строкой замены.
  • Исправление: в рабочем процессе мог произойти segmentation fault, если директива break использовалась совместно с директивой alias или директивой proxy_pass с URI.
  • Исправление: строка Location заголовка ответа могла содержать мусор, если URI запроса был изменён на URI, содержащий нулевой символ.
  • Исправление: при возврате перенаправлений с помощью директивы error_page запросы с телом обрабатывались некорректно; ошибка появилась в 0.7.12.
  • Исправление: утечки сокетов при использовании HTTP/2.
  • Исправление: при обработке pipelined-запросов по SSL-соединению мог произойти таймаут; ошибка появилась в 1.17.5.
  • Исправление: в модуле ngx_http_dav_module.

>>> Changelog

★★★★★

Проверено: cetjs2 ()

Надо именовать как в Эппл: nginx 1.17.7 Mamut

anonymous ()
Ответ на: комментарий от nebularia

Nginx 1.17 Malamut :) Поправил, не благодари!

anonymous ()

Зонды от ФСБ уже засунули или следующего релиза ждать?

WitcherGeralt ★★ ()
Ответ на: комментарий от WitcherGeralt

Ты шапочку из фольги одень, она поможет.

anonymous ()

Где HTTP/3 и Quick? Нет его. Значит не интересно. И почему они никак поддержку единственного нормального протокола запилить не могут? Таки руки не оттуда растут, или просто чуваки в 20-м веке застряли?

lucentcode ★★★★★ ()

Уже с копирайтом рамблера?

gtk3 ★★ ()

Нафиг ненужон этот ваш нжиникс, lighttpd наше все

anonymous ()
Ответ на: комментарий от lucentcode
  1. QUIC, а не Quick

  2. Есть модуль от клаудфлера https://blog.cloudflare.com/experiment-with-http-3-using-nginx-and-quiche/ который сделали специально для возможности массового тестирования и обкатки. Он вполне функционален, если очень нужна поддержка HTTP/3 – можно юзать.

chaos_dremel ★★ ()

Как-то внезапно обновление вышло, особенно после недавних событий. Не знаю как вам, а мне он перестал внушать доверие.

anonymous ()
Ответ на: комментарий от anonymous

После недавних событий ты мне тоже перестал внушать доверие.

anonymous ()
Ответ на: комментарий от anonymous

Два чая с неизвестно чем этому подозрительному анонимусу !

Deleted ()
Ответ на: комментарий от WitcherGeralt

Главное чтоб зонды шли под лицензией GNU GPL

Deleted ()

Исправление: в модуле ngx_http_dav_module. Два года ждал

anonymous ()
Ответ на: комментарий от lucentcode

Этот UDP засунут по гланды в конце 2020, щас большинство браузеров даже не знают что это такое (я про мобилки)

menangen ★★★★★ ()

Оп, новый выпуск Rambler nginx!

anonymous ()
Ответ на: комментарий от WitcherGeralt

Они пока встраивают зонды от ЦРУ, поэтому фичи от ФСБ будут значительно позже

anonymous ()
Ответ на: комментарий от anonymous

Да откуда вы такие упоротые лезете? Бери исходники, делай аудит, собирай пакет и получай профит.

anonymous ()
Ответ на: комментарий от anonymous

Думаю минимум половина этих поехавших просто стебётся

MrClon ★★★★★ ()
Ответ на: комментарий от MrClon

Ты так говоришь, как будто это мало)

anonymous ()
Ответ на: комментарий от anonymous

Нас, сюда, привлекают такие как ты, очень «умные» люди, не способные пользоваться головой при написании комментариев

anonymous ()
Ответ на: комментарий от anonymous

Сколько же ошибок ты допустил в одном предложении.

anonymous ()
Ответ на: комментарий от anonymous

Только одну, я посчитал тебя умным

anonymous ()
Ответ на: комментарий от WitcherGeralt

да тебе уже все засунули… вытаскивай и иди на***

anonymous ()
Ответ на: комментарий от lucentcode

иди и сделай, у тебя, дэбила, же ***** тут

anonymous ()

Жив курилка :)

anonymous ()
Ответ на: комментарий от chaos_dremel

Только с BoringSSL? Они серьёзно? Кому нужна эта поделка, которой нет ни в одной приличной системе? OpenSSL прикрутить не осилили… Нет, я пожалуй подожду нормальную поддержку с нормальным OpenSSL.

lucentcode ★★★★★ ()
Ответ на: комментарий от menangen

Да, но десктопные последних версий уже умеют, а значит пора понемногу переходить на него, тем более что до эксплуатации в проде нужно ещё потестить это дело пару-тройку месяцев.

lucentcode ★★★★★ ()
Ответ на: комментарий от anonymous

Звёзды за болтливость дают, а не за скиловость. Да и ленив я что-то делать, тем более для кого-то. Я лучше ныть буду, что плохиши не сделали, авось за меня всё сделают. Видно, что вы тут недавно, или случайно проездом, если таких простых вещей не знаете :)

lucentcode ★★★★★ ()
Ответ на: комментарий от lucentcode

Он ведь ещё черновик, мало-ли как ещё изменится к релизу

MrClon ★★★★★ ()
Ответ на: комментарий от MrClon

Странно, что TLS 1.3 в nginx прикручивали постепенно, как раз с черновиков. Ещё были две не совместимых версии черновика, в результате тем кто тестил нужно было тестить на правильной версии OpenSSL с правильной версией черновика, выбранной в настройках браузера. Знаю подноготную, потому что тестил с ранних версий это дело, в результате имел зоопарки сборок nginx и версий браузеров для проверки работы с конкретной версией черновика. Могли бы и в этом случае также сделать.

lucentcode ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.