LINUX.ORG.RU

Релиз nginx 1.14.2 (исправления в стабильной ветке)

 ,


0

1

Состоялся минорный релиз nginx 1.14.2 исправляющий ряд ошибок в текущей стабильной ветке. Так-же внесено одно изменение.

  • Исправление: nginx не собирался gcc 8.1.
  • Исправление: nginx не собирался на Fedora 28 Linux.
  • Исправление: в обработке адресов клиентов при использовании unix domain listen-сокетов для работы с датаграммами на Linux.
  • Изменение: уровень логгирования ошибок SSL «http request», «https proxy request», «unsupported protocol», «version too low», «no suitable key share» и «no suitable signature algorithm» понижен с уровня crit до info.
  • Исправление: при использовании OpenSSL 1.1.0 и новее директиву ssl_prefer_server_ciphers нельзя было выключить в виртуальном сервере, если она была включена в сервере по умолчанию.
  • Исправление: nginx не собирался с LibreSSL 2.8.0.
  • Исправление: если nginx был собран с OpenSSL 1.1.0, а использовался с OpenSSL 1.1.1, протокол TLS 1.3 всегда был разрешён.
  • Исправление: при отправке сохранённого на диск тела запроса на gRPC-бэкенд могли возникать ошибки.
  • Исправление: соединения к некоторым gRPC-бэкендам могли не кэшироваться при использовании директивы keepalive.
  • Исправление: в рабочем процессе мог произойти segmentation fault, если использовался модуль ngx_http_mp4_module на 32-битных платформах.
★★★★★