LINUX.ORG.RU

Опубликовано обновление программы PonyProg

 ,


0

2

Портирована программа PonyProg для прошивки EEPROM и микроконтроллеров.

Из новшеств:

  1. Поддержка мультиязычности и переключения локали интерфейса «на лету»;
  2. Ускорен поиск информации при выборе микросхемы;
  3. Переработаны структуры программы для более простого расширения списка программируемых микросхем;
  4. Полностью переаботано и дополнено текстовой помощью окно прошивки FUSE/LOCK битов;
  5. Программа собирается с Qt версий 4.8 и выше, совместима с пятой веткой;
  6. Проект собирается с компиляторами, поддерживающими параметр c++0x и выше;
  7. Файлы перевода основаны на простых текстовых файлах для облегчения создания и тестирования новых локализаций энтузиастами, не имеющих опыта работы с Qt Linguist.

>>> https://github.com/lancos/ponyprog

anonymous

Проверено: jollheef ()
Ответ на: комментарий от hobbit

На каком железе она проверена и работает?

Она работает с консольными прошивальщиками. Например, avrdude. Конкретное железо нужно смотреть в документации к прошивальщику. А если вы о том, на каком железе запускается сама PonyProg, то так как она написана на Qt, то должна запускаться везде, где поддерживается Qt4.8 и выше.

Tuxman ()

Я думал, что PonyProg уже давно умерло, а оно оказывается ещё живо. Когда я начинал осваивать микроконтроллеры, то хотел собирать программатор PonyProg, но потом вместо него решил собрать специализированный программатор для PIC.

Теперь найти комп, на котором PonyProg будет работать --- это проблема. Отдельный COM-порт сейчас вымирает.

DarthVadimius ()
Ответ на: комментарий от DarthVadimius

Где про это написано? PonyProg всегда работал со своим оригинальным программатором SIProg или JDM.

Действительно, я ошибся. Спутал ее с другой программой. Когда-то у меня был диск с кучей (больше 10) разных прошивальщиков для AVR, и большинство похожи и работали с AVRdude и подобными.

Tuxman ()