LINUX.ORG.RU

Объявлено о прекращении поддержки Debian 5.0 Lenny

 , ,


0

0

Шестого февраля, спустя три года после выхода Debian 5.0, прекращён выпуск обновлений безопасности для этой версии дистрибутива. Пользователям был предоставлен срок в один год для обновления до текущего стабильного выпуска 6.0 (Squeeze).

Обновление до 6.0 может быть выполнено с помощью aptitude для большинства конфигураций, и, в определённой мере, с помощью apt-get. Как всегда, обновление происходит безболезненно, но, тем не менее, рекомендуется ознакомиться с примечаниями к выпуску текущей стабильной ветки во избежание возможных проблем.

Последний выпуск Debian 5.0.10 ожидается в ближайшие дни.

>>> Подробности

★★★★★

Проверено: JB ()

Один сервер на нём остался. Придётся таки обновить. :(

Binary ★★★★★ ()

как-то поздно новость разместили. она уж давно стухла.

bernd ★★★★★ ()

Дебианщикам надо подумать, как время поддержки увеличить, а то даже в убунте 5 лет, а в дебиане 1-1.5 года выходит (или сколько там)

xorik ★★★★★ ()

Печально, однако. Очень не хочется трогать сервер, на котором все работает. Похоже, что пора с Дебиана переползать на Убунту ЛТС.

anonymous ()
Ответ на: комментарий от xorik

1 год с момента выпуска следующей стабильной версии, т.е в сумме каждый релиз поддерживается 3 года.

sniper21 ★★★★★ ()
Ответ на: комментарий от xorik

Дебианщикам надо подумать, как время поддержки увеличить, а то даже в убунте 5 лет, а в дебиане 1-1.5 года выходит (или сколько там)

1) Ubuntu — коммерческий дистрибтив с оплачиваемыми разработчиками.

2) Список пакетов с поддержкой от Canonical относительно невелик.

GotF ★★★★★ ()

Кайф! распоследний KDE 3.5.10 с распоследними фиксами безопасности! А я, дурак, Squeeze ставил и TDE на него.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Везучий. Мне вон кое-где ещё etch теребить приходится и портировать на него дровишки под новое железо.

imul ★★★★★ ()

Чёрт..один сервак таки есть на Ленни, надо срочно обновляться :)

pento ★★★★★ ()

всего три года???! Дебиан уже не торт.
Уйду-ка на арчик, там поддержка обновлений безопасности куда дольше.

darkshvein ☆☆ ()

«Со времен» вуди, ленни был первый «настолько удачный» :)

Jetty ★★★★★ ()

Стареем. Я помню, как мы ждали Sarge, а вот уже и Lenny с поддержки снят :(

Xellos ★★★★★ ()
Ответ на: комментарий от pento

А зачем сразу прямо торопиться обновляться? Работает же... ну и что, что обновления не будут выходить...

BattleCoder ★★★★★ ()

Слишком маленький срок поддержки.

blackst0ne ★★★★★ ()
Ответ на: комментарий от BattleCoder

BattleCoder

А зачем сразу прямо торопиться обновляться? Работает же... ну и что, что обновления не будут выходить...



Вам наплевать на обновления безопасности?

blackst0ne ★★★★★ ()

при прекращении поддержки просто прекращают выпуск обновлений безопасности или и репозитории отключают?

pyometra ★★★★★ ()
Ответ на: комментарий от blackst0ne

Слишком маленький срок поддержки.

Покажи мне другой полностью некоммерческий дистр с сопоставимым числом пакетов в официальном репозитории, имеющий более длительную поддержку.

GotF ★★★★★ ()
Ответ на: комментарий от pyometra

Только прекращается выпуск обновлений.

GotF ★★★★★ ()
Ответ на: комментарий от blackst0ne

Ну вот будет новость об очередном решете - будет и повод обновиться.

BattleCoder ★★★★★ ()
Ответ на: комментарий от BattleCoder

«Новость» может быть в виде абузы от хостера, про то что вы рассылаете тонны спама.

myhand ()
Ответ на: комментарий от BattleCoder

Обновления безопасности как бы хочется получать...

pento ★★★★★ ()

У меня в Lenny было 12309 во все поля. А в Squeeze нету. Так что не жалко.

Polugnom ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu

да, мне почему-то казалось, что и у десктопов тоже 5 лет было, просто эта фраза первая нагуглилась

autonomous ★★★★ ()

Патрик для 8.1 до сих пор обновления делает, а ей уже 10 лет.

dm1024 ★★★ ()
Ответ на: комментарий от xorik

Дебианщикам надо подумать, как время поддержки увеличить, а то даже в убунте 5 лет, а в дебиане 1-1.5 года выходит (или сколько там)

Уже неделю хочу про это большой большой пост написать, но, во-первых, не понимаю, зачем, а во-вторых - лень. Но напишу. :)

deb ()
Ответ на: комментарий от dm1024

Сравнил поддержку полутора пакетов и нескольких тысяч.

GotF ★★★★★ ()
Ответ на: комментарий от GotF

Сравнил поддержку полутора пакетов и нескольких тысяч.

Ну да, лучше не поддерживать несколько тысяч пакетов, чем поддерживать полтора.

dm1024 ★★★ ()
Ответ на: комментарий от dm1024

Лучше Патрику забросить ненужную слакварь насовсем.

Fanta ()
Ответ на: комментарий от darkshvein

Ты в Арчике используешь старые релизы? Это ж /0. Ах да, там релизы то есть вообще?

Deleted ()
Ответ на: комментарий от geekless

А иначе о чём речь? Какой там срок поддержки если роллинг во все поля? :}

Deleted ()
Ответ на: комментарий от Deleted

иначе о чём речь?

По-моему, речь о толстотроллинге darkshveinа :}

geekless ★★ ()
Ответ на: комментарий от Deleted

Арчик и сервер помойму немного опасно, хотя у самого большое желание сервер поставить на арче, но буду дожидаться апреля

Sky4eg ()

три года - маловато будет!

Лично у меня на 5 дебиане серверов не осталось, но вот к примеру среда виртуализации proxmox VE имеет стабильную версию на базе debian 5, а версия на базе 6 дебиана еще в бете.

jekader ★★★★★ ()
Ответ на: комментарий от GotF

Да хотя бы tzdata поддерживалась, да некоторые критичные вещи, было бы уже хорошо.

deb ()

А разве в Debian нет проекта долгосрочной поддержки сообществом, как, например, openSUSE Evergreen?

BMX ★★☆ ()
Ответ на: комментарий от BMX

А разве в Debian нет проекта долгосрочной поддержки сообществом, как, например, openSUSE Evergreen?

Как хорошо бы было, если бы в Debain был такой проект...

deb ()
Ответ на: комментарий от BattleCoder

BattleCoder



Ну вот будет новость об очередном решете - будет и повод обновиться.


Не совсем понял логику.
Если оставаться на 5.0, то даже после выхода новости об уязвимости Вы не сможете обновиться, т.к. security updates не выпускаются для 5.0.
Если же Вы имеете ввиду вариант, когда нужно будет мигрировать на 6.0 для устранения уязвимости, то это рискованный подход, т.к. перед миграцией нужно удостовериться, что всё пройдёт удачно и всё будет работать как и прежде. А осуществлять это в то время, когда существует уязвимость и её нужно оперативно прикрыть - неправильно.

blackst0ne ★★★★★ ()
Ответ на: комментарий от GotF

GotF

Покажи мне другой полностью некоммерческий дистр с сопоставимым числом пакетов в официальном репозитории, имеющий более длительную поддержку.


Альтернатива: rhel или rhel-based.

Да, в основном репозитории пакетов меньше. Поэтому приходится подключать сторонние репозитории, типа epel, percona, icu или другие, в зависимости от производственной необходимости.

blackst0ne ★★★★★ ()
Ответ на: комментарий от blackst0ne

полностью некоммерческий дистр

rhel или rhel-based

x/0 + ln(-x^2) = ?

А если серьёзно. то для многих серверов 3 года --- вполне пристойный срок. Плохо, что 3 года получается, если ставить сразу после выхода, а если ставишь за пару месяцев до выхода следующего, получается куда хуже.

Что касается Убунты, то это не лучший вариант: число поддерживаемых пакетов там совсем невелико и полноценно работать 5 лет всё равно не получится, если только вы не проспонсируете нужные вам пакеты сами.

Vudod ★★★★★ ()
Ответ на: комментарий от Vudod

Что касается Убунты, то это не лучший вариант: число поддерживаемых пакетов там совсем невелико

Для universe обновления всё равно приходят.

deb ()

Придется обновляться. До сих пор на рабочей машине ленни на 2.6.26-2-686

ymn ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.