LINUX.ORG.RU

Вышел Debian 6.0 Squeeze

 ,


0

2

Вышел новый стабильный выпуск одного из старейших дистрибутивов Linux — Debian 6.0 Squeeze. Основные изменения:

  • Инфраструктура Debian:
    • backports.org теперь является частью основного проекта (backports.debian.org).
  • Структура ОС:
    • переработан установщик;
    • dash теперь устанавливается по умолчанию и является обязательным;
    • используется новый загрузчик GRUB 2, старый GRUB доступен в пакете grub-legacy;
    • загрузка ускорена с помощью insserv и параллельного запуска служб на основе их зависимостей;
    • в dpkg добавлена поддержка компрессии xz, проведены оптимизации по ускорению работы с базой данных, а также произведена отвязка от perl;
    • соответствие стандартам FHS 2.3 и LSB 3.2;
    • полностью свободное ядро Linux без закрытых и несвободных прошивок (перенесены в non-free);
    • более 10 000 новых пакетов — теперь общее число пакетов достигло 29 000 (собраны из 15 000 пакетов с исходными кодами), около 60% пакетов обновлены, некоторые пакеты были удалены;
    • в качестве технического обзора в дистрибутив включены два ядра FreeBSD, работающие с пакетами Debian: kfreebsd-i386 и kfreebsd-amd64.
  • ПО, включённое в выпуск:
    • ядро Linux 2.6.32 с поддержкой ext4 и KMS;
    • GNOME 2.30 с некоторыми частями GNOME 2.32;
    • KDE 4.4.5;
    • Xorg 7.5;
    • OpenOffice 3.2;
    • Python 2.6.6;
    • Samba 3.5.5;
    • Tomcat 6.0.28.

>>> Подробности

★★★★★

Проверено: svu ()

Ответ на: комментарий от AX

Сам то понял что сказал? =)
Debian 1993 год выпуска, туча пакетов, туча архитектур, туча левых дистров (привет убунта).
Что этому может противопоставить Arch? Толпу плохо учащихся школьников кричащих, - Вендокапец! - А?

redkot ()
Ответ на: комментарий от GotF

скрины на самом деле у Вас негодны, на мой вкус

anonymous ()

Скачал нетинсталл, надо опробовать.
В очередной раз немного запутался в этом нагромождении дисков Дебиана, немного неочевидно сделано.

Valeg ★★★ ()
Ответ на: комментарий от icecat

Показатель Archевода, своих мыслей нет, повторяет за другими.
И толст, просто супер толст.

redkot ()
Ответ на: комментарий от redkot

особенно смешно твоя реплика выглядит в силу того, что я не арчевод ни разу, лол

icecat ()
Ответ на: комментарий от icecat

> я не арчевод ни разу, лол

Считай «арчевод» синонимом «школоло».

tailgunner ★★★★★ ()
Ответ на: комментарий от redkot

о, ты поставил дебиан и почувствовал себя законченной целостной личностью? бывают же такие задроты, лол

icecat ()
Ответ на: комментарий от neocrust

То сообщение удалили, отвечу здесь. Наутилусом.

Nxx ★★★★★ ()
Ответ на: комментарий от elipse

>И что там путанного ?

Я тыкнул скачать CD и увидел пару десятков исошников, в недоумении вспомнил об нетинстале.

Valeg ★★★ ()
Ответ на: комментарий от icecat

И это все, что ты можешь сказать? Начинаю сильно сомневаться в твоих интеллектуальных способностях.

redkot ()
Ответ на: комментарий от redkot

не всё, но тебе пока этого хватит

Начинаю сильно сомневаться в твоих интеллектуальных способностях

лучше в своих посомневайся, ибо у тебя в голове такая же помойка, что и в дебиановских репах, лол

icecat ()

Скорее бы этот дебиан закопали, зоопарк не нужен. Убунту наше всё.

anonymous ()
Ответ на: комментарий от Valeg

Ну обычно нужно первых 4...5 CD или один первый DVD.
Все просто.

elipse ★★★ ()
Ответ на: комментарий от redkot

продолжай защитывать сливы, деточка, даже когда вздумаешь обновить тестинг и половина пакетов не приедет из-за поломанных зависимостей, лол

icecat ()
Ответ на: комментарий от icecat

>внезапно, нормальный дистрибутив - это и есть RR-дистрибутив
...сказал icecat, одетый в обтягивающую чёрную кожу и стегающий себя кнутом.

darkshvein ☆☆ ()
Ответ на: комментарий от darkshvein

не надо сидеть на лоре, если у тебя опухоль мозга, лучше оторвись по полной в реале, пока можешь

icecat ()

Хватит кормить тролля. Если он лопнет - нас всех забрызгает!

adepto ()
Ответ на: комментарий от adepto

>Если он лопнет - нас всех забрызгает!

Он уже весь тред забрызгал.

Pavval ★★★★★ ()

обновился десу ^_^

anonymous ()

А, кстати, в дебиане есть что-то типа backports, только наоборот? А то есть сервер, на нём много всего крутится, и есть одна мерзкая программа, которой нужен только php 5.2.

Хочется таки обновить (там много другого софта, которому обновление поможет), но сохранить конкретно старый пхп. Какие есть самые простые способы?

anonymous ()
Ответ на: комментарий от anonymous

Версии пакетов можно фиксировать.

Deleted ()
Ответ на: комментарий от anonymous

>одна мерзкая программа, которой нужен только php 5.2.

Видимо нет. Проще поковырять программу, и заменить в ней «= & » на «= » (можно даже автозаменой, забэкапив предварительно).

adepto ()
Ответ на: комментарий от Deleted

>Версии пакетов можно фиксировать.

Можно, но некоторые пакеты ведь могут не дать утянуть зависимости, которые не дадут обновиться чему-то ещё.

anonymous ()
Ответ на: комментарий от elipse

apt-get не нужен. Я бы его выпилил бы к чертям и юзал исключительно aptitude вообще.

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от anonymous

Можно, но некоторые пакеты ведь могут не дать утянуть зависимости, которые не дадут обновиться чему-то ещё.

А ты хочешь несколько установленных версий программ сразу?

Deleted ()
Ответ на: комментарий от Deleted

>А ты хочешь несколько установленных версий программ сразу?

Нет, но просто там есть всякие libapache-mod-php5, который зависит от апача и всяких там libc, вдруг не получится обновить что-то из-за фиксированного пакета php.

Я так пишу, потому что не пробовал, естественно, что если попробую - всё станет ясно. Просто вдруг кто знает более простые способы.

anonymous ()
Ответ на: комментарий от LongLiveUbuntu

не, я предпочетаю программы с предсказуемым поведением, меньшего объема и с хорошим послужным списком. И apt-get этому соответствует.

Понятно, что часть вины в размножении полчищ идиотов с убунту лежит и на Debian. Ну это уже издержки.

elipse ★★★ ()
Ответ на: комментарий от Deleted

>А ты хочешь несколько установленных версий программ сразу? в генте сие реально, да.

nevar ★★ ()
Ответ на: комментарий от nevar

в LFS ещё реальнее. да.
только такое дерьмо никому кроме гентушников не нужно же. да

system-root ★★★★ ()
Ответ на: комментарий от system-root

да, ибо Ъ-дебиан-овцы привыкли трахаться с дубовыми зависимостями, даже за подвиг это считают, лол

icecat ()
Ответ на: комментарий от icecat

да. Ъ-дебиан-овцы предпочитают трахатся. или заниматся сексом. или вести половую жизнь. как угодно.
а не USE флаги по ночам считать.

system-root ★★★★ ()
Ответ на: комментарий от system-root

пожалуй, внесу «считать юз-флаги по ночам» в цитатник слабоумных гентоненавистников, лол

icecat ()
Ответ на: комментарий от elipse

Да я с apt-get натерпелся уже просто, aptitude более комплексная утилита, удобнее же.

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu

А у меня нет проблем с apt-get, просто нет их года четыре уже.

aptitude - мухрыжат уже 11 лет, дали ей фору в релизах etch и lenny.
и как было она непредсказуемой, так она непредсказуемой и осталась.

aptitude - не может быть основным средством управления пакетами.
Избыточна для встроенных систем и серверов.
aptitude - полезна для любителей помоек, левых реп и не желающих разбираться в системе.



elipse ★★★ ()

Замечательно! Жду пополнения в unstable ветке. Пока, что там появился ffmpeg который ломает mplayer - придется подождать mplayer.

Nebuchadnezzar ★★★★ ()
Ответ на: комментарий от elipse

>и как было она непредсказуемой, так она непредсказуемой и осталась.

В чём её непредсказуемость?

anonymous ()

Дебилиан, форева!

anonymous ()
Ответ на: комментарий от LongLiveUbuntu

Дык, кривые репы это еще не основание иметь кривой пакетный менеджер для них.
Может для Ubuntu это и подходит.

elipse ★★★ ()
Ответ на: комментарий от icecat

зачем писать безсмысленные сообщения которые не несут смысла?
они никому не нужны.
тебе не лень?

system-root ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.