LINUX.ORG.RU

FreeBSD 11.3-RELEASE

 


2

3

Анонсирован четвёртый выпуск ветки stable/11 операционной системы FreeBSD — 11.3-RELEASE.
Двоичные сборки доступны для следующих архитектур: amd64, i386, powerpc, powerpc64, sparc64, armv6 и aarch64.


Некоторые из нововведений в базовой системе:

  • Компоненты LLVM (clang, lld, lldb и сопутствующие библиотеки времени выполнения) обновлены до версии 8.0.0.
  • Инструментарий для работы с файлами ELF обновлён до версии r3614.
  • OpenSSL обновлён до версии 1.0.2s.
  • в libzfs добавлен алгоритм параллельного (многопоточного) монтирования файловых систем (используется по умолчанию командой zfs mount -a, для монтирования в один поток необходимо установить переменную окружения ZFS_SERIAL_MOUNT).
  • loader(8) поддерживает geli(8) на всех архитектурах.
  • При записи в журнал завершения процесса указывается его идентификатор jail(8).

В портах/пакетах:

  • pkg(8) обновлён до версии 1.10.5.
  • KDE обновлён до версии 5.15.3.
  • GNOME обновлён до версии 3.28.

И многое другое...


Замечания к выпуску: https://www.freebsd.org/releases/11.3R/relnotes.html
Исправления: https://www.freebsd.org/releases/11.3R/errata.html

>>> Объявление



Проверено: Shaman007 ()

Ответ на: комментарий от mandala

Ты что то путаешь, это во FreeBSD из линукса тащат ZFS. ФС кстати была кем разработана, напомнить? Ну и память ест, сама довольно таки специфичная, мех.

Deleted ()
Ответ на: комментарий от mandala

Ты лучше скажи чем тогда модно цеплять etx4?

Да, да, нормальные ФС есть, конечно. Как там с XFS дела кстать?

Deleted ()
Ответ на: комментарий от mord0d
# mount -t ext2fs /dev/ada1p2 /mnt
mount: /dev/ada1s2: Invalid argument

Что я недоделал? В dmesg валится:

WARNING: mount of ada1s2 denied due to unsupported optional features:
64bit

У меня GENERIC, ничего не пересобирал, ничего не компилял, работает без проблем.

Да у меня тоже.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 3)
Ответ на: комментарий от Deleted

Тормозная, специфичная ZFS

Которая никогда не позиционировалась как десктопная файловая система для тостеров и утюгов. У меня на сервере кроме ZFS ничего не используется, и даже просадок нет, а ты про какие-то тормоза на каком-то тостере/утюге.

и убогая UFS.

Надёжная и стабильная. Поддержка которой есть даже на допотопных версиях. А попробуй-ка ты примонтировать современную Ext4 где-нибудь в 2.14..2.16 с соответствующими версиями юзерспейсных библиотек.

Все на собственном опыте проверил.

А что, ты какой-то авторитетный источник, на который можно сослаться? Смешно.

Ну примерно так и есть.

Зоопарк софта от разных разработчиков, которые даже не контактируют, чтобы координировать свои действия. Ничего другого ожидать и не стоило.

mord0d ★★★★ ()
Ответ на: комментарий от Deleted

это во FreeBSD из линукса тащат ZFS

Если бы ты потрудился разобраться что там на самом деле: вопрос от какого угла плясать там, т.к. команда по запилингу ZFS в linux сейчас коммитит в сам апстрим ZFS чуть ли не больше всех остальных вместе взятых (как я понимаю, могу конечно ошибаться, вот прям пруф не дам скходу), не сохранял. Это, кстати, о ненужности её, ага. И наличию на линуксах кучи няшнызх фс – вот идиоты то, сколько труда вкладывают и в саму ZFS, и в то чтобы присобачить её к пингвину.

Ну и память ест, сама довольно таки специфичная, мех.

Так она не для малинок, уж извините, всем не угодишь.

кем разработана

Это вообще тут при чём? Вот где используется – та да, вот это важно.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от mord0d

а ты про какие-то тормоза на каком-то тостере/утюге.

Нисовые оправдания, спорить я даже пожалуй не буду.

Зоопарк софта от разных разработчиков, которые даже не контактируют, чтобы координировать свои действия. Ничего другого ожидать и не стоило.

FreeBSD даже запилить сами ZFS ниасили, как и DE, zram, etc))

Deleted ()
Ответ на: комментарий от mandala

Invalid argument

64bit

Соболезную.

Я монтировал Ext4, созданную ещё при ≈3.14, с тех пор они чего-то там накрутили, очевидно.

mord0d ★★★★ ()
Ответ на: комментарий от mandala

Это, кстати, о ненужности её, ага.

Я и не говорил что нинужно.

Так она не для малинок, уж извините, всем не угодишь.

Поэтому линукс поддерживает куча фс.

Это вообще тут при чём? Вот где используется – та да, вот это важно.

Забей, я не так понял твой коммент выше.

Deleted ()
Ответ на: комментарий от Deleted

https://www.opennet.ru/opennews/art.shtml?num=50543

Вот пруф про ZFS-for-linux:

Напомним, что в декабре прошлого года разработчики FreeBSD выступили с инициативой перехода на реализацию ZFS от проекта «ZFS on Linux» (ZoL), вокруг которого последнее время сосредоточилась вся активность, связанная с развитием ZFS. В качестве причины миграции была упомянута стагнация кодовой базы ZFS от проекта Illumos (форк OpenSolaris), которая ранее использовалась в качестве основы для переноса связанных с ZFS изменений во FreeBSD.

Ну как я и говорил, апстрим перехвачен просто. Ну и про недесктопность: во главе движухи создатель PC-BSD, это так, к слову.

mandala ★★★★ ()
Ответ на: комментарий от Deleted

Linux поддерживает зоопарк, да, вот теперь и нормальную взрослую zfs. )

mandala ★★★★ ()
Ответ на: комментарий от mandala

перетащить всякое абарахло, а не работать с ней

Я что-то прощёлкал этот момент. Тогда да, ext4fuse в этом плане посвежее будет, но я сомневаюсь в её стабильности.

mord0d ★★★★ ()
Ответ на: комментарий от Deleted

Ну у меня вот вчера опять молния шизанула по линии, хорошо не погорело ни чего как в прошлый раз. Проблемы только у меня с ней от аппаратных факапав, чисто софтово к ней претензий нет.

mandala ★★★★ ()

Как во FreeBSD с гибкостью? Можно ли накатить простенько старую xfce4 на 11.3 эту к примеру?

Deleted ()
Ответ на: комментарий от karaien

Двоичные сборки

Что это?

Как Вы заблудились, сэр, люди не обязаны же знать собачьих языков? )

anonymous ()
Ответ на: комментарий от Deleted

как раз 11.3

Можно ли накатить простенько старую xfce4 на 11.3 эту к примеру?

pkg install xorg xfce

сделать pw user mod user_name -L russian иначе крыса с ума сойдёт для руссиша (если он нужен, конечно)

% cat .xinitrc 
export LANG='ru.RU-UTF-8'
export LC_ALL='ru_RU.UTF-8'
exec startxfce4 --with-ck-launch

А это я боролся с крысиным терминалом, не хотел в русскую расскладку:

artem@nika:~ % cat .Xdefault 
Aterm*background: black
Aterm*foreground: #CECECE
Aterm*scrollBar: true
Aterm*loginShell: true
Aterm*saveLines: 3000
Aterm*transparent: true
Aterm*transpscrollbar: true
Aterm*tintingType: true
Aterm*tinting: #a07040
Aterm*shading: 60
Aterm*fade: 90
Aterm*title: aterm
Aterm*iconName: aterm
Aterm*font: -*-terminus-medium-*-*-*-*-*-*-*-*-iso10646-1
Aterm*boldFont: -*-terminus-medium-*-*-*-*-*-*-*-*-iso10646-1
Aterm*geometry: 80x24
Aterm*termName: aterm

вот ссылочка, но тут, имхо, избыточно, но просто для понимания что можно, вообще:

http://linuxoidblog.blogspot.com/2017/09/freebsd.html

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 2)
Ответ на: как раз 11.3 от mandala

Мне именно старая версия xfce4 нужна, до перехода на gtk3 %) Как ее накатить?

А это я боролся с крысиным терминалом, не хотел в русскую расскладку:

Хм, я на OpenBSD ставил, там вроде все без трабл было.

Deleted ()
Ответ на: комментарий от Deleted

В слаке я просто могу качнуть старые сурс пакеты из папки xfce/ и поставить их на билженье, потом установить. А в FreeBSD как можно?

Deleted ()
Ответ на: комментарий от Deleted

Какая то фигня из-за юникода, может решается красивее, говорят в половине иксовых терминалов норм, в другой половине вот такая бяка: не кракозябры, просто ввод не происходил при переключении на ru, в xterm тоже. Может пофиксили в 14 версии, но тут пока только 12-я.

mandala ★★★★ ()
Ответ на: комментарий от Deleted

А в FreeBSD как можно?

Просто порт поправить, чтоб не слетал при обновлении дерева – юзать subversion. Но мне лень, я пакет подожду)

mandala ★★★★ ()
Ответ на: комментарий от mord0d

Однако ж нет возможности в одном вайне запускать 32-битные и 64-битные приложения, со стимом из-за этого полный швах. Сам стим на 32 бита, игры на 64, вот и трахайся с этим.

unC0Rr ★★★★★ ()
Ответ на: комментарий от anonymous

Для нагруженных и ответственных Линукс пока не готов

ну-ну. иди это ребятам из топ1 расскажи, болезный!

anonymous ()
Ответ на: комментарий от Deleted

у фрибзд база (кернел+утилиты) фиксированная. а потом там же порты. из них можно накатить. вот qt4 они из них выкинули и goldendict теперь не поставить. 1 - 0 в пользу линукса.

crypt ★★★★★ ()
Последнее исправление: crypt (всего исправлений: 1)
Ответ на: комментарий от Deleted

Мне именно старая версия xfce4 нужна, до перехода на gtk3 %) Как ее накатить?

да вроде такая там и есть...

crypt ★★★★★ ()
Ответ на: комментарий от unC0Rr

Однако ж нет возможности в одном вайне запускать 32-битные и 64-битные приложения

Да, но это не то же самое, что утверждал болезный поциент по треду выше.

со стимом из-за этого полный швах

Стим не пашет, да. Но никто не обещал из FreeBSD делать игровую платформу.

Сам стим на 32 бита, игры на 64, вот и трахайся с этим.

Трахаться — это в GNU/Linux, а BSD — это работать.

mord0d ★★★★ ()

я с этого года начал «играться» с FreeBSD 12. засетапил на одно из рабочих мест, поднял билд сервер, виртуалки и т.п.

кстати, линуксовую версию heroes 3 запустил в линуксоляторе. не без глюков к сожалению.

есть явно хорошие места у этой ОС, а есть, где она просасывает по сравнению с линукс.

так что смысл спорить в треде. что-то работает хуже, что-то лучше. если бы было все однозначно лучше, то на линукс бы никто и не смотрел.

crypt ★★★★★ ()
Последнее исправление: crypt (всего исправлений: 1)
Ответ на: комментарий от mord0d

Но никто не обещал из FreeBSD делать игровую платформу.

смешно:) в sony напиши:)

Трахаться — это в GNU/Linux, а BSD — это работать.

это, конечно, полный фанатизм)

crypt ★★★★★ ()
Последнее исправление: crypt (всего исправлений: 1)
Ответ на: комментарий от Deleted

до перехода на gtk3 %)

Пока у себя не наблюдаю, хотя вот не рассматривал. ща…

gtk3-3.24.9                    Gimp Toolkit for X11 GUI (current stable version)

А, есть. Но это наверное лиса припёрла. Собирай из портов, там выберешь что поотрубать при сборке.

mandala ★★★★ ()
Ответ на: комментарий от crypt

1 - 0 в пользу линукса

В пользу какого дистрибутива? Много их? Именно одним из них ты пользуешься?

А так ни кто не запрещает самому собрать (я тут собирал как-то gnu-coreutil).

mandala ★★★★ ()
Ответ на: комментарий от crypt

Но никто не обещал из FreeBSD делать игровую платформу.

смешно:) в sony напиши:)

Это ты VarfolomeyKote4ka предложи использовать Sony PlayStation вместо компа.

это, конечно, полный фанатизм)

Есть немного. ☺

mord0d ★★★★ ()
Ответ на: комментарий от unC0Rr

Однако ж нет возможности в одном вайне запускать 32-битные и 64-битные приложения, со стимом из-за этого полный швах. Сам стим на 32 бита, игры на 64, вот и трахайся с этим.

unC0Rr, VarfolomeyKote4ka используйте sony playstation (на основе freebsd) для игр.

crypt ★★★★★ ()
Ответ на: комментарий от unC0Rr

Однако ж нет возможности в одном вайне запускать 32-битные и 64-битные приложения, со стимом из-за этого полный швах.

про wine что-то я такое читал, да. то ли к 12 релизу решили, то ли еще нет. а вот их вариант запускать линуксовые бинарники с определением налету 32 бита линукс или 64 бита линукс мне очень понравился. еще бы разобраться, как библиотеки билдить и подсовывать линуксолятору, так я бы GoG (использует древние библиотеки, которых в линуксе уже тоже нет) запускал не хуже, чем на самом Linux.

crypt ★★★★★ ()
Ответ на: комментарий от crypt

Ой да зачем мне playstation, просто изредка (раз в год-два) хочется посмотреть что-нибудь другое кроме привычных игр, а у меня ни винды, ни линукса нет.

unC0Rr ★★★★★ ()
Ответ на: комментарий от unC0Rr

ну меня лично то же самое всегда останавливает. но линукс у меня тоже с проблемами стим запускал. а вобще я ретро-чувак, меня скорее платформеры всякие интересуют и аркады.

если уж сильно прижмет - держи просто диск отдельно на полке для таких случаев.

crypt ★★★★★ ()
Последнее исправление: crypt (всего исправлений: 1)
Ответ на: комментарий от crypt

не вопрос.:) см. выше)

Жаль только, что из этого ничего не выйдет.

Во-первых от FreeBSD там не так много, во-вторых это всё же проприетарное решение, и фанатики-линуксоиды на это просто не согласятся.

mord0d ★★★★ ()
Ответ на: комментарий от anonymous

Ну не знаю, может мне еще и с железом не подфартило – но потери данных были несколько раз, две запоротых ФС вообще (нет суперблока, какая печалька, куда же он мог подеваться?). Как то надоело… Диска два, разные.

mandala ★★★★ ()
Ответ на: комментарий от mandala

может мне еще и с железом не подфартило

Возможно. У меня не сломалось ни одной ext3, ext4, XFS и Btrfs за десять лет, несмотря на неожиданные отключения по разным причинам. Только один раз потерял несколько открытых файлов на XFS с древним ядром очень давно.

anonymous ()
Ответ на: комментарий от mandala

Какая то фигня из-за юникода, может решается красивее, говорят в половине иксовых терминалов норм, в другой половине вот такая бяка: не кракозябры, просто ввод не происходил при переключении на ru, в xterm тоже. Может пофиксили в 14 версии, но тут пока только 12-я.

LANG ru_RU.UTF-8
MM_CHARSET UTF-8

Либо

LANG=en_US.UTF-8
MM_CHARSET=UTF-8

Прописывать в /etc/login.conf вроде предпочтительно,я у себя просто в ~/.xinitrc добавляю

export LANG=en_US.UTF-8
export MM_CHARSET=UTF-8

Laydakkk ()
Ответ на: комментарий от anonymous

Однако на ext4 такого не было на этих же железках. Ну вот посмотрим что будет на ZFS…

mandala ★★★★ ()
Ответ на: комментарий от Laydakkk

Это костыль именно для крысы, консоль руссифицирована через вот это:

pw user mod user_name -L russian

Больше ни чего во FreeBSD 11 и новее не нужно (емнип, в 10-ке тоже). Ну и клавиатуру прописать, если кириллицу еще и вводить надо, а не только читать.

Да, и костыль второй портяночный: только для эмуляторов терминала, в остальных иксовых прогах ввод уже работал (вывод естественно тоже).

я у себя просто в ~/.xinitrc добавляю

Ну я туда же засунул сначала, только этого не хватило именно для терминалов: xterm и xfce-terminal я проверил.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 4)
Ответ на: комментарий от mord0d

Во-первых от FreeBSD там не так много

как раз FreeBSD (ядро и база) там должно быть достаточно. а вот гнутового софта как раз нету.

crypt ★★★★★ ()
Ответ на: комментарий от crypt

как раз FreeBSD (ядро и база) там должно быть достаточно.

Мне кажется, своих проприетарных решений там куда больше, чем того, что осталось от базы.

а вот гнутового софта как раз нету

Ну и славно, GNU не засудит.

mord0d ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.