LINUX.ORG.RU

FreeBSD 11.3-RELEASE

 


2

3

Анонсирован четвёртый выпуск ветки stable/11 операционной системы FreeBSD — 11.3-RELEASE.
Двоичные сборки доступны для следующих архитектур: amd64, i386, powerpc, powerpc64, sparc64, armv6 и aarch64.


Некоторые из нововведений в базовой системе:

  • Компоненты LLVM (clang, lld, lldb и сопутствующие библиотеки времени выполнения) обновлены до версии 8.0.0.
  • Инструментарий для работы с файлами ELF обновлён до версии r3614.
  • OpenSSL обновлён до версии 1.0.2s.
  • в libzfs добавлен алгоритм параллельного (многопоточного) монтирования файловых систем (используется по умолчанию командой zfs mount -a, для монтирования в один поток необходимо установить переменную окружения ZFS_SERIAL_MOUNT).
  • loader(8) поддерживает geli(8) на всех архитектурах.
  • При записи в журнал завершения процесса указывается его идентификатор jail(8).

В портах/пакетах:

  • pkg(8) обновлён до версии 1.10.5.
  • KDE обновлён до версии 5.15.3.
  • GNOME обновлён до версии 3.28.

И многое другое...


Замечания к выпуску: https://www.freebsd.org/releases/11.3R/relnotes.html
Исправления: https://www.freebsd.org/releases/11.3R/errata.html

>>> Объявление



Проверено: Shaman007 ()

Ответ на: комментарий от mord0d

Мне кажется, своих проприетарных решений там куда больше, чем того, что осталось от базы.

решений чего? чего они там решают-то? они запускают морду для пользователя на железке. про морду мы говорить не будем - прикладной софт. а работу с железом ядро все делает. ну что они подхачили? usb3? работу с fs? видеодрайвер? да тот же драйвер nvidia и взяли (вы думаете, для кого nvidia их выпускает?). они, также как netflix, отрезали лишнее, подтюнили то, что есть.

crypt ★★★★★ ()
Ответ на: комментарий от Laydakkk

Ну я допинал до рабочего состояния, пока пусть так будет. Заведу 12-ю версию (у меня любой кадровый буфер на 12-м ядре при загрузке не поднимается, ни VT, ни SC, ни текст, ни VGA – GENERIC) – там разберусь уже. А может в 14-й крысе уже пофиксили, так как говорят в некоторых других ДЕ такой проблемой не пахнет.

mandala ★★★★ ()
Ответ на: комментарий от crypt

а работу с железом ядро все делает

А ты можешь гарантировать, что там немодифицированная FreeBSD под капотом? Я — нет.

ну что они подхачили

Могли своих модулей написать, в том числе для работы с видео, видеоускорение прикрутить.

они, также как netflix, отрезали лишнее, подтюнили то, что есть.

Не знаю, не знаю. Наверняка и у Netflix есть что-то своё, не обязаны же они отчитываться.

mord0d ()
Ответ на: комментарий от VarfolomeyKote4ka

Как во FreeBSD с гибкостью? Можно ли накатить простенько старую xfce4 на 11.3 эту к примеру?

Как пропатчить кде3 под freebsd? )

pihter ★★ ()
Ответ на: комментарий от captain_cat

Номер раздела man-страниц.

Он ведь не понимает, что такое man. Зачем ты это ему говоришь?

Odalist ★★★★★ ()
Ответ на: комментарий от mord0d

У меня самая надёжная криокамера! :3

Используй dsbmd/dsbmc.

Odalist ★★★★★ ()
Ответ на: комментарий от VarfolomeyKote4ka

Если я тебе назову видеокарту с драйверами под линукс на офф.сайте, поставишь мне дрова под нее во FreeBSD?

Проперитарные дрова от Nvidia на FreeBSD 12.0-RELEASE работают отлично. Даже лучше, чем на Linux.

Odalist ★★★★★ ()
Ответ на: комментарий от Odalist

Используй dsbmd/dsbmc.

Использую для съёмных носителей (autofs для этого не годится — юзерспейс проседает). Но он не предназначен для автомаунта NFS.

mord0d ()
Ответ на: комментарий от mord0d

Но он не предназначен для автомаунта NFS.

Ясно. Спасибо.

Odalist ★★★★★ ()
Ответ на: комментарий от VarfolomeyKote4ka

wine не поддерживает его

Опять чушь.

Давай пруфы.

https://www.freshports.org/search.php?query=wine

i386-wine-3.0.4_1,1            32-bit Microsoft Windows compatibility environment for 64-bit FreeBSD
i386-wine-devel-4.0.r1_1,1     32-bit Microsoft Windows compatibility environment for 64-bit FreeBSD
wine-4.0.1,1                   Microsoft Windows compatibility environment
wine-devel-4.11,1              Microsoft Windows compatibility environment
wine-gecko-2.47                Gecko Layout Engine for Wine (HTML support)
wine-gecko-devel-2.47          Gecko Layout Engine for Wine development branch (HTML support)
wine-mono-4.7.5                Mono .NET implementation for Wine development branch (HTML support)
wine-mono-devel-4.9.0          Mono .NET implementation for Wine development branch (HTML support)
winetricks-20190615

Если я тебе назову видеокарту с драйверами под линукс на офф.сайте, поставишь мне дрова под нее во FreeBSD?

А еще больше найдется того, что вообще поддерживается только под виндой. Но этим настоящих линуксоидов не смутить, WSL он и в Африке WSL, да?

и убогая UFS.

Такая убогая, что в бенчах обходит пингвиноФС https://www.phoronix.com/scan.php?page=article&item=freebsd-zol-april&amp... как стоячих? Ну-ну, не надо так явно заявлять, что виноград зеленый и вообще, не нужен :)

anonymous ()
Ответ на: комментарий от anonymous

https://www.freshports.org/search.php?query=wine

These packages are built and supported by the distros.

А еще больше найдется того, что вообще поддерживается только под виндой. Но этим настоящих линуксоидов не смутить, WSL он и в Африке WSL, да?

Поехавший, был разговор про Linux vs F-BSD, а не про Windows vs Linux vs F-BSD.

Такая убогая, что в бенчах обходит пингвиноФС

Угадай почему.

VarfolomeyKote4ka ()
Ответ на: комментарий от VarfolomeyKote4ka

Как во FreeBSD с гибкостью? Можно ли накатить простенько старую xfce4 на 11.3 эту к примеру?

Вообще-то это считается не гибкостью, а обратной совместимостью. И да, смотри фокус:

% grep COMPAT /usr/src/sys/amd64/conf/GENERIC 
options 	COMPAT_FREEBSD32	# Compatible with i386 binaries
options 	COMPAT_FREEBSD4		# Compatible with FreeBSD4
options 	COMPAT_FREEBSD5		# Compatible with FreeBSD5
options 	COMPAT_FREEBSD6		# Compatible with FreeBSD6
options 	COMPAT_FREEBSD7		# Compatible with FreeBSD7
options 	COMPAT_FREEBSD9		# Compatible with FreeBSD9
options 	COMPAT_FREEBSD10	# Compatible with FreeBSD10
options 	COMPAT_FREEBSD11	# Compatible with FreeBSD11
и
% pkg search -x "compat.*x"
compat10x-amd64-10.4.1004000.20181014 Convenience package to install the compat10x libraries
compat11x-amd64-11.2.1102000.20181014 Convenience package to install the compat11x libraries
compat4x-i386-5.3_11           Convenience package to install the compat4x libraries
compat5x-amd64-5.4.0.8.1_1     Convenience package to install the compat5x libraries
compat6x-amd64-6.4.604000.200810_3 Convenience package to install the compat6x libraries
compat7x-amd64-7.4.704000.201310.1 Convenience package to install the compat7x libraries
compat8x-amd64-8.4.804000.20151116 Convenience package to install the compat8x libraries
compat9x-amd64-9.3.903000.20170608 Convenience package to install the compat9x librarie
Теперь прошу показать что-то похожее для пингвина.

anonymous ()
Ответ на: комментарий от mandala

Пользуюсь в проде с LA > 0 с 2005 года без батарей аккумуляторов. За исключением посыпавшихся дисков, сбоев не было. Расскажи мне ещё что-нибудь про нежную XFS.

anonymous ()
Ответ на: комментарий от mord0d

Не знаю, не знаю. Наверняка и у Netflix есть что-то своё, не обязаны же они отчитываться.

Так ты это, смотри шире:) Они выступают на конференциях:)

А ты можешь гарантировать, что там немодифицированная FreeBSD под капотом? Я — нет.

Гарантировать нет, тем более, что я не сильно интересуюсь sony.

в том числе для работы с видео, видеоускорение прикрутить.

это решает драйвер nvidia. я исхожу из простой истины, что nvidia не делает свой драйвер для ничтожно малой доли пользователей обычной FreeBSD на десктопе. они это делают для комерческого продукта.

crypt ★★★★★ ()
Ответ на: комментарий от VarfolomeyKote4ka

https://www.freshports.org/search.php?query=wine

These packages are built and supported by the distros.

А сказать ты хотел что? Я ж тебе выхлоп пакетника запостил, знаток аглицкого.

Поехавший, был разговор про Linux vs F-BSD, а не про Windows vs Linux vs F-BSD.

Во-во, не знаешь что возразить, перейди на личности и съедь с темы.

Угадай почему.

Потому что простая, как два пальца. Отсутствие свистелок и перделок, оно как бы на быстроте работы сказывается, знаешь ли.
Хочешь, я тебе ссылок на бенчи фороникса 2010 брошу, где пингвиноФС не проигрывали так разгромно — почему-то тогда никто в морониксе не заикался «оно на самом деле неправильно работает!» :) ?

anonymous ()
Ответ на: комментарий от anonymous

Так все же как ставится? Я могу написать примерно как в Slackware будет:

export BUILD=oldxfce
echo $BUILD >> /etc/slackpkg/blacklist
wget -r ftp://mirror.yandex.ru/slackware/slackware-14.1/source/xfce
cd xfce
for i in *; do
	cd $i
	upgradepkg --installpkg $(sh *.SlackBuild | grep created | tr ' ' -f3)
done
Это мое костыль-решение, наверное можно и проще. Xfce4 поставится и не будет обновляться. А в FreeBSD?

VarfolomeyKote4ka ()
Ответ на: комментарий от Odalist

dsbmd/dsbmc разрабатывался как раз для монтирования съёмных носителей, но dsbmd работает с GEOM, а NFS девайсом не является, потому dsbmd его даже никогда не увидит.

mord0d ()
Ответ на: комментарий от anonymous

А сказать ты хотел что?

Смотри мой начальный комментарий.

Во-во, не знаешь что возразить, перейди на личности и съедь с темы.

Это ты съехал с темы когда начал про винду.

Отсутствие свистелок и перделок

Отсутствие возможностей.

VarfolomeyKote4ka ()

Сердечно поздравляю всех причастных и сочувствующих с релизом. Желаю продолжения развития и, традиционно, напоминаю, что для всех желающих совершенно бесплатно доступны RR в домене freebsd.rip (в разумных пределах конечно же), а для особых ценителей доступен https://freebsd.rip.

anonymous ()
Ответ на: комментарий от VarfolomeyKote4ka
pkg install -r OldRepo "старый пакет"
или 
pkg add /usr/localrepo/"старый пакет"
и потом
pkg lock "старый пакет"

старые репы:
http://pkg.freebsd.org/FreeBSD:8:amd64/latest/All/ http://pkg.freebsd.org/FreeBSD:9:amd64/latest/All/ http://pkg.freebsd.org/FreeBSD:10:amd64/latest/All/

или переходишь в /usr/ports, смотришь в svn log версии xfce, делаешь «svn up -r нужная-версия» и вперед, с песней, собирать.

anonymous ()
Ответ на: комментарий от anonymous

О, неплохо. Только если я поставлю пакет xfce4 (к примеру), то установятся же и зависимости, как их заpkg-лочить?

И можно ли собрать старый xfce4 с новыми либами?

VarfolomeyKote4ka ()
Ответ на: комментарий от VarfolomeyKote4ka

Смотри мой начальный комментарий.

wine не поддерживает его

Тебя еще раз ткнуть носом в выхлоп пакетника?

Это ты съехал с темы когда начал про винду.

Ты съехал с темы подменой изначального тезиса «поддержки железа нету» на «назову видеокарту с драйверами под линукс».
Очевидно, что по твоей логике, если я найду железяку, работающую под виндой, то могу сразу же сказать, что в линуксе «поддержки железа нету».

Отсутствие возможностей.

Список будет? По сравнению с EXTом?
Вот я например знаю — невозможность делать dump/restore с полным бэкапом всех аттрибутов и флагов. Правда, невозможно — только в пингвине, потому что тамкак поломали лет 12 назад, так и не починили.

anonymous ()
Ответ на: комментарий от VarfolomeyKote4ka

О, неплохо. Только если я поставлю пакет xfce4 (к примеру), то установятся же и зависимости, как их заpkg-лочить?

Зачем их лочить? Иерархия зависимостей для того и придумана, чтобы обновление (или необновление) было консиснентным.

И можно ли собрать старый xfce4 с новыми либами?

Этот вопрос каким-то образом относится к ОС, а не самому софту?

anonymous ()
Ответ на: комментарий от anonymous

Тебя еще раз ткнуть носом в выхлоп пакетника?

Я даже играл через wine в жта на FreeBSD.

то могу сразу же сказать, что в линуксе «поддержки железа нету»

Так оно и есть.

VarfolomeyKote4ka ()
Ответ на: комментарий от anonymous

Зачем их лочить? Иерархия зависимостей для того и придумана, чтобы обновление (или необновление) было консиснентным.

Если thunar зависит от libthunar и последняя обновится, то что случится с thunar?

Этот вопрос каким-то образом относится к ОС, а не самому софту?

Да. Можно или нет?

VarfolomeyKote4ka ()
Ответ на: комментарий от mandala

У меня, везде

Что там с виртуалками? Есть контейнеры? Что с дровами на NVIDIA и тирингом? Есть wine?

the_real_kinik ()
Ответ на: комментарий от the_real_kinik

фрибзд сейчас напоминает старый линукс

Что там с виртуалками?

есть bhyve для linux/windows.

Есть контейнеры?

есть jail, а вот в линуксе отмер openvz. видел в блоге, кто-то девелопил linux kernel в докер на фрибзд

Что с дровами на NVIDIA и тирингом?

драйвер официальный от nvidia. не лучше и не хуже, чем для других.

Есть wine?

да есть вроде.

вопрос не в том, что этого нет. а насколько это сопоставимо по фичам с линуксом и насколько больше нужно провести в command line.

crypt ★★★★★ ()

Пожалуй задам традиционный вопрос. Она уже умеет utf8 из каропки?

anonymous ()
Ответ на: комментарий от mandala

ты у нас как к wayland относишься?) не хочешь в галерею сделать скриншот со sway+wayland на freebsd?:)

crypt ★★★★★ ()
Ответ на: комментарий от pihter

Как пропатчить кде3 под freebsd? )

это было про kde2) но особенно хорошо звучало в онлайн вопросах для президента, если кто помнит)

crypt ★★★★★ ()
Ответ на: комментарий от crypt

Я к sway ни как не отношусь… Подумаю, может и потыкаю. (а wayland – мне без разницы, если оно не потребует пляски с бубеном, вокруг иксов я хотя бы плясать умею).

mandala ★★★★ ()

Консоль-то юникодную сделали, наконец?

gns ★★★★ ()
Ответ на: комментарий от gns

прям все так болеют за бедных бздунов… Да сделали-сделали давно, всё, не волнуйтесь уже.

mandala ★★★★ ()
Ответ на: комментарий от Laydakkk

Русификация в современном стиле.

В /etc/login.conf:

#
# Russian Users Accounts. Setup proper environment variables.
#
russian|Russian Users Accounts:\
	:charset=UTF-8:\
	:lang=ru_RU.UTF-8:\
	:tc=default:

Задаём класс пользователю:

# chpass имя_пользователя
или через vipw(8).

iZEN ★★★★★ ()
Ответ на: Русификация в современном стиле. от iZEN

И? Я же это описал. Крысе от этого ни тепло, ни холодно, да еще и эмуляторы колбасит до кучи (зато для консолекита всё искаропки, только ключ при запуске добавить).

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 2)
Ответ на: комментарий от mandala

да еще и эмуляторы колбасит до кучи.

Кстати,это на одной машине? Я на двух ноутах ни на 11 ни на 12 ветке такой проблемы не наблюдал.

Laydakkk ()
Ответ на: комментарий от Laydakkk

На одной. Вообще она не счастливая какая то… :D

mandala ★★★★ ()
Ответ на: комментарий от mandala

Я сам давний пользователь BSD, с прошлого века еще. У меня раз в пять (примерно) лет случается «подход к снаряду». Обещали в десятке сделать юникодную консоль по-умолчанию, и сделали в 10.2 что-ли, и то с приложением небольшого напильника. Опять притопы и прихлопы нужны?

gns ★★★★ ()
Ответ на: комментарий от gns

Ну именно с сонсолькой проблем нет уже в 11.x (c 11.0 использую без иксов, иксы вот поднял только на 11.3), у меня вот только с крысой было не много, но это уже крысиные приколы.

mandala ★★★★ ()

Готова ли?

Кто на десктопе пользует пара вопросов, как там с google-chrome, slack, telegram и spotify и pycharm?

ggrn ★★★★★ ()
Ответ на: комментарий от VarfolomeyKote4ka

Тормозная, специфичная ZFS

Нет, не так: современная, фичастая, гибко настраиваемая, чтобы работать даже на старых 32-битных ноутах с 768 МБ ОЗУ.

убогая UFS

Чуть ли не единственная из классических, олдскульных файлух, умеющая в снапшоты. По другим фичам (журналирование, чексуммы метаданных, расширенные атрибуты и пр.) паритет с конкурентами, по надежности сильно впереди.

danfe ()
Ответ на: комментарий от mandala

Не ради флейма. Скажите, как на BSD с поддержкой ноутов. На полном серьезе рассматриваю переход с Линукса - надоел он по самое не хочу со своими системд, пульсами и т.п. Просвета не вижу. Рассматривал gentoo - млин, она какая-то вся мегаифраструктурная, crux - пока не понял, бдзя нравится, но поскольку в полку уже давно только ноуты, хотелось бы понять, насколько все хорошо или плохо. Гугел приводит кучу старых и не актуальных линков.

zh_v68 ()
Ответ на: комментарий от zh_v68

https://wiki.freebsd.org/Laptops – тут не много инфы по поддержке.

А вообще пока не попробуешь – не узнаешь. С linux то проблемы до сих пор на лаптопах…

mandala ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.