LINUX.ORG.RU

Ubuntu 19.04 с Xfce 4.14 pre-release

 , ,


0

1

Это Ubuntu 19.04, на которую я поставил для теста Xfce 4.14 из PPA — https://launchpad.net/~xubuntu-dev/ archive/ubuntu/experimental

Готово практически полностью, за несколько недель не поймал ни одного значительного бага. xfwm4 допилили — теперь тиринга действительно нет. А вот оперативку теперь крыса кушает не меньше, чем кеды.

Тема gtk самодельная — благодаря oomox-gui это просто: https://github.com/themix-project/oomox

>>> Просмотр (1920x1080, 1405 Kb)

Ответ на: комментарий от Athor

Слушай, я просто пользователь, по большей части — скажи, как мне проверить то, что тебя интересует, а я отвечу.

Vsevolod-linuxoid ★★★★★ ()

А вот оперативку теперь крыса кушает не меньше, чем кеды.

Вот это поворот! За счёт чего? Что они с ней сделали?

th3m3 ★★★★★ ()
Ответ на: комментарий от VarfolomeyKote4ka

На gtk3 перевели.

Не должно так сильно из-за этого. Тут скорее дело в Ubuntu.

У меня сейчас Ubuntu 18.04 с Xfce - на старте жрёт чуть более 500 мб. А у него на скрине, почти 400 мб. Т.е. это даже меньше, чем сейчас в стабильной версии. Не вижу, чтобы как кеды жрало память.

th3m3 ★★★★★ ()
Последнее исправление: th3m3 (всего исправлений: 1)
Ответ на: комментарий от th3m3

Ну про gtk3 даже сами разработчики бугуртили. Но скорость точно упала, элементы не так управляются, много чего... Интересно, собирается ли с gtk2 еще?

VarfolomeyKote4ka ()

теперь тиринга действительно нет.

Значит, теперь Compton не понадобится?

th3m3 ★★★★★ ()
Ответ на: комментарий от RedMaun

у всех сейчас стоит по 16гб

У большинства максимум 8 Гб. Не мало людей, у кого и по 4 Гб.

th3m3 ★★★★★ ()
Ответ на: комментарий от th3m3

Я его и раньше не использовал, опции xserver решали. Но теперь и они не нужны, xfwm4 допилили.

Vsevolod-linuxoid ★★★★★ ()

А вот оперативку теперь крыса кушает не меньше, чем кеды.

Это в связи с чем?

А как общая производительность крыски в Убунту и Дебиане если сравнить?

deepforest ★★★ ()
Ответ на: комментарий от VarfolomeyKote4ka

На gtk3 перевели

Я тоже смотрю, что производительность с новыми версиями падает. На что можно перейти? Есть ли альтернативы? Неужели тайлинг или LXQT?

deepforest ★★★ ()
Ответ на: комментарий от th3m3

На gtk3 перевели.
Не должно так сильно из-за этого. Тут скорее дело в Ubuntu.

Да. Проверял, xfce на глаз точно тормознее в Убунту по сравнению с Дебианом

deepforest ★★★ ()
Ответ на: комментарий от deepforest

В Slackware можно любую версию без проблем собрать и сидеть на ней... Поэтому я лично буду сидеть на Xfce 4.12 %) А потом должны Gnome3 допилить, и смысла сидеть на чем то другом наверное и не будет.

VarfolomeyKote4ka ()
Ответ на: комментарий от deepforest

Если что, все хорошее из нового Xfce можно принести в Xfce 12, у меня например xfwm из git прямо, да, gtk3, но зато без tearing, еще catfish стоит.

VarfolomeyKote4ka ()
Ответ на: комментарий от deepforest

А ест как кеды. В принципе нет смысла выбрасывать Xfce4, оно же модульное! Заменить просто компоненты. Хотя на Debian это сложно будет, хм, ну тогда LXQT будет вариантом неким, если тебя устраивает она...

VarfolomeyKote4ka ()
Ответ на: комментарий от deepforest

Поиска нету в ФМ, gvfs, программ нужных, плагинов. Xfce 4.12 меньше кушает а делает больше.

VarfolomeyKote4ka ()
Ответ на: комментарий от VarfolomeyKote4ka

А где можно пощупать последнюю версию xfce? Или она полноценно еще не вышла?

deepforest ★★★ ()

С 19.04 лив-исо. Добавил ппа, установил. Но кажетцо, что установилась не 4.14. Как проверить точно?

deepforest ★★★ ()
Ответ на: комментарий от deepforest

4.14 не называется 4.14 до релиза. В этом PPA все пакеты 4.13 версий.

Ubuntu ставится не в режиме Debian-а, когда пакеты ставятся с репозиториев, а в режиме разворота изначального образа на диск — потому PPA нужно после установки добавлять.

Проверить правильность версии можно через вывод

apt-cache policy имя_пакета
Имена пакетов узнаешь в PPA, как и версии.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 2)
Ответ на: комментарий от deepforest

Рассказывай всё крайне подробно и в деталях. Никаких недоговорок по причинам «это очевидно», или «и так поймет», или «это не важно». В нормальном случае дотошность и впрямь не нужна, но ты — рукожоп, уж прости за прямолинейность. И я даже представить не могу, какую феерически странную фигню ты опять творил.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от kirill_rrr

Это у вас 4Гб, а у меня есть железки с 2Гб, 1Гб (и это основная!) и ещё один старичок с 512М.

Пень2/3 или Атлончик старенький? Любите страдать?

utanho ()
Ответ на: комментарий от Vsevolod-linuxoid

Рукожоп, жопоруку) скачал лив убунту(не xfce) зпустил, и на него ставил xfce, ставится 4.12 не смотря на ппа

А как на дебиан9 накатить 4.13?

deepforest ★★★ ()
Ответ на: комментарий от utanho

Основная это внезапно RPi3 B с гигом. Ещё ноут с 2Г, используется для работы. А из старого хлама в одном месте стоит старый атлончик с 512М на случай «не таскать ноут». Игровой ноут с 8Г памяти стоит не у дел, лениво восстанавливать винду на полетевшем диске.

Страдать я не люблю, но современный веб ненавижу сильнее и не собираюсь собирать под него специальную машину.

kirill_rrr ★★★★★ ()
Последнее исправление: kirill_rrr (всего исправлений: 2)
Ответ на: комментарий от VarfolomeyKote4ka

нету gvfs

Как нету? Так установи. Ведь PcManFM с ними работает...

Odalist ★★★★★ ()
Последнее исправление: Odalist (всего исправлений: 1)
Ответ на: комментарий от VarfolomeyKote4ka

Речь про lxqt.

Посмотрел зависимости в Дебиан. В зависмости входит и gvfs. Идет вместе с pcmanfm-qt.

Odalist ★★★★★ ()
Ответ на: комментарий от Odalist

Они взяли половину либ от kde, а другую от gnome? Лол. Неожиданно. Ну значит gvfs там есть.

VarfolomeyKote4ka ()

413 мб с открытым файловым менеджером вполне скромно для gtk3, учитывая, что всякие neofetch еще и завышают потребление.

Mate правда заметно меньше жрет, да и интереснее для домохозяйки, они и развиваются так, что даже заметную разницу видно 1.22.1 и 1.23.1.

One ★★★ ()
Ответ на: комментарий от VarfolomeyKote4ka

Да, да. Плюс работа с метаданными в GVFS может раскрыть некоторую информацию о содержимом зашифрованных разделов. Вот потому я и избегаю такого «удобства».

Odalist ★★★★★ ()
Ответ на: комментарий от deepforest

Я серьезно спросил. Изволь помогать помогать тебе или нечего тут делать.

Мы — не платная техподдержка, чтобы тебе сопли утирать, ясно? Хочешь ныть и доказывать, какой Linux сложный и какое дурное у него сообщество? Ты в детском саду, чтобы вместо дела истерики закатывать?

Я не телепат. Ты допустил ошибку — у меня всё работает, как и у тысяч пользователей PPA. Узнать, какую, можно _только_ из подробного отчета.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Какой отчет? Прописал ппа из шапки этой темы. Но когда делаешь apt install xfce4 устанавливается 4.12 Видмио тянет из обычных реп.

deepforest ★★★ ()
Последнее исправление: deepforest (всего исправлений: 1)
Ответ на: комментарий от deepforest

Как прописал (есть несколько вариантов)? На каком конкретно дистибутиве? Как ставил и ставил ли перед этим дистрибутив? Какие именно пакеты не той версии?

Vsevolod-linuxoid ★★★★★ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)