LINUX.ORG.RU

Галерея

Активные теги:

 , , , , , , , , , , , , , ,

Рабочий MaXX

Галерея — Скриншоты

Работа заключается в написании комментариев на ЛОРе.

MaXX Interactive Desktop это современная проприетарная среда рабочего стола, копирующая IRIX Interactive Desktop. Проект настолько процветает, что у него нет официального сайта, зато есть сайт подражателя.

>>> Просмотр (1920x1080, 1385 Kb)

 

GalleryPoster ()

Моя рабочая машинка

Галерея — Скриншоты

Вот наконец-то купил себе новый ноут. Долго выбирал из всевозможных вариантов, остановился на Lenovo ideapad 720S-13ARR с процессором AMD Ryzen 7 2700U, NVMe, Type-C и прочими прелястями жизни.

На скриншоте - powerlevel10k, улучшенная и ускоренная версия powerlevel9k, лучшего powerline-шелла для zfs, ну и несколько интересных плагинов которые позволяют разукрасить консоль подобно fish.

Справа выводятся модули:

  • текущий контекст и неймспейс Kubernetes
  • текущая ветка git

В качестве рутовой файловой системы - btrfs. Каждый вызов pacman содаёт снапшот и в любой момент можно в него загрузиться прямо из меню grub.

Ноут использую как дома, так и на работе. На работе подключаю его через Type-C док-станцию с двумя мониторами через displaylink, очень удобно. Очень порадовало наличие аппаратного шифрования NVMe-диска и возможность зарядки от пауэрбанка, а процессор AMD достаточно производителен и не подвержен уязвимостям Meltdown и Spectre.

Подробности:

>>> Просмотр (1920x1080, 1862 Kb)

 , ,

kvaps ()

FVWM. В продолжение олдскульных скриншотов

Галерея — Скриншоты

В последнее время что-то много скриншотов с олдскульными WM а-ля «привет из первой половины 90-х». Так что решил и я поддержать тенденцию.

На скриншотах FVWM 2.6.8 в Debian Testing. С прошлого скриншота мало что изменилось на самом деле. Управление по большей части осуществляется с клавиатуры, панель теперь гигантская и перекрывается окнами дабы не занимать место на экране зря. Находится она в отдельном слое и поднимается наверх и опускается обратно по хоткею.

Плоское оформление на волне олдовых настроений заменил на типичное псевдо-3D а-ля MWM, вернул всем окнам рамки и заголовки, хотя раньше их не было у максимизированных окон.

Обойку не дам, так как пулл обоек большой и скрипт мне ставит оттуда случайную раз в 30 минут.

В общем, ругайте.

>>> Просмотр (1366x1536, 788 Kb)

 ,

skiminok1986 ()

Void с evilwm — легкая и удобная система

Галерея — Скриншоты

Система

Void Linux установлена и настроена на нетбуке 10.1″ с 2 GB RAM и микропроцессором Intel Atom.
Я люблю Void за его следование философии Unix. Он очень просто устроен. Здесь нечему ломаться, потому что ничего лишнего нет. Разработчики сделали очень быстрый пакетный менеджер. Также быстрым является и родная система инициализации Runit. Всё просто, удобно и работает очень быстро.

Как оказалось, evilwm предоставляет все необходимое для управления окнами. Большие навороты не нужны. Вместе с консольным tmux/screen, в котором ты сам с легкостью настраиваешь расположение окон (панелей) как захочешь, – это лучший выбор для пользователей, которые привыкли к классическому управлению окон. Нет никаких панелей, значков и прочего хлама.

evilwm потребляет всего 3.8 Мб RAM из всей потребляемой оперативной памяти (56 Мб), а его клавишные бинды легко запомнить (Ctrl + Alt). Создание собственных хоткеев не предусмотрено, но меня вполне устраивают текущие. Если кого-то не будут устраивать, может воспользоваться xbindkeys. Также имеется псевдотайлинговое поведение (Ctrl + Alt + {Y,U,B,N}, Ctrl + Alt + =, Ctrl + Alt + X). При желании можно легко отредактировать исходный код. Очень интересный WM, несмотря на то, что им мало кто пользуется.

Скриншот

ОС: любимый Void Linux.
WM: evilwm.
Музыкальный плеер: mpd + ncmpcpp.
Эмулятор терминала (консоли): rxvt.
Шрифты: Pragmata.

За кадром

Текстовый редактор: vim (+ vim-latex + vim-pandoc + nou.vim).
Табличный процессор: sc-im.
Файловый менеджер: nnn.
Видеоплеер: mplayer + youtube-viewer.
Почтовый клиент: mutt.
IRC-клиент: irssi
RSS-клиент: newsboat.

>>> Просмотр (1366x768, 48 Kb)

 ,

PerfectReactor ()

В поиске легковесного, или TWM в минимальном Дебиане

Галерея — Скриншоты

Дело вот такое. На одной из своих машин совершил фатальную ошибку. Теперь уже не помню какую, но и не важно. Главное, что делал бэкапы важных данных, так что, систему снес нафиг, и сделал чистую установку. Не долго думая поставил TWM, потому, что люблю олдскул. После неторопливого курения мануала, TWM настроил под себя. А ведь отличный менеджер окон этот TWM. Делает то, что от него требуется, и ничего другого. Отличный пример того, что называется философия Unix

Пишите программы, которые делают что-то одно и делают это хорошо.

Код давно не меняется, новомодные, никому не нужные функции не вводятся. Это то, что меня восхищает. Так что, не жалею, что снес систему с i3wm.

Теперь по порядку. Что тут имеем? Все тот же набор cli программ (irssi, mpg123, mocp). Также установил Ranger, но думаю, что зря. Крайне редко им пользуюсь. Хватает и консольных команд. Из графических программ-Firefox-esr (который недавно обновился до версии 68.3) и Transmission-gtk.

П.С.

На этом ПК никакой серьезной работы не ведется. Для этого имею другую машину. И думаю, что там тоже установлю twm. Он предназначен для музыки, фильмов и сёрфинга.

>>> Просмотр (1920x1080, 73 Kb)

 ,

Odalist ()

ARM для arm

Галерея — Скриншоты

Вполне себе можно использовать для задач типа смотреть трубу читать книжку, слушать музыку, программировать младшего собрата в виде Cortex-M.

>>> Просмотр (2560x1440, 550 Kb)

 , , , ,

ukr_unix_user ()

Старый добрый FVWM

Галерея — Скриншоты

Вдохновленный «некрофильными» скриншотами, решил кардинально изменить конфигурацию своего FVWM. Конфигурация минимальная. В системе 900 пакетов. Из графических приложений только браузер Firefox-esr (есть и w3m, но он для простых сайтов) и торрент качалка — transmission-gtk. Все остальное — терминальные программы (irssi, fff, mpg123 со скриптом conplay, есть и moc), gotop, видео — mpv.

Conky почти дэфолт. Я только убрал ненужную мне инфу, и добавил вывод mocp.

Использую лишь xterm. Почему он? Потому, что быстрый.

Терминальные шрифты — идущие в поставке Xorg. Я только изменил их размер. А в самой системе — DejaVu Sans.

Получилось удобно (для меня).

Кому интересно, конфиги, как всегда, лежат вот тут.

>>> Просмотр (1920x1080, 84 Kb)

 ,

Odalist ()

twm в естественной среде обитания

Галерея — Скриншоты

Раз уж по галерее катится волна некрофилии, надо добавить свою каплю. Например дефолтный twm, который я использую как дополнительное окружение (fluxbox надоел) для дополнительного юзера в системе, сеансы которого настроены на ~10% общего процессорного времени через cgrops.

В данном случае оно занято запихиванием сериала на мелкий экран моего кнопочного смартфона через ffmpeg. Небольшой скрипт через файл-блокировку позволяет запуститься только 1 копии ffmpeg, но писать скрипт для автоматического запуска заданий мне лениво, поэтому просто ручной запуск в 10-и окнах.

Из минусов: 10 минут на выгрузку задачи на ночь, оверхед ~2800Кб памяти на копию xterm и 2100Кб на копию bash.
Из плюсов: нескучные обои, креативные методы управления окнами (креативней чем гном3), отдельный пользовательский сеанс, занимающий всего 19Мб на Х-сервер и 3960Кб на оконный менеджер.

P.S. Для полного погружения можно запустить в основном окружении homm2 в досбоксе или doom в PrBoom-Plus, а на vt2 через mc включить какую-нибудь музыку.

>>> Просмотр (1400x1050, 36 Kb)

 

kirill_rrr ()

Google Stadia на Linux Mint

Галерея — Скриншоты

Так-то бы ещё скриншотов наделать, но когда игра не в фулл-скрине Стадия ругается и предлагает её закрыть. Про работу рассказать особо нечего. Она работает. Задержка там как-то хитро обрабатывается алгоритмом и в целом не ощущается. Никуда она однако не делась и в рейд Destiny я бы с ней не пошёл (в саму Destiny я тоже играл, всё хорошо, уже достаточно людно). В какие-нибудь нерасторопные игры вроде той же Red Dead Redmeption, думаю будет норм.

Завёл всё через ProtonVPN подружив его со своим Mikrotik. Дружил долго так как руки из одного места и в целом до конца не подружил.

Вот мой конфиг, может кому интересно будет.

/ip ipsec profile add name=ProtonVPN 

/ip ipsec proposal add name=ProtonVPN auth-algorithms=sha256 enc-algorithms=aes-256-cbc pfs-group=none

/ip ipsec policy group add name=ProtonVPN

/ip ipsec policy add dst-address=0.0.0.0/0 group=ProtonVPN proposal=ProtonVPN src-address=0.0.0.0/0 template=yes

/ip ipsec mode-config add name=ProtonVPN responder=no

/ip ipsec peer add address=se.protonvpn.com exchange-mode=ike2 name=ProtonVPN profile=ProtonVPN

/ip ipsec identity add auth-method=eap certificate="" eap-methods=eap-mschapv2 generate-policy=port-strict mode-config=ProtonVPN peer=ProtonVPN policy-template-group=ProtonVPN username=имя password=пароль

/ip ipsec profile add name="ProtonVPN" hash-algorithm=sha256 enc-algorithm=aes-256 dh-group=modp2048 lifetime=1d proposal-check=obey nat-traversal=yes dpd-interval=2m dpd-maximum-failures=5

/ip firewall address-list add address=мой-пк list=local  /ip ipsec mode-config set [ find name=ProtonVPN ] src-address-list=local 

В чём суть отсутствия дружбы. На любой сайт практически ничего нельзя загрузить. Upload просто мёртвый. Захожу на speedtest.net там всё по нулям, https://testmy.net/upload ещё хуже, просто виснет на середине. По какой-то одному богу известной странности файлы (вот этот вот скриншот) и вот этот текст и вообще всё, я могу загрузить только на LOR. Что происходит и почему работает лишь LOR я понять не могу. Стадия тоже понятное дело работает (нажатия же обрабатываются), но не факт, что войсчат заведётся (пока не смог никого найти чтоб проверить).

>>> Просмотр (1920x1080, 1961 Kb)

 , ,

zenkov ()

Я люблю глухое эхо

Галерея — Скриншоты

Недавно вышла новая версия Common Desktop Environment, решил накатить!

( читать дальше... )

>>> Просмотр (1280x768, 118 Kb)

 , ,

insw ()

В 2020 год с оформлением из 1992

Галерея — Скриншоты

Шалом, понята!
Посчитал, что негоже входить в новое десятилетие с оформлением из 2013. Поэтому, вдохновлённый цветами из Windows 3.11 и прочими ретроградскими непотребствами состряпал новую тему оформления. На скриншоте:

  • Fluxbox 1.3.7 (верность традициям)
  • polybar 3.4.1 (для отображения всякой ерунды)
  • galculator v2.1.4 (для демонстрации декорации окон)
  • rofi 1.5.4 (для запуска приложений, названия которых я не помню)
  • XTerm (351) с запущенным htop 2.2.0

Ну и FreeBSD-12.1-RELEASE-p1. Это всё вращается на HP Pavilion dv4 с 4 ГБ ОЗУ и Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz вместо процессора. Благо, с Firefox'ом и Sylpheed'ом справляется.
На polybar'е отображается слева направо: погода (с openweathermap.org, свободное место/всего места на / и /usr/home, температура ядер процессора, свободная ОЗУ/всего ОЗУ, точка доступа Wi-Fi (канал), заряд батареи и статус заряда, яркость, громкость и раскладка клавиатуры. Все данные, кроме раскладки клавиатуры отдаются собственными скриптами.
Как и в 2013 году, на каждом рабочем столе (всего их 12) запущен xterm без декораций.
Шрифт — Anonymous Pro, Terminus уже надоел (почти за семь лет-то).

Как-то так.

>>> Просмотр (1280x800, 196 Kb)

 , , ,

IPR ()

Нужно больше постановочных скринов с i3

Галерея — Скриншоты

https://github.com/neg-serg/dotfiles

В нормальном качестве, а не вот это вот всё: https://i.imgur.com/z1arTLh.png

Из того на что стоит обратить внимание это конфиги zsh, там свой дистрибутив по сути, также tmux, tridactyl и polybar. Также для i3 я сделал что-то типа notion 3/4-like UX на базе i3ipc и оно всё быстро работает.

Вот например что хочу выделить, это zsh-defer позволяет ускорить загрузку zsh где-то в два раза.

Для tmux прикольные плагины вот эти:

plugins/tpm – ну это понятно, это менеджер плагинов)

tmux-plugins/tmux-resurrect – это для того чтобы сохранять состояние короче текущее и потом можно с него загружаться со всей историей что уже была

Morantron/tmux-fingers – позволяет быстро копиривать в буфер обмена или буфер tmux файлики и что-то подобное, особенно хорошо сочетается с безпрефиксными хоткеями, которые идут через alt)

laktak/extrakto – позволяет делать автокомплит через fzf для той инфы, которая уже есть в tmux

Ну polybar это просто полибар, но мне нравится идея с прозрачными разделителями под наклоном, может и вам тоже :)

Ну про tridactyl я уже писал что там почти всё поправил.

>>> Просмотр (1920x1200, 1687 Kb)

 , , , ,

e7z0x1 ()

i3-шное настроение, переключился

Галерея — Скриншоты

всё просто и удобно

>>> Просмотр (1600x900, 1475 Kb)

 , ,

spawn_sp ()

Мой manjaro

Галерея — Скриншоты

Всем доброго вечера. Мой первый скриншот для публики. Ничего особенного, подпиленный дефолт, но по мне по приятнее.

>>> Просмотр (1920x1080, 1538 Kb)

 , , , ,

evgenn ()

И снова Arch...

Галерея — Скриншоты

По просьбам трудящихся: Выбор файловой системы (комментарий)

Таки собрался с переходом на арч. Сразу скажу по поводу файловых систем – корень у меня весь под btrfs, отдельного /var нет(сжатие – lzo ). И, надо отметить, pacman работает очень шустро. Свап-раздела нет, использую zram. /home на ext4. В целом, арч значительно быстрее федоры. Это касается и пакмана (сравнить по скорости dnf и pacman – это все равно, что сравнить трактор с Феррари /tread) и в целом работы системы. Работать с компьютером стало сильно приятней. Плюс, за счет наличия AURа не нужно скакать по интернетам в поисках какой-нибуть програмулины – скорее всего она есть в репозитории. Не может не радовать и то, что в системе нет никакого лишнего хлама – только нужные тебе утилиты. Еще, касательно времени, зтрачиваемого на установку и первоначальню настройку – мнение, что арч требует аццкое количество времени на развертывание – миф. Да, это конечно заметно более длительный процесс, нежели настройка убунты, но я за два часа получил полностью рабочую систему с кедами, звуком, интернетом, браузером и печатью. Хотя, при количестве машин, отличном от единицы расклад должен поменяться… Так что, пока доволен аки слон

>>> Просмотр (1920x1080, 133 Kb)

 

anti_win ()

OpenBSD 6.6 xfce на флешке

Галерея — Скриншоты

OpenBSD 6.6 amd64, xfce 4.14, не самая быстрая usb-flash на 16 гб

Всё работает довольно быстро, ещё несколько лет назад на той же флешке были ощутимые тормоза, а сейчас полностью юзабельно. softdep включён, что тогда, что сейчас, без softdep не пробовал.

Всё из штатных реп, тема pkg_add yaru, шрифты pkg_add ubuntu-fonts

>>> Просмотр (1360x768, 402 Kb)

 ,

buratino ()

vimperator, давай до свидания, привет tridactyl

Галерея — Скриншоты

В общем-то я довольно давно сопротивлялся апдейту, главным образом потому что было не понятно как заставить работать некоторые хоткеи вроде control+c для закрытия окон, темы и другое тому подобное, постоянно что-то было не так, но всё это удалось решить, так что vimperator я теперь выбросил и наслаждаюсь высокой скоростью. В чем-то tridactyl даже лучше, чем вимператор, например лучшей поддержкой русского языка.

Также пара скринов в догонку:

Терминал: https://i.imgur.com/F4Vv23w.png

neovim: https://i.imgur.com/Tqfu65R.png

>>> Просмотр (1920x1200, 572 Kb)

 , , ,

e7z0x1 ()

Высоко сижу, далеко гляжу

Галерея — Рабочие места

Усталость от офиса накопилась и вынудила выбраться в какую-нибудь менее приевшуюся обстановку. На вооружение взят староватый макбук под управлением самого домохозяйского дистрибутива, отправленный вместе с тушей прокладки между креслом и клавиатурой в оживлённую бюджетным ремонтом квартиру с потолками несколько повышенной высоты в Будапеште. На обоих ярусах присутствует по дивану, внизу, когда тишина приедается, периодически включаю телевизор с новостями, которые круглосуточно крутятся по какому-то каналу. Слева от рабочего места совсем слегка, едва щекоча уши, попёрдывает бойлер.

>>> Просмотр (2560x1920, 1354 Kb)

 

Princesska ()

Хинди-руси бхай-бхай

Галерея — Скриншоты

В поддержку Малаяламских коллег, скриншот с тремя раскрасками сверстанными в Scribus. Нарисовано или на андроиде или на линуксе. Что в данный момент может Scribus:

  • верстать сравнительно быстро текст с картинками;
  • очень медленно и неудобно делать таблицы (лучше пока не делать);
  • открывать многостраничные файлы пдф и иллюстратор иногда без проблем (тут ка повезет, иной раз файл настолько бездарно собран? что грех винить программу, которая не может его нормально открыть), и иногда корел

Последний пункт практически эксклюзив, и с невероятным удобством и легкостью позволяет исправить макет, исходника от которого не найти.

>>> Просмотр (1680x1050, 626 Kb)

 , , , ,

hrum ()

С Днём ГИС, САПРоводы!

Галерея — Скриншоты

13 ноября — междунарождный День ГИС (GIS Day)

САПР на протяжении многих лет используют для решения задач ГИС, но вот использование ГИС для решения задач САПР очень затруднено.

И так как моей основной ГИС является OpenOrienteering Mapper, вдохновившись дополнением для создания штриховки на чертежах для Inkscape, я решил сделать набор условных знаков для создания технических чертежей.

А что было первое: САПР или ГИС?

>>> Просмотр (1335x800, 203 Kb)

 , ,

atsym ()

RSS подписка на новые темы