LINUX.ORG.RU
ФорумTalks

Что за...?

 , , , ,


0

1

Реши обновить кубунту 13.10 и узрел адъ, трэш и угар:

valkeru@valkeru-desktop:~$ sudo apt-get upgrade 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакеты, которые будут оставлены в неизменном виде:
  linux-generic linux-headers-generic linux-image-generic
Пакеты, которые будут обновлены:
  linux-libc-dev [!!!]systemd-shim[!!!] update-notifier-common
обновлено 3, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 3 пакетов не обновлено.
Необходимо скачать 1 200 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 2 048 B.
Хотите продолжить [Д/н]? n
Аварийное завершение.
valkeru@valkeru-desktop:~$ sudo apt-get remove systemd-s
systemd-services  systemd-shim      
valkeru@valkeru-desktop:~$ sudo apt-get remove systemd-services 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  calligra-l10n-ru dvdauthor dvgrab ffmpeg gdebi-core imagemagick-common kde-l10n-ru kdenlive-data libaacs0 libav-tools
  libavdevice53 libavfilter2 libbluray1 libcdio-cdda1 libcdio-paranoia1 libgraphicsmagick3 liblircclient0 liblqr-1-0
  libmagickcore5 libmlt++3 libmlt-data libmlt6 libquicktime2 libsox-fmt-alsa libsox-fmt-base libsox2 libwmf0.2-7 libxcb-xv0
  libxine2 libxine2-bin libxine2-doc libxine2-ffmpeg libxine2-misc-plugins libxine2-plugins libxine2-x melt recordmydesktop
  swh-plugins xine-ui
Для их удаления используйте «apt-get autoremove».
Пакеты, которые будут УДАЛЕНЫ:
  akregator amarok amarok-utils apport-kde aptdaemon apturl-kde ark audiocd-kio bluedevil colord colord-kde dolphin dragonplayer
  filelight firefox-kde-support gdebi-kde gstreamer0.10-qapt gwenview hplip jockey-common jockey-kde k3b k3b-i18n kaccessible
  kaddressbook kamoso kate kcalc kde-baseapps-bin kde-config-pimactivity kde-config-telepathy-accounts kde-config-touchpad
  kde-runtime kde-style-oxygen kde-telepathy kde-telepathy-auth-handler kde-telepathy-contact-list kde-telepathy-desktop-applets
  kde-telepathy-filetransfer-handler kde-telepathy-integration-module kde-telepathy-minimal kde-telepathy-send-file
  kde-telepathy-text-ui kde-window-manager kde-window-manager-common kde-workspace kde-workspace-bin kdemultimedia-kio-plugins
  kdenlive kdepasswd kdepim-kresources kdepim-runtime kdesudo kdm kexi khelpcenter4 kinfocenter kio-audiocd klipper kmag kmail
  kmenuedit kmix kmousetool knotes konsole kontact korganizer kpat kppp krdc krita kscreen ksnapshot ksysguard ksystemlog
  ktorrent kubuntu-debug-installer kubuntu-firefox-installer kubuntu-notification-helper kwalletmanager language-pack-kde-en
  language-pack-kde-ru libcalendarsupport4 libcanberra-pulse libeventviews4 libincidenceeditorsng4 libkateinterfaces4 libkdepim4
  libkdepimdbusinterfaces4 libkfbapi1 libkgapi2-2 libkolab0 libksieveui4 libktpcommoninternalsprivate5 libmailcommon4
  libmailimporter4 libmessagecomposer4 libmessagecore4 libmessagelist4 libmessageviewer4 libmuonprivate1 libpam-systemd
  libpimactivity4 libpimcommon4 libqapt2-runtime libreoffice-kde libtemplateparser4 muon muon-discover muon-notifier
  muon-updater network-manager nvidia-settings-331 okular partitionmanager plasma-dataengines-workspace plasma-desktop
  plasma-netbook plasma-nm plasma-scriptengine-python plasma-widget-facebook plasma-widget-homerun plasma-widgets-addons
  plasma-widgets-workspace policykit-1 policykit-1-gnome polkit-kde-1 print-manager printer-driver-postscript-hp pulseaudio
  pulseaudio-module-bluetooth pulseaudio-module-x11 python-kde4 python3-pykde4 qapt-batch qapt-deb-installer quassel rekonq
  screen-resolution-extra skanlite software-properties-kde systemd-services systemsettings ubuntu-release-upgrader-qt
  usb-creator-kde xul-ext-ubufox
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 147 пакетов, и 6 пакетов не обновлено.
После данной операции, объём занятого дискового пространства уменьшится на 334 MB.
Хотите продолжить [Д/н]? n
Аварийное завершение.
valkeru@valkeru-desktop:~$ 
Ладно, в связи с процессом прибивания гнума к любимому лисапеду поцтеринга я бы понял такое поведение относительно кусков юнити. Но каким надо быть муд^C уродом, чтобы вот так присобачить этот кусок фекальных масс к кедам? Какого хрена?

★★★★

Время тебе собирать собственный дистриб с кедами и инитскриптами на рубях.

fraxinum ()

Собственно, фундаментальный недостаток бинарных дистров.
Раньше был semantic-desktop невыпиливаемый, щас вот это, завтра какую-нибудь облачную херню прикрутят.
Жить стало лучше, жить стало веселей! (С)

Yustas ★★★★ ()

Может, можно вместо systemd-services вставить любимый всеми ConsoleKit?

Darth_Revan ★★★★★ ()
Ответ на: комментарий от Yustas

А вам лишь бы всё выпиливать! Некоторые вещи можно просто отключить, если вы про semantic-desktop.

awesomenickname ★★★★★ ()

Уже давно известно, что убунта перейдет на вырезанные куски из systemd с сохранением upstart, так как consolekit больше не поддерживается (и udev, кстати говоря, тоже часть systemd).

equeim ★★ ()
Ответ на: комментарий от awesomenickname

Да оно теперь просто реактивное. Смысла отключать нет.

feofan ★★★★★ ()

А почему upgrade а не dist-upgrade ?

sin_a ★★★★★ ()
Ответ на: комментарий от fraxinum

Теперь и собственный дистрибутив не помогает. Нам пришлось тащить небольшие куски systemd к себе, хотя системы инициализации и управления службами собственные. Хорошо, хоть на части его раздолбали.

Tribunal ()
Ответ на: комментарий от sin_a

Потому что upgrade более безопасен и не будет ставить то, что по зависимостям потенциально может сломать другие пакеты.

Valkeru ★★★★ ()
Последнее исправление: Valkeru (всего исправлений: 1)

Что за...?

Обычный хомячий баттхерт при виде названия компонента, значения которого хомяк толком не понимает.

thesis ★★★★★ ()
Ответ на: комментарий от leg0las

Не, ну на части systemd мы все-таки раздолбали, хотя это было не просто. Например, у нас отрублены journald и logind. Кстати, Поттеринг говорил в одной из своих проповедей, что logind неотделим от systemd. И вообще, у нас пока мало systemd. А так если водрузить его, вместо PISI - pacman, убрать GUI для настройки того и сего, убрать Kaptan (пользователи Chakra, привет!), усложнить установку и получится почти Arch. А по Kubuntu - вообще странно, у нас тоже кеды и этого чуда нету в зависимостях.

Tribunal ()
Ответ на: комментарий от sin_a

Неа. Upgrade не будет обновлять пакет, если при этом потребуется что-то удалить или установить.

Valkeru ★★★★ ()
Ответ на: комментарий от awesomenickname

Некоторые вещи можно просто отключить, если вы про semantic-desktop.

а зачем его вобще ставить?

der_looser ★★ ()
Ответ на: комментарий от Valkeru

Вот к такого рода ситуациям это и может привести. Если ещё не выполнил, по попробуй запросить dist-upgrade, возможно он как раз разрулит.

sin_a ★★★★★ ()
Ответ на: комментарий от awesomenickname

А вам лишь бы всё выпиливать!

Апгрейд бритвы Оккама. Теперь с зубцами. Для более жОского, бескомпромиссного выпиливания!

Yustas ★★★★ ()
Ответ на: комментарий от der_looser

Ну, непоймук довольно полезен. На фоне общей тормознутости и кривости поиска файлов в Dolphin.

Valkeru ★★★★ ()
Ответ на: комментарий от sin_a

Вот к такого рода ситуациям это и может привести.

Не распарсил

Valkeru ★★★★ ()
Ответ на: комментарий от fraxinum

Время тебе собирать собственный дистриб с кедами и инитскриптами на рубях.

Лучше так: «С кедами и инитскриптами на рубях собирать собственный дистриб время тебе».

Mr_Gentoo ()

systemd-shim — это случаем не имеет отношения к первоначальному до'GRUB'овскому подписанному загрузчику Shim для сосуществования с UEFI Secure Boot?

А вообще, в вашем любимом upstart'е уже есть куски systemd. Вся беда в том, что в системе появился пакет с именем systemd-bla-bla-bla?

carasin ★★★★★ ()
Последнее исправление: carasin (всего исправлений: 1)
$ apt-cache show systemd-shim

...

Description-en: shim for systemd
 This package emulates the systemd function that are required to run
 the systemd helpers without using the init service
Evil_And ★★ ()

Купи себе винт еще на 20 гигов (стоит не больше 500 рублей, на хлеб останется) и больше не заботься о свободном месте.

KendovNorok ()

что ж ты так беспокоишься? системд уже и к апстарту приколотили, правда, в кастрированном виде

xsektorx ★★★ ()
Ответ на: комментарий от leg0las

Ну так, некоторые считали нас производными от Gentoo, хотя мало общего. Собирать пакеты на компьютере - у нас опция PISI, да и все остальное иначе устроено. А вообще, скоро systemd приколотят к Wayland, на него все перейдут и приехали...

Tribunal ()
Ответ на: комментарий от Tribunal

Ну вяленый интел пилит, я думаю у них мозгов хватит не завязывать такую инфраструктуру.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

Я знаю, что Интел, просто уже не раз и не два вижу обещания, что для своих нужд Wayland, а точнее Weston, будет использовать systemd. Правда, пока все это или рассуждения в G+ от разработчиков разных DE или сомнительные ресурсы, вроде фороникса. Опять же, откат патча для XMir в интеле дает почву для размышлений. Тут основательно так обсуждали уже.

Tribunal ()
Ответ на: комментарий от Tribunal

Они могут использовать связку с системд, но привязывать не вижу смысла. Хотя если привяжут и навяжут, то свалю на фрю.

leg0las ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.