LINUX.ORG.RU
решено ФорумTalks

Глупый вопрос про устаревшее оборудование

 , ,


0

1

Вот смотрите, есть у меня старый нетбук. В нем старая видеокарта, которую АМД сняло с поддержки в пропиетарном драйвере. Со свободным драйвером проблемы с ускорением и энергосбережением.
Т.е. у меня есть три варианта: дебиан олдстабильный, гента/калька (в которых я совсем не разбираюсь), ну и решение, предложенное поставщиком оборудования с последующим винфаком.
Первый вариант оставляет меня без софта, третий без воспроизведения видео ввиду низкой производительности. Поэтому вопрос по второму варианту:
Смогу ли я в кальке использовать свежий софт со старым пропиетарным драйвером и вытекающей из него старой версией иксов?
Насколько это будет сложно для человека, ни разу не прикасавшегося к гентам, LFS'ам и подобным интересным вещам?
Есть ли по кальке какое-нибудь руководство для совсем тупых, в котором бы подробно разъяснялось использование emerge в контексте кальки, а не «знакомься это emerge, у него есть ман»?

Сложно будет (поставить старый драйвер в gentoo, если ебилды хоть найдёшь - в том числе может не взлететь с текущими версиями xorg/mesa). Факт. А открытый драйвер совсем не катит?

BattleCoder ★★★★★ ()
Последнее исправление: BattleCoder (всего исправлений: 1)

Ставь винду и не выёживайся. Если нормального драйвера нет, то хоть LFS собери — работать нормально не будет.

Stahl ★★☆ ()

CentOS 6 до 2020 поддерживается с ядром 2.6

f3ex ★★ ()

Карту не назвал. Модель ноутбука не назвал. Зачем ты вообще создал этот нытик-тред?

daemonpnz ★★★★★ ()

Отправляй баг-репорты разработчикам свободного драйвера.

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от BattleCoder

открытый драйвер совсем не катит?

Аппаратное ускорение совсем не пашет. Приложения, которые его использовали просто крэшились. К тому же энергосбережение совсем печальное.

siphonops ★★★ ()

gentoo stable + ядро 2.6 если оно необходимо

murmur ()
Ответ на: комментарий от Stahl

Если нормального драйвера нет

Пропиетарный драйвер работал приемлимо, просто его нет в новых дистрибутивах и не поставить из-за новой версии иксов.

Ставь винду

Нет смысла из-за низкой производительности устройства.

siphonops ★★★ ()
Ответ на: комментарий от f3ex

Центось мне уже советовали, поставил в виртуалку и не увидел преимуществ перед дебианом. Мне, собственно просто «поддержка» по части латания дыр не нужна, мне нужна актуальная версия браузера, например.

siphonops ★★★ ()
Ответ на: комментарий от siphonops

Так поставь хром из гугловского репозитория.

f3ex ★★ ()
Ответ на: комментарий от daemonpnz

Я же написал, что это «глупый вопрос про устаревшее оборудование». У меня нет цели поныть про линукс, или про амд. Мне нужно узнать возможности по кастомизации генты и кальки. При чем здесь модель устройства?

siphonops ★★★ ()
Ответ на: комментарий от Chaser_Andrey

Отправляй баг-репорты разработчикам свободного драйвера.

Зачем? Чтобы они копались в засохшем г. прошлого десятилетия? У них и без этого достаточно работы с актуальным оборудованием.

siphonops ★★★ ()

А может проще толкнуть его с рук, добавить и взять новый?

GNU-Ubuntu1204LTS ★★★ ()
Ответ на: комментарий от siphonops

Так ты определись - ты хочешь, чтобы была поддержка твоей видеокарты открытым драйвером или нет? Баг-репорты - это ещё и способ привлечь внимание разработчиков к тому факту, что оборудование до сих пор используется.

Алсо, ничего плохого не вижу в поддержке оборудования, которое до сих пор может исполнять свои базовые задачи.

Chaser_Andrey ★★★★★ ()
Ответ на: комментарий от GNU-Ubuntu1204LTS

А может проще толкнуть его с рук, добавить и взять новый?

Отличная идея. Толкну его винеру в соседний топик за 2500, пусть он с ним возится, а я добавлю 20-30к и куплю новый, сопоставимого качества сборки.
P.S. Денег нет, чтобы добавить.

siphonops ★★★ ()
Ответ на: комментарий от Chaser_Andrey

Так ты определись - ты хочешь, чтобы была поддержка твоей видеокарты открытым драйвером или нет?

Нет. Я хочу собрать относительно свежую систему со последним рабочим пропиетарным драйвером.

siphonops ★★★ ()
Ответ на: комментарий от siphonops

Если денег совсем нема,это конечно плохо.Но давай посмотрим, какое последнее ядро и иксы поддерживаются?И из того что есть выберем дистрибутив, с максимальным оставшемся временем поддержки.

GNU-Ubuntu1204LTS ★★★ ()
Ответ на: комментарий от siphonops

Тогда дорога на CentOS. Большинство проектов делают сразу rpm el6.

А вообще из любого дистра можно сделать слаку.

f3ex ★★ ()
Ответ на: комментарий от Chaser_Andrey

ТС надо решать здесь и сейчас, а не в заоблачном будущем 23 века, когда наконец запилят нормально свободные дрова.

DeadEye ★★★★★ ()
Ответ на: комментарий от siphonops

Можно, кстати, через докер доставить требуемое ПО со своими зависимостями.

f3ex ★★ ()
Последнее исправление: f3ex (всего исправлений: 1)
Ответ на: комментарий от GNU-Ubuntu1204LTS

И из того что есть выберем дистрибутив, с максимальным оставшемся временем поддержки.

Да ладно, я все-равно туда дебиан туда поставлю.
Просто думал поиграться с калькой, или гентой на выходных с полезным результатом, а если все-равно результата не будет, то затея теряет смысл.

siphonops ★★★ ()
Ответ на: комментарий от siphonops

Мой тебе совет,поклянчи железо на лоре. Мне отдали вполне годный куплюхтер , очень им доволен.

GNU-Ubuntu1204LTS ★★★ ()
Ответ на: комментарий от GNU-Ubuntu1204LTS

У меня вполне годный десктоп, на нем вполне годно живет дебиан.
Просто читаю тут волшебные истории о том, как лоровцы с пользой применяют старое железо, аж зависть берет. А у самого с этим обычно ничего не выходит.

siphonops ★★★ ()
Ответ на: комментарий от daemonpnz

Оно не настолько устаревшее, чтобы работать, но достаточно устаревшее, чтобы перестать поддерживаться. На wheezy я ставил fglrx-legacy-driver, это вроде (AMD Catalyst Legacy 13.1).

siphonops ★★★ ()

Юзай oldstable, софт компиль руками

Reedych ★☆ ()
Ответ на: комментарий от siphonops

Оно не настолько устаревшее, чтобы работать, но достаточно устаревшее, чтобы перестать поддерживаться.

Тебе стыдно назвать железяку или просто шлангуешь?!

daemonpnz ★★★★★ ()
Ответ на: комментарий от daemonpnz

Ну смотри, напишу я модель железяки. Через час здесь нарисуется доброхот, который мне скажет, что у его бабушкиного племяника внучатой курицы на таком же железе все чудесно работает, и начнет мной руководить. Потом к делу подключатся еще парочка подобных, я буду день по этим советам собирать и разбирать обратно пакеты и патчить ядро, а когда и кладезь знаний кончиться не позволив мне получить результат, они тихо сольются.
Ну или этот доброход окажется действительно грамотным и начнет давать дельные советы, половину слов из которых я буду гуглить. Так я потеряю аж два дня, но результата не добьюсь, т.к. надо будет знать какую-нибудь пустяковину по его меркам, вроде синктаксиса плюсов, а я этого не знаю.
Поэтому я и вбрасываю в таком виде. Вдруг найдется человек, который скажет: «я тоже ничего не понимаю, но почитал вот это руководство по кальке (ссылка) и мне стало понятно, какие слова гуглить».

siphonops ★★★ ()
Ответ на: комментарий от siphonops

Всего-то надо портировать легаси-драйвер на новые иксы и ядро.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Вот об этом я и писал. Только предложение портирования пропиетарного драйвера - это слишком толсто.

siphonops ★★★ ()
Ответ на: комментарий от siphonops

Ну я и говорю - шланг шлангом. Вместо того чтобы разбираться с дистрибутивом, ты его меняешь, причём без гарантий о том, что норм будет работать. И в итоге получится ты с дровами будешь сношаться вечно. Успехов.

daemonpnz ★★★★★ ()
Ответ на: комментарий от siphonops

Только предложение портирования пропиетарного драйвера - это слишком толсто.

Почему? На картинке http://img825.imageshack.us/img825/4559/bsr.png видна Android-версия Opera Mini, которая запущена в эмуляторе, в котором крутится x86-версия Android. Картинка с надписью «Google» декодировалась неправильно, так как в рекомпиляторе был баг. Финальная версия работает под MIPS. Доступных исходников, как понимаешь, у Opera Mini нет.

i-rinat ★★★★★ ()
Ответ на: комментарий от daemonpnz

Ну я и говорю - шланг шлангом.

Употреби свой пыл в техразделах. Мы в толксах, здесь можно и за жисть потрепаться, если о линуксе.

Вместо того чтобы разбираться с дистрибутивом

С каким? Я еще ни с чем не начал разбираться. Просто спрашиваю имеет ли мне смысл возиться с калькой/гентой, если у меня нулевая подготовка, а проблему надо решить непростую.

ты его меняешь

Ну и что же, по твоему, я меняю на пустом ноуте, на который я несколько месяцев назад накатывал дебиан для пробы? user@local$ потру? Бида.

И в итоге получится ты с дровами будешь сношаться вечно.

Ничего не поделаешь это линукс/амд/кривые_руки/[подставь_нужное].

Успехов

А вот за это - спасибо.

siphonops ★★★ ()
Ответ на: комментарий от siphonops

Все-равно толсто.

Мда.

У тебя картинка отвалилась.

Они Referer проверяют, похоже.

i-rinat ★★★★★ ()

Я чото П! Есть время - ставь Gentoo. Там всё сделано для установки старого AMD блоба. Перед этим веселым приключением рекомендую gentoo wiki. Установка в других дистрибутивах на порядок сложнее. Это личный опыт, карта была HD3xxx.

dodevich ()

карту и дистрибутив в котором проблемы на опенсорсном драйвере в студию?

Thero ★★★★★ ()

Ну, что такой непонятливый... Дали же четко понять: покупай новое, покупай ещё! Не покупаешь - не человек же. Что о тебе думать.

record ★★★★★ ()
Последнее исправление: record (всего исправлений: 1)

Что за карта? Предчувствую, что 4.2 в твоём посте. На старых радеонах давно уже есть dpm

aegi ★★★ ()
Ответ на: комментарий от Thero

Mobility HD3650 и Kubuntu 14.04+ - случайные фризы системы. Теоретически лечится отключением оптимизаций radeon, но тогда смысла использовать его становится меньше. Со всякими там dpm, sb и hyperz в Left 4 Dead fps в два раза ниже, чем на проприетарном. А игорь тоже нужен, да.

xmichael ()
Ответ на: комментарий от xmichael

пробовали дрова из oibaf ppa? в стандартных репах для 14.04 весьма устарелые дрова лежат. но в целом в любом случае лучше научиться брать от открытого драйвера всё чем тащить каталист из прошлого.

Thero ★★★★★ ()

Slackware ждёт тебя. Ставь 13.37-14.1, подключай репы -current и обновляй оттуда только браузер + его зависимости.

iz_tabakerki ()
Ответ на: комментарий от iz_tabakerki

Ставь 13.37-14.1, подключай репы -current и обновляй оттуда только браузер + его зависимости

Возможно лучше поставить slackpkg+, прописать хранилище alien (на самом деле оно там уже прописано), и обновлять оттуда свежий chromium.

bormant ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.