LINUX.ORG.RU

Установка debian на SSD-диск

 , ,


1

1

Пытаюсь который день ставить debian на SSD-диск.

Дистрибутив скачал с дебиан.орг, записал на USB-флешку. Ставится нормально, после перезагрузки, выключения питания (в том числе выдергивание сетевого шнура) - норма, линукс грузится.

Проблема:

Если я отключу SSD и перезагружу компьютер - выдает логичную надпись «reboot and select proper boot device…».

Но если я подключаю SSD-диск обратно, линукс больше не грузится, надпись «reboot and select proper boot device…». На обычный жесткий диск линукс ставится нормально и «не слетает» в подобной ситуации. Одно наблюдение - когда линукс грузится нормально, название устройства в bios «debian: Plextor…», когда не грузится становится «UEFI: Plextor…»

Прошу подсказать в чем может быть проблема? Может кто сталкивался?

P.S. SSD-диск Plextor PX-512M8VC+ (обновления проверял, нету), пробовал на другой SSD Plextor, картина такая же, мать Gigabyte Z87-HD3 F6,I7-4770. Также пробовал на другом компьютере с примерно такой же мамкой, картина одинаковая, после вынимания SSD и перезагрузки и обратного втыкания - не грузится. Изменения параметров загрузки и и т.п. в биосе ни к чему не приводят.


Прошивка может чистить записи при вытаскивании диска. Могу предложить попробовать установить груб с --force-extra-removable или скопировать /boot/efi/EFI/debian в /boot/efi/EFI/BOOT

xgatron ()

Рекомендую отключить UEFI-загрузку в настройках биоса и установить ОС традиционным способом с GRUB в загрузочном секторе, тогда ничего слетать не должно.

firkax ★★★ ()

Материнка при отключении диска «забывает» про кастомный путь к дебиану, а по стандартному пути /boot/bootx64.efi у тебя пусто, поди?

zemidius ()

Изучай свой УЕФИ, тебе с ним жить!

Если я отключу SSD…

Особенность твоего конкретного УЕФИ. Создавай ESP-раздел на том диске, который не будешь отключать.

Если на материнке несколько разъемов, то может быть подключать SSD к тому, который первый инициализируется.

andytux ★★★★ ()

очередная жертва уефи

anonymous ()

Посмотрите что у Вас в вариантах загрузки UEFI после установки linux до отключения ssd и после отключения и перезагрузки, с помощью утилиты efibootmgr. Возможно UEFI-прошивка Вашей системы, во время запуска не найдя накопитель, удаляет соответствующий пункт из вариантов загрузки.

Ваш hdd размечен в GPT или MBR? Если второе, то возможно прошивка просто загружается с него в legacy-режиме. Этим можно объяснить различие при установке на ssd и hdd.

QsUPt7S ()
Ответ на: комментарий от firkax

Рекомендую отключить UEFI-загрузку в настройках биоса и установить ОС традиционным способом с GRUB в загрузочном секторе, тогда ничего слетать не должно.

Так и сделал - поставилось, ничего не слетает. Похоже действительно какая-то несовместимость с UEFI.

или скопировать /boot/efi/EFI/debian в /boot/efi/EFI/BOOT

Папки /boot/efi/EFI/BOOT не было, но копирование не помогло, однако я мог что-то не так сделать. Копировал из терминала «cp debian/* BOOT/», файлы скопировались, но не уверен что так правильно.

Ваш hdd размечен в GPT или MBR? Если второе, то возможно прошивка просто загружается с него в legacy-режиме. Этим можно объяснить различие при установке на ssd и hdd

SSD был размечен скорее всего в MBR, однако инсталлятор не предлагает выбора и не комментирует как ставит.

Всем большое спасибо!

ankul ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.