LINUX.ORG.RU

переход на Linux

 , , ,


0

1

Пытаюсь перейти c OSX на Linux. Нужен deb-based, взял Ubuntu 16.04.1. На ноутбуке из коробки завелось все. Батарейку с tlp держит на 1/3 меньше чем OSX, но это не проблема. А проблемой являются шрифты но не качество отрисовки а размер. Шрифт PragmataPro 12pt соответствует 16pt в OSX, как уменьшить «размер» что бы получить паритет? Где то читал что для убунты запилили мультитач который должен работать на macbook pro, как его включить? Из коробки поддерживается только прокрутка двумя пальцами.

P.s. Из интересного заметил что в Emacs 25.1 в OSX плавно работает скроллинг по ставнению с Ubuntu, но перемещение курсора менее отзывчиво.

Ответ на: комментарий от FIL

Поверь, не стоит!

Верю, но может лучше к урологу?

anonymous ()
Ответ на: комментарий от gssomi

установи дебиан

ставил, впечатления положительные. Там поблема таже. Мультитач нужно настраивать touchegg. А со шрифтами нужно патчить libcairo, freetype и libxft, а в Ubuntu насколько понял этого делать ненужно.

И зачем тебе pre-compiled?

Чтоб не собиарть) Например в OSX для сборки этого чуда требует собрать gcc + boost, не считая времени сборки этого чуда.

robotron5 ()

Ты ошибаешься, тебе нужен rpm-based. Попробуй в следущий раз настроить энергосбережение, кооректной работы из коробки тебе никто не обещал. Проблемы с масштабом как-то связаны с DPI, видеодрайвером, X-ами и разрешением монитора.

anonymous ()
Ответ на: комментарий от anonymous

тебе нужен rpm-based.

зачем?

настроить энергосбережение

tlp вроде работает

с масштабом как-то связаны с DPI

возможно, попробую покрутить.

robotron5 ()
Ответ на: комментарий от robotron5

Там поблема таже. Мультитач нужно настраивать touchegg. А со шрифтами нужно патчить libcairo, freetype и libxft, а в Ubuntu насколько понял этого делать ненужно.

Но там все это работает криво.

не знаю, я столько всего собираю, и у меня большая часть компилиться без проблем и быстро.

gssomi ★★ ()
Ответ на: комментарий от Deleted

ой, да возьми топовые дистры и пробуй.
федору, бунту, зюзю.
а , внезапно, остановишься на каком Генто-Арче.

Deleted ()
Ответ на: комментарий от Deleted

поэтому ты заделал топик

Я создал топик так как незнаю как пользовать линукс в какчестве десктопа. Многие здесь присутствующие его используют т.е. решили эти проблемы. Из за патентов в любом линуксе нужно патчить библиотеки отрисовки шрифтов. Выбрал убунту так как было подозрение что там этого делать ненужно будет, но там тоже не все гладко как оказалось.

да возьми топовые дистры

я уже отписал что мне нужен Debian или производные.

robotron5 ()

Шрифт PragmataPro 12pt соответствует 16pt в OSX

Тред не читал, но по описанию похоже на описанную у Лебедева разницу в размерах шрифтов (количестве точек на дюйм)

XMs ★★★★★ ()
Ответ на: комментарий от robotron5

Из за патентов в любом линуксе нужно патчить библиотеки отрисовки шрифтов.

Ты уверен в этом? Вроде бы уже срок всех патентов на это давно истёк и в любом Linux всё пакеты связанные со шрифтами по умолчанию поставляются собранными со всеми включёнными опциями для наилучшего отображения шрифтов.

anonymous ()
Ответ на: комментарий от anonymous

Вроде бы уже срок всех патентов на это давно истёк

Нет.

в любом Linux

В федорке до сих пор ШГ, в шлаке предлагают пересобрать. В Debian положили болт, и всё же включили и патентованные алгоритмы, и патчи от Ubuntu. То есть в нормальных дистрибутивах всё нормально :)

anonymous ()
Ответ на: комментарий от sudopacman

Deb пакет нельзя конвертировать в любой другой?

Думаю можно, а что делать с зависимостями? Pin'ить и устанавливать нужные версии в ручную? Проще сорать из исходников под то что есть в системе.

robotron5 ()
Ответ на: комментарий от robotron5

Думаю можно, а что делать с зависимостями? Pin'ить и устанавливать нужные версии в ручную?

Штуковина по ссыке, что ты дал, вроде не привязана к конкретным версиям.

sudopacman ★★★★★ ()

пирихади мил чилавек пирихади

mos ★★☆☆☆ ()
Ответ на: комментарий от robotron5

можно извлечь содержимое из деба и перепапаковать. зависимости переделать под свой дистр

f1u77y ★★★ ()
Последнее исправление: f1u77y (всего исправлений: 1)
Ответ на: комментарий от sudopacman

не привязана к конкретным версиям.

К конкретным нет, там только есть ограничение снизу. Я имел ввиду что в разных дистрибутивах зависимости у однго и того же приложения могут быть различны. Пример: сталю gnome-flashback с --without-recommentd в ubuntu и debian, в поледнем я получаю минимально «рабочее» окружение а в Ubuntu что то недоставилось. Но дело не в этом, путь изначально неправильный, тут собирать из исходников или идти туда где уже собрано.

robotron5 ()
Ответ на: комментарий от XMs

Если не секрет

Меньше 75 как то мелко совсем, но нужно еще за ручки подергать, межбуквенный интервал уменьшить и жирнее сделать. Цифра не конечная.

robotron5 ()
Ответ на: комментарий от robotron5

В разных дистрибутивах разные зависимости, потому что по-разному собирают пакеты. Хотя, конечно, решать тебе.

sudopacman ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.