LINUX.ORG.RU

Проблема с pacman (database is incorrect version: /var/lib/pacman/) как решить?

 , ,


0

0

устанавливаю минимальную систему arch linux при установке grub :

arch-chroot /mnt pacman -S grub-bios

ругается следующим :

error:failed to initialize alpm library (database is incorrect version: /var/lib/pacman/) error: try running pacman-db-upgrade

пробовал:

pacman-db-upgrade pacman-key --init pacman-key --populate msys2 pacman-key --refresh-keys

не помогает, ругается :

==>ERROR: The keying file /usr/share/pacman/keyrings/msys2.gpg does not exist

==>ERROR: A specified local key could not be upgrade from keyserver

Скорее всего не установлен пакет с ключами:

pacman -S msys2-keyring pacman-key --init pacman-key --populate msys2 pacman-key --refresh-keys

P.S. Думаю по поводу проблем MSYS2 лучше будет пойти на oftc.net IRC канал #msys2.

alexpux ()
Ответ на: комментарий от alexpux

всем спасибо,проблема решена) ставил по старому гайду, вместо где grub-bios устанавливал grub в новой версии это одно и тоже

danya_stdfx ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.