LINUX.ORG.RU

Gentoo без emul-linux с ABI_x86_32

 ,


0

3

Правильно ли я понимаю, что для того чтобы отказаться от пакетов emul-linux-*, но иметь multilib, надо перейти на профиль no-emul-linux и добавить в make.conf «ABI_X86=„32 64“»? Насколько всё это безопасно, не будет ли проблем с зависимостями?

★★

Ответ на: комментарий от turtle_bazon

честно говоря, перешёл на no-emul ещё до появления профиля, поэтому всё работает

Deleted ()

добавить в make.conf «ABI_X86=„32 64“»

Система растолстеет в 2 раза, каждый пакет будет в двух экземплярах, 32- и 64-битном. Зачем эта лажа вместо тёплых ламповых emul-linux-*?

anonymous ()

добавить в make.conf «ABI_X86=„32 64“

А зачем тебе ВСЕ 32-битные библиотеки в 64-битной системе? Не лучше ли выставить флаг abi_x86_32 только нужному софту?

Да, понятное дело, влепить в make.conf проще, но анонимус выше уже сказал о том, что система растолстеет

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)
Ответ на: комментарий от anonymous

Зачем эта лажа вместо тёплых ламповых emul-linux-*?

Угу, привет проблемы с ABI, запаздыванием обновлений, security и прочим шлаком. Даже pacho - мэйнтэйнер почти всех emul-linux-* обеими руками за выкидывание их на мороз. А уж он то что-то подозревает :-)

Плюс, эти библиотеки поддерживают только классическое 32-битное ABI, любители x32 - в пролете

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)
Ответ на: комментарий от anonymous

вообще-то можно воспользоваться --autounmask-write

anonymous ()

Как пользователь профиля no-emul-linux и ABI_X86=«32 64» скажу: всё нормально. Придётся пересобрать много софта, кое-где будут конфликты, но если гентушник, то это не есть проблема.

funeralismatic ★★★ ()
Ответ на: комментарий от Pinkbyte

Как ни крути, на данный момент emul-linux-* - наименее геморройное решение для мультилиба. Тем более, ради чего изобретать новые велосипеды, ради парочки 32-битных прог в 64-битной системе? 32 бита скоро умрут вместе с нужностью мультилиба.

Barbudos ()
Ответ на: комментарий от Barbudos

Тем более, ради чего изобретать новые велосипеды, ради парочки 32-битных прог в 64-битной системе? 32 бита скоро умрут вместе с нужностью мультилиба.

Дооо, скажи это MIPS-овым железкам с 64-битными процами и 512 мб оперативной памяти. Кааанешна, туда только чистую 64-битную систему ставить, ага-ага.

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Barbudos

Неужели так жжётся от этого?

от наличия спорадически обновляемого, бинари-онли крапа, с несоответствующим хостовой системе ABI и запаздывающей реакцией на security-проблемы? Нет, ты что, всё в порядке, я гарантирую

Тем не менее, на сегодняшний день в stable находятся именно emul-linux-*. Потому что до впиливания полноценного мультилиба везде и всюду еще нужно много дерьма разгрести

Pinkbyte ★★★★★ ()

надо перейти на профиль no-emul-linux

Да.

и добавить в make.conf «ABI_X86=„32 64“»

Нет.

andreyu ★★★★★ ()

мне потребовалось еще размаскнуть ABI_X86_64 в use.mask

хотя кому-то, говорят, не потребовалось

MyTrooName ★★★★★ ()

если размер оперативки не превышает 32Gb, то тупо ставь Gentoo i686 и не парься

armbox ()
Ответ на: комментарий от Barbudos

То есть, всё-таки в линукс с мультилибом зачастую гемморой?

menangen ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Потому что до впиливания полноценного мультилиба везде и всюду еще нужно много дерьма разгрести

Ну я вот как чувствовал, что у вас там в линуксах с 64битным и старым 32-х битным софтом всё не очень гуд. По-ходу, люди реально уже заколёбываются этими мультилибами. Майкрософт в этом плане, конечно, поступили правильней и проще.

menangen ★★★★★ ()
Ответ на: комментарий от menangen

Ну я вот как чувствовал, что у вас там в линуксах с 64битным и старым 32-х битным софтом всё не очень гуд.

В бинарных дистрах проще - им не нужно предусматривать собираемость всех возможных вариантов - поэтому Gentoo в плане внедрения мультилиба далеко не впереди планеты всей.

Так что геморрой - только у тех, кто не осилил прочесть инструкцию в бинарных дистрах, где мультилиб в большинстве своем оттестированная и хорошо работающая вещь.

Майкрософт в этом плане, конечно, поступили правильней и проще.

А какие проблемы в оффтопике - один хрен каждое приложение практически всегда бандлит все нужные либы, так что если захочешь выяснить где у тебя дырявая версия OpenSSL например - замучаешься :-)

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)
Ответ на: комментарий от menangen

на лоре постоянно темы с проблемами мультилиба

только у ламеров, которые считают, что x64 работает быстрее чем x32

armbox ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.