LINUX.ORG.RU

[arch][error] Pacman-key


0

1
[root@pioserver /]# pacman-key --init
gpg: error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory
chmod: cannot access `/etc/pacman.d/gnupg/trustdb.gpg': No such file or directory
gpg: error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory
gpg: error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory
==> Updating trust database...
gpg: error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory
==> ERROR: Trust database could not be updated.

Сделал

 pacman -S libusb 

Не помогло


Пока спасает только SignLevel = Never

mrcim ()

Я не смог допилить до вменяемого состояния проверку пакетов.

Поэтому закомментировал везде # SigLevel в /etc/pacman.conf, потом сделал pacman -Scc , pacman -Syy, pacman -Suu

rafister ()
Ответ на: комментарий от mrcim

Пока спасает только SignLevel = Never

Вроде бы пока так и нужно)

uniqwert ()
Ответ на: комментарий от rafister

Что вообще случилось с арчем, решил поставить на старенького, а он вообще на все ругается и разбрасывается еррорами.

mrcim ()
Ответ на: комментарий от mrcim

Столкнулся с той же самой проблемой. Да просто последний установочный образ кривой. После отключение проверки пакетов все начинает работать как и раньше.

rafister ()
Ответ на: комментарий от rafister

Это результат pacman -Syu

Total Installed Size:   688.54 MiB
Net Upgrade Size:       60.49 MiB

Proceed with installation? [Y/n]
(127/127) checking package integrity                                     [#########################################] 100%
(127/127) loading package files                                          [#########################################] 100%
(127/127) checking for file conflicts                                    [#########################################] 100%
error: failed to commit transaction (conflicting files)
filesystem: /etc/mtab exists in filesystem
initscripts: /etc/profile.d/locale.sh exists in filesystem
Errors occurred, no packages were upgraded.

mrcim ()
Ответ на: комментарий от mrcim

filesystem: /etc/mtab exists in filesystem

initscripts: /etc/profile.d/locale.sh exists in filesystem

Об этом есть в новостях на главной.

uniqwert ()
Ответ на: комментарий от rafister

А что его там пилить, всего 3 скрипта с арчвики выполнить.

f1xmAn ★★★★★ ()
Ответ на: комментарий от f1xmAn

Я что-то выполнял, но ничего не заработало. Неосилятор.

rafister ()
Ответ на: комментарий от rafister

Устанавливал с archlinux-core, уже пожалел об этом. Была возможность net-install сделать.

mrcim ()
Ответ на: комментарий от rafister

Я похоже вообще привет дерево я дуб. У меня такое первый раз. Я устанавливал арч просто немеренно раз. Сейчас мне трудно выражать мысли. Я все сделал, все установил, делаю ребут... И груб радует меня, мол kernel - file not found! И реально - /boot пустой!

mrcim ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.