LINUX.ORG.RU

плохо обновился? смотри лог пакмана

visual ★★★ ()

Откатись до следующих версий:

$ yaourt -Qs startup-notification         
extra/startup-notification 0.12-1
    Monitor and display application startup
$ yaourt -Qs xcb-util                     
extra/xcb-util 0.3.6-2
    Utility libraries for XC Binding
$ 

Или это уже новый баг?

urxvt ★★★★★ ()
Ответ на: комментарий от visual
[2011-12-19 19:04] Running 'pacman -S --asdeps --needed extra/xcb-util-image extra/xcb-util-wm extra/xcb-util-keysyms'
[2011-12-19 19:04] upgraded xcb-util (0.3.6-2 -> 0.3.8-1)
[2011-12-19 19:04] installed xcb-util-image (0.3.8-1)
[2011-12-19 19:04] installed xcb-util-wm (0.3.8-1)
[2011-12-19 19:04] installed xcb-util-keysyms (0.3.8-1)
[2011-12-19 19:11] Running 'pacman -U /tmp/yaourt-tmp-rahal/PKGDEST.hjj/awesome-3.4.11-2-i686.pkg.tar.xz'
[2011-12-19 19:11] 
[2011-12-19 19:11] ==> awesome installation notes:
[2011-12-19 19:11]     ----------------------------------------
[2011-12-19 19:11]     During some updates of awesome, the config file syntax changes heavily.
[2011-12-19 19:11]     This means that your configuration file (~/.config/awesome/rc.lua) for
[2011-12-19 19:11]     any other than this particular version of awesome may or may not work.
[2011-12-19 19:11] 
[2011-12-19 19:11] 
[2011-12-19 19:11]     You need to install one of the following programs to be able to set a background image.
[2011-12-19 19:11]         esetroot habak feh hsetroot chbg fvwm-root imlibsetroot
[2011-12-19 19:11]         display qiv xv xsri xli xsetbg wmsetbg xsetroot
[2011-12-19 19:11] 
[2011-12-19 19:11] upgraded awesome (3.4.10-1 -> 3.4.11-2)
[2011-12-19 19:53] Running 'pacman -S libxcb xcb-util-*'
[2011-12-19 19:54] Running 'pacman -S libxcb xcb-util-image xcb-util-wm xcb-util-keysyms xcb-util-renderutil'
[2011-12-19 19:54] Running 'pacman -S xcb-util'
[2011-12-19 20:07] Running 'pacman -U /tmp/yaourt-tmp-rahal/PKGDEST.6R9/cairo-xcb-1.10.2-2-i686.pkg.tar.xz'
[2011-12-19 20:07] upgraded cairo-xcb (1.10.2-2 -> 1.10.2-2)
[2011-12-19 20:15] Running 'pacman -U /tmp/yaourt-tmp-rahal/PKGDEST.hso/awesome-3.4.11-2-i686.pkg.tar.xz'
[2011-12-19 20:15] 
[2011-12-19 20:15] ==> awesome installation notes:
[2011-12-19 20:15]     ----------------------------------------
[2011-12-19 20:15]     During some updates of awesome, the config file syntax changes heavily.
[2011-12-19 20:15]     This means that your configuration file (~/.config/awesome/rc.lua) for
[2011-12-19 20:15]     any other than this particular version of awesome may or may not work.
[2011-12-19 20:15] 
[2011-12-19 20:15] 
[2011-12-19 20:15]     You need to install one of the following programs to be able to set a background image.
[2011-12-19 20:15]         esetroot habak feh hsetroot chbg fvwm-root imlibsetroot
[2011-12-19 20:15]         display qiv xv xsri xli xsetbg wmsetbg xsetroot
[2011-12-19 20:15] 
[2011-12-19 20:15] upgraded awesome (3.4.11-2 -> 3.4.11-2)
[2011-12-19 20:16] Running 'pacman -U --asdeps /tmp/yaourt-tmp-rahal/PKGDEST.cxJ/lua-oocairo-1.4-2-i686.pkg.tar.xz'
[2011-12-19 20:16] installed lua-oocairo (1.4-2)
[2011-12-19 20:17] Running 'pacman -U --asdeps /tmp/yaourt-tmp-rahal/PKGDEST.eC2/lua-oopango-1.1-1-i686.pkg.tar.xz'
[2011-12-19 20:17] installed lua-oopango (1.1-1)
[2011-12-19 20:31] Running 'pacman -U /tmp/yaourt-tmp-rahal/PKGDEST.zaY/awesome-git-20111219-1-i686.pkg.tar.xz'
[2011-12-19 20:31] Running 'pacman -Rsc awesome'
[2011-12-19 20:31] removed obvious (3.3.2-1)
[2011-12-19 20:31] removed awesome (3.4.11-2)
[2011-12-19 20:31] removed libev (4.04-1)
[2011-12-19 20:31] removed libxdg-basedir (1.1.1-1)
[2011-12-19 20:31] removed xcb-util-image (0.3.8-1)
[2011-12-19 20:31] removed xcb-util-keysyms (0.3.8-1)
[2011-12-19 20:31] removed xcb-util-wm (0.3.8-1)
[2011-12-19 20:32] Running 'pacman -U /tmp/yaourt-tmp-rahal/awesome-git-20111219-1-i686.pkg.tar.xz'
[2011-12-19 20:32] installed libxdg-basedir (1.1.1-1)
[2011-12-19 20:32] installed libev (4.04-1)
[2011-12-19 20:32] installed xcb-util-image (0.3.8-1)
[2011-12-19 20:32] installed xcb-util-keysyms (0.3.8-1)
[2011-12-19 20:32] installed xcb-util-wm (0.3.8-1)
[2011-12-19 20:32] installed awesome-git (20111219-1)
[2011-12-20 00:01] Running 'pacman -S --asdeps --needed extra/xorg-util-macros'
[2011-12-20 00:01] installed xorg-util-macros (1.16.0-1)
[2011-12-20 00:09] Running 'pacman -U /tmp/yaourt-tmp-rahal/PKGDEST.W8E/xcb-util-all-0.3.8-1-i686.pkg.tar.xz'
[2011-12-20 00:09] Running 'pacman -Rsc xcb-util'
[2011-12-20 00:09] Running 'pacman -Rc xcb-util'
[2011-12-20 00:10] Running 'pacman -Rs xcb-util'
[2011-12-20 00:16] Running 'pacman -R awesome-git'
[2011-12-20 00:16] removed awesome-git (20111219-1)
[2011-12-20 00:22] Running 'pacman -U /tmp/yaourt-tmp-rahal/PKGDEST.ezu/awesome-3.4.11-2-i686.pkg.tar.xz'
[2011-12-20 00:22] 
[2011-12-20 00:22] ==> awesome installation notes:
[2011-12-20 00:22]     ----------------------------------------
[2011-12-20 00:22]     During some updates of awesome, the config file syntax changes heavily.
[2011-12-20 00:22]     This means that your configuration file (~/.config/awesome/rc.lua) for
[2011-12-20 00:22]     any other than this particular version of awesome may or may not work.
[2011-12-20 00:22] 
[2011-12-20 00:22] 
[2011-12-20 00:22]     You need to install one of the following programs to be able to set a background image.
[2011-12-20 00:22]         esetroot habak feh hsetroot chbg fvwm-root imlibsetroot
[2011-12-20 00:22]         display qiv xv xsri xli xsetbg wmsetbg xsetroot
[2011-12-20 00:22] 
[2011-12-20 00:22] installed awesome (3.4.11-2)
ados ★★★★★ ()
Ответ на: комментарий от urxvt

awesome уже не тот, требует модули xcb-util, которые прилагаются только к новой версии.

ados ★★★★★ ()
Ответ на: комментарий от urxvt

Хотя вроде за всё время поменялись только пкгбилды, попробую...

ados ★★★★★ ()
Ответ на: комментарий от ados

У меня были проблемы пару недель назад, я откотился и все стало четко.

urxvt ★★★★★ ()

Я всегда знал (и на своем опыте тоже), что арч стабильно работает и ни разу не косячит после обновлений только у тех, кто его никогда не обновляет после установки.

anonymous ()
Ответ на: комментарий от post-factum

А что в данном контексте означает фраза «вовремя реагировать»?

anonymous ()
Ответ на: комментарий от anonymous

Читать, что во время обновления пишется на экране. 99% проблем из-за того, что не читают.

post-factum ★★★★★ ()

libxcb теперь в нескольких пакетах, вместо одного. там доп пакет поставить нужно

mrdeath ★★★★★ ()

была аналогичная проблема, решается пересборкой awesome

anonymous ()
Ответ на: комментарий от anonymous

В общем обновил полностью систему, пересобрал awesome с зависимостями и всё заработало.

ados ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.