LINUX.ORG.RU

Нормальное 3d на Radeon HD7xxx (свободный драйвер)

 , , ,


1

2

Есть ли истории успеха? Лично у меня (HD 7750) 3д (с артефактами каждые 3-4 секунды) работает только с месовским xorg-драйвером radeonsi.so. На xf86-video-ati (radeon.so) не работает ни xv, ни 3d.

кусок xorg.0.log

[ 12489.648] (II) RADEON(0): RADEONPreInit_KMS
[ 12489.648] (**) RADEON(0): Depth 24, (--) framebuffer bpp 32
[ 12489.648] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[ 12489.648] (==) RADEON(0): Default visual is TrueColor
[ 12489.648] (==) RADEON(0): RGB weight 888
[ 12489.648] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
[ 12489.648] (--) RADEON(0): Chipset: "VERDE" (ChipID = 0x683f)
[ 12489.649] (II) RADEON(0): KMS Color Tiling: disabled
[ 12489.649] (II) RADEON(0): KMS Color Tiling 2D: disabled
[ 12489.649] (II) RADEON(0): KMS Pageflipping: enabled
[ 12489.649] (II) RADEON(0): SwapBuffers wait for vsync: enabled
[ 12489.680] (II) RADEON(0): Output DisplayPort-0 using monitor section Philips
[ 12489.680] (**) RADEON(0): Option "PreferredMode" "1280x1024_60.00"
[ 12489.680] (**) RADEON(0): Option "RightOf" "HDMI-0"
[ 12489.680] (**) RADEON(0): Option "Primary" "true"
[ 12489.713] (II) RADEON(0): Output HDMI-0 using monitor section Samsung
[ 12489.713] (**) RADEON(0): Option "PreferredMode" "1280x1024_75.00"
[ 12489.713] (**) RADEON(0): Option "Position" "0 0"
[ 12489.713] (**) RADEON(0): Option "Primary" "false"
[ 12489.731] (II) RADEON(0): Output DVI-0 using monitor section Philips
[ 12489.731] (**) RADEON(0): Option "PreferredMode" "1280x1024_60.00"
[ 12489.731] (**) RADEON(0): Option "RightOf" "HDMI-0"
[ 12489.731] (**) RADEON(0): Option "Primary" "true"
[ 12489.751] (II) RADEON(0): EDID for output DVI-0
[ 12489.751] (II) RADEON(0): Printing probed modes for output DVI-0
[ 12489.790] (II) RADEON(0): EDID for output DisplayPort-0
[ 12489.823] (II) RADEON(0): EDID for output HDMI-0
[ 12489.823] (II) RADEON(0): Manufacturer: SAM  Model: 194  Serial#: 1112092985
[ 12489.823] (II) RADEON(0): Year: 2006  Week: 1
[ 12489.823] (II) RADEON(0): EDID Version: 1.3
[ 12489.823] (II) RADEON(0): Digital Display Input
[ 12489.823] (II) RADEON(0): Max Image Size [cm]: horiz.: 38  vert.: 30
[ 12489.823] (II) RADEON(0): Gamma: 2.20
[ 12489.823] (II) RADEON(0): DPMS capabilities: Off
[ 12489.823] (II) RADEON(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
[ 12489.823] (II) RADEON(0): First detailed timing is preferred mode
[ 12489.823] (II) RADEON(0): redX: 0.640 redY: 0.329   greenX: 0.300 greenY: 0.600
[ 12489.823] (II) RADEON(0): blueX: 0.150 blueY: 0.060   whiteX: 0.313 whiteY: 0.329
[ 12489.823] (II) RADEON(0): Manufacturer's mask: 0
[ 12489.823] (II) RADEON(0): Supported standard timings:
[ 12489.823] (II) RADEON(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
[ 12489.823] (II) RADEON(0): #1: hsize: 1280  vsize 960  refresh: 60  vid: 16513
[ 12489.823] (II) RADEON(0): #2: hsize: 1152  vsize 864  refresh: 75  vid: 20337
[ 12489.823] (II) RADEON(0): Supported detailed timing:
[ 12489.823] (II) RADEON(0): clock: 108.0 MHz   Image Size:  376 x 301 mm
[ 12489.823] (II) RADEON(0): h_active: 1280  h_sync: 1328  h_sync_end 1440 h_blank_end 1688 h_border: 0
[ 12489.823] (II) RADEON(0): v_active: 1024  v_sync: 1025  v_sync_end 1028 v_blanking: 1066 v_border: 0
[ 12489.823] (II) RADEON(0): Ranges: V min: 56 V max: 75 Hz, H min: 30 H max: 81 kHz, PixClock max 145 MHz
[ 12489.823] (II) RADEON(0): Output DVI-0 connected
[ 12489.823] (II) RADEON(0): Output DisplayPort-0 disconnected
[ 12489.823] (II) RADEON(0): Output HDMI-0 connected
[ 12489.823] (II) RADEON(0): Using user preference for initial modes
[ 12489.823] (II) RADEON(0): Output DVI-0 using initial mode 1280x1024_60.00
[ 12489.824] (II) RADEON(0): Output HDMI-0 using initial mode 1280x1024_75.00
[ 12489.824] (II) RADEON(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[ 12489.824] (II) RADEON(0): mem size init: gart size :1fbff000 vram size: s:40000000 visible:fac0000
[ 12489.824] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM
[ 12489.824] (++) RADEON(0): DPI set to (76, 76)
[ 12489.824] (II) RADEON(0): Front buffer size: 10240K
[ 12489.824] (II) RADEON(0): VRAM usage limit set to 221788K
[ 12489.824] (==) RADEON(0): Backing store disabled
[ 12489.824] (WW) RADEON(0): Direct rendering disabled
[ 12489.824] (II) RADEON(0): Acceleration disabled
[ 12489.824] (II) RADEON(0): Initializing DPMS
[ 12489.824] (==) RADEON(0): DPMS enabled
[ 12489.824] (II) RADEON(0): Initializing Cursor
[ 12489.824] (==) RADEON(0): Silken mouse enabled
[ 12489.824] (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 12489.824] (II) RADEON(0): Initializing kms color map
[ 12489.824] (WW) RADEON(0): Option "UseEDID" is not used
[ 12489.824] (WW) RADEON(0): Option "VendorName" is not used
[ 12489.824] (WW) RADEON(0): Option "ModelName" is not used
[ 12489.824] (WW) RADEON(0): Option "Primary" is not used
[ 12489.824] (WW) RADEON(0): Option "RightOf" is not used
[ 12489.825] (WW) RADEON(0): Option "PreferredMode" is not used
[ 12489.825] (WW) RADEON(0): Option "DPI" is not used
[ 12489.825] (II) RADEON(0): RADEONScreenInit finished
[ 12489.941] (II) RADEON(0): Setting screen physical size to 855 x 342

xorg.conf:

Section "Device"
	Identifier "Radeon0"
	Driver     "radeon"
	Option	   "Monitor-HDMI-0" "Samsung"
	Option	   "Monitor-DVI-0" "Philips"
EndSection

Section "Screen"
	Identifier	"Screen0"
	Device		"Radeon0"
	Monitor		"Samsung"
	Monitor		"Philips"
	DefaultDepth	24
	Subsection "Display"
		Viewport 0 	0
		Depth	24
		Virtual	2560 1024
	EndSubSection
EndSection

Section "Monitor"
	Option "UseEDID" "False"
	Identifier	"Samsung"
	Option	"VendorName" 	"SyncMaster"
	Option	"ModelName"	"930bf"
	Option 	"Primary"	"false"
	Option	"Position"	"0 0"
	Option	"PreferredMode"	"1280x1024_75.00"
	Modeline "1280x1024_75.00" 138.54 1280 1368 1504 1728 1024 1025 1028 1069 -HSync +Vsync
	DisplaySize 378 302
	Option "DPI" "86x86"
EndSection

Section "Monitor"
	Option "UseEDID" "False"
	Identifier	"Philips"
	Option	"VendorName"	"Philips"
	Option	"ModelName"	"170s"
	Option	"Primary"	"true"
	Option	"RightOf"	"HDMI-0"
	Option	"PreferredMode" "1280x1024_60.00"
	Modeline "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync
	DisplaySize 336 269
	Option "DPI" "96x96"
EndSection

Section "ServerFlags"
        Option     "AccelMethod" "glamor"
EndSection

иксы 1.13.1, xf86-video-ati,mesa и прочее из гита. Фирмваря грузится нормально, дмесг ничего путного не выдает.
З.Ы. Как детальнее просмотреть процесс загрузки иксового драйвера?

с артефактами каждые 3-4 секунды

Репорти @ Пересобирай

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от smilessss

сменить на EXA

EXA с GCN не работает, только glamor.

devl547 ★★★★★ ()
Ответ на: комментарий от daemonpnz

Еще бы она работала как надо. Спасибо, покушал блоба, когда еще моя HD5670 дичайше тормозила, пока не включишь композитинг.

no-steam ★★ ()
Ответ на: комментарий от daemonpnz

Да не. Там какая-та несовместимость с моей картой была. На hd5670 от msi все нормально (за исключением того, что оно все равно тормозит, по сравнению с свободкой).
И да, блоб пробовал. Три паники за день, тонны срача в dmesg... Спасибо, больше не хочу.

no-steam ★★ ()

Ставь блоб. Между тем, как для моего rv630 заявили поддержку, и тем, когда им стало возможно пользоваться без зависаний по 5 раз в день, прошло больше года.

anonymous ()
Ответ на: комментарий от daemonpnz

tell me more

Ну например блоб от AMD — глючное говно. Рекордный аптайм у меня с ним был две недели, это просто ***ный стыд. Ещё что рассказать? Может, про бесполезный и кривой Xv? Про столь же бесполезный XvBA? Про исключительно глобальные настройки в /etc/ati/? Про лотерею с выводом фулл-хд видео через OpenGL?

anonymous ()

Попробуй ядро 3.8, libdrm-9999, xf86-video-ati тоже 9999. Ибилд с radeonsi 9999, не знаю как называется. Ну и mesa-9999. Если и с этим не заработает, то никак. Подожди.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Behem0th

Такой свежатины у меня нет. На моей 4830 видео выводится норм, а вот серьёзный сэм 3, виснет периодически. Жду нового релиза легаси драйвера.

daemonpnz ★★★★★ ()
Ответ на: комментарий от Behem0th

Я тут пока выяснил что косяк не в видео, а в звуке т.е в связке openal + alsa... будем ковырять

daemonpnz ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

И так. За исключением ядра. Но это надо ребутнуться, а мне лень пока. Завтра.

no-steam ★★ ()
Ответ на: комментарий от no-steam

И получай тиринг [/thread]

Ты эта, свежий блоб поставь. Новее 11.10. Там есть tearing-free desktop.

ekzotech ★★★★ ()

по моему скромному мнению в fglrx 13.1 все нормально, в то время как radeon до такого же нормального состояния можно до конца жизни допиливать

Radius ★★★★ ()
Ответ на: комментарий от Radius

по моему скромному мнению в fglrx 13.1 все нормально

Точно, там же VSync вообще к херам поломали :)

в то время как radeon до такого же нормального состояния можно до конца жизни допиливать

Хорошо, что это только скромное мнение человека, которого не смутит случайное зависание графики раз в недельку-другую. А вот меня такие вещи почему-то огорчают. Так что этот ваш катаклизм не нужен.

anonymous ()
Ответ на: комментарий от Behem0th

На Radeon HD 7950 у меня бывает виснет.

У меня это было на HD6450. Перезапустить графику не удалось, пришлось заходить по SSH и перезагружать всю систему :(

anonymous ()
Ответ на: комментарий от anonymous

Точно, там же VSync вообще к херам поломали :)

я только заметил что в opengl vsync работает и прекрасно отключается/включается в гуишной этой amd ccc

вообще давай рассказывай больше, у меня 7 компов с fglrx и 24 видяшками в сумме - аптайм по несколько месяцев.

нативные игры тоже гонял с 13.1, не поверишь - ничего не упало ни разу и фпс 100-300

у fglrx и radeon просто разные сферы применения, которые у нас с тобой видимо не пересекаются

Radius ★★★★ ()
Ответ на: комментарий от Radius

Не хотел создавать новую тему раз уж в этой обсуждается подобный вопрос....

3й день не могу подружить 13.1 drv с ATI 4250/Fedora 18.

На F16 зачетно встал предыдущий драйвер перед 13.1(c amd.com). После апдейта F16>F17>F18 также fgrlx работал,Steam\CSS запускался без проблем.

Но из-за стремления ко всему новому )) была попытка установить - «AMD Catalyst™ 13.1 Proprietary Linux x86 Display Driver»

Методом проб и ошибок поставил драйвер через yum? сейчас dmesg выдает следующее

[fglrx] Maximum main memory to use for locked dma buffers: 7589 MBytes.

<3>[fglrx:firegl_init_device_list] *ERROR* No supported display adapters were found

<3>[fglrx:firegl_init_module] *ERROR* firegl_init_devices failed

aticonfig говорит что не найдено совместимых устройств

Иксы запускаются только с драйвером «vesa»

Вопрос как вернуть fgrlx к жизни?

Спасибо за понимание ))

doctor-ua ()
Ответ на: комментарий от smilessss

если удаление 1.13 иксов не потянет за собой 5 гиг зависимостей - попробую.

catalyst-legacy ставить тот что через yum или все так пробовать офф пакет с amd.com? спс за ответ.

doctor-ua ()
Ответ на: комментарий от doctor-ua

офф пакет с amd.com

зло.
нужно ставить пакет под свой дистр - у меня в арче репа есть catalyst 234 - Я оттуда ставил и каталист и иксы

если удаление 1.13 иксов

если только есть софт завязан именно на 1.13 то да
если просто на иксах - то удалять не нужно - просто поставить сверху, пакетный менеджер должен сам разрулить.

smilessss ★★★★★ ()
Ответ на: комментарий от doctor-ua

У иксов на самом деле мало зависимостей. Кроме дров - меза и еще по мелочи. Если потянет удаление всего, значит есть метапакеты, которые содержат xorg. Их в этом случае нужно удалить, но при этом отменить удаление всего остального (например метапакет кде при удалении xorg, потянет все кде, но чтобы избежать удаления, достаточно пометить все нужные пакеты на установку).

catalyst-legacy ставить тот что через yum или все так пробовать офф пакет с amd.com? спс за ответ.

В дистрибутиве с пакетным менеджером, следует ставить через пакетный менеджер. Как минимум проще менеджмент в дальнейшем.

ps: извиняюсь за возможные неточности, я не знаю нюансов твоего дистрибутива

Radius ★★★★ ()
Ответ на: комментарий от Radius

ок попробую удалить всё, что связано с xorg-x11 все kmod/akmod и драйвера АТИ которые поставились через yum. Установлю Иксы с 0.

Потом отпишу.

doctor-ua ()

этот тред полон боли амд-фоннатов :)

думаю, такие треды - убедительный аргумент в пользу повсеместного сноса по 4.2 пропаганды типа «бери АМД, она дружит с сообществом, у неё хорошие драйвера и всё такое» :)

anonymous ()
Ответ на: комментарий от RussianNeuroMancer

Затем что дрв. перестал работать после теперь уже не нужной установки 13.1. Сейчас Иксы запускаются только с веса драйвером.

doctor-ua ()
Ответ на: комментарий от doctor-ua

Поставь xf86-video-radeon или как он там в твоем дистре называется.

no-steam ★★ ()
Ответ на: комментарий от doctor-ua

Затем что дрв. перестал работать после теперь уже не нужной установки 13.1.

Ну... удалите его, да переустановите Месу и свободный драйвер.

RussianNeuroMancer ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.