LINUX.ORG.RU

Проблемы при установке драйверов nVidia в Ubuntu 18.04

 , , , ,


0

1

Как бы я не старался, я не смог грамотно составить топик. Поэтому, тут будет лишь видеоматериал.

Устанавливал драйвер по этой инструкции: http://help.ubuntu.ru/wiki/%D0%B4%D1%80%D0%B0%D0%B9%D0%B2%D0%B5%D1%80_%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE%D0%BA%D0%B0%D1%80%D1%82_nvidia

При попытке установить драйвер через GUI из репозитория "http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu" происходило: https://youtu.be/XlXaTV-unEI

При попытке установить драйвер через shell сценарий, загруженого премяком из сайта Nvidia происходило следующее: https://youtu.be/mmieOZnD7OU

Установка драйвера из официального репозитория Ubuntu: https://youtu.be/KIz2APhUiu4

Установка более новой версии драйвера из PPA: https://youtu.be/aSfVORbR6Vo

Установка драйвера с официального сайта Nvidia: https://youtu.be/RnBnaATB0Zk

Xubuntu 18.04 (32bit) NVidia GeForce 7600 GS

Deleted

Ответ на: комментарий от Deleted

Видите ли, здесь полно народа, который не воспринимает видео, им нужны текстовые логи. Так что, для полноты аудитории, советую привести и их.

tiinn ★★★★ ()

Поставь w10, не мучайся уже.
Я даже хз, что тебе сказать по твоему вопросу. Как по мне, у не осиливших установить видеодрайвер нужно регистрацию отбирать и запрещать постить в техразделы

sehellion ★★★★★ ()
Ответ на: комментарий от ozz_is_here

Как ты мог сделать столько ошибок в слове «дос»? В линуксе последние лет 20 драйвер ставится элементарно. В данном случае, самое сложное — это знать, что для твоей карты нужен legacy драйвер, что, в общем-то, не является линукс-специфичным и требуется для любой ОС.

redgremlin ★★★★★ ()
Ответ на: комментарий от anonymous
apt-cache show nvidia-legacy-304xx-driver
<cut>
This legacy version is the last release that supports the following GPUs:
<cut>
 GeForce 7550 LE [G72], GeForce 7600 GS [G73], GeForce 7600 GT [G73],
 GeForce 7600 LE [G73], GeForce 7650 GS [G73], GeForce 7800 GS [G70],
redgremlin ★★★★★ ()

Уноси свой youtube отсюда. Это все элементарно гуглится, если не смог найти то и линукс боюсь тебе не нужен. Ставь W10, она лучше для тебя. На будущее, нормальные люди все логи выкладывают в текстовом виде.

karton1 ★★★★★ ()
Ответ на: комментарий от anonymous

Если я тебе скажу. что ты не умеешь делать минет, а ты скажешь, что тебе и не нужно. То, как думаешь, адекватным ли будет ответом , что ты просто оправдываешься?

sehellion ★★★★★ ()
Ответ на: комментарий от karton1

Уноси свой youtube отсюда

Из самого первого ответа понял, что пора переписать топик.

Это все элементарно гуглится

Ну раз ты смог узнать информацию, то можешь предоставить её?

в текстовом виде

Понял.

Deleted ()
Ответ на: комментарий от sehellion

Аналогия не очень. Ибо без systemd в линуксах сейчас по факту никак. А без минета вполне можно прожить.

anonymous ()
Ответ на: комментарий от sehellion

Типичный системдхейтер, одни минеты в голове. Не маняврируй - не умеешь - пароль на стол.

anonymous ()
Ответ на: комментарий от Deleted

Хосспаде, видео драйвера (запомни раз и навсегда) в линуксе ставятся ТОЛЬКО из репозитория, никаких шелл скриптов с сайта, при обновлении ядра отвалится у тебя видео и все. графическая утилита может не работать, это линукс детка, тут что бы что то гарантировано сделать надо открыть консоль.

пакеты у тебя там битые вроде судя по видео, в консоли выполни: sudo apt-get -f install и с зависимостями что то ты намудрил.

karton1 ★★★★★ ()
Последнее исправление: karton1 (всего исправлений: 2)
Ответ на: комментарий от anonymous

Без него тоже пока вполне живется неплохо.

системдхейтер

да то с вами, убогими, спорить. просто не пользуюсь

sehellion ★★★★★ ()
Ответ на: комментарий от karton1

Ставил я систему через mini.iso. Не знаю, связано это, или нет, но пока я не полез добавлять репозитории с видеодрайверами, в «дополнительные драйвера» была пустота, но помню на Ubuntu 16.04 всё и «из коробки» в GUI установилось.

Deleted ()
Ответ на: комментарий от karton1

Вывод:

hugonote@PC:~$ sudo apt-get -f install
[sudo] пароль для hugonote: 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  libxnvctrl0 screen-resolution-extra
Для их удаления используйте «sudo apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 128 пакетов не обновлено.
hugonote@PC:~$ 
Deleted ()
Ответ на: комментарий от karton1

Увидел на сайте Убунты, что 18.04 можно через mini.iso установить, что я и сделал, пока вчера не понял, что можно было нормально скачать Lubuntu, или Xubuntu 18.04 на 32бит, и не париться.

Deleted ()
Ответ на: комментарий от Deleted

Ну как бы да, в mini вечно чего то не докладывают, а даже ssd в 2018 году имеют достаточно места и выгадывать лишние 5 Gb на них смысла нет, я уже не говорю про HDD.

karton1 ★★★★★ ()
Ответ на: комментарий от karton1

Вывод:

hugonote@PC:~$ sudo apt autoremove
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакеты, которые будут УДАЛЕНЫ:
  libxnvctrl0 screen-resolution-extra
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 2 пакетов, и 128 пакетов не обновлено.
После данной операции, объём занятого дискового пространства уменьшится на 124 kB.
Хотите продолжить? [Д/н] Д
(Чтение базы данных … на данный момент установлено 228416 файлов и каталогов.)
Удаляется libxnvctrl0:i386 (396.24-0ubuntu0~gpu18.04.1) …
Удаляется screen-resolution-extra (0.17.3) …
Обрабатываются триггеры для libc-bin (2.27-3ubuntu1) …
Обрабатываются триггеры для dbus (1.12.2-1ubuntu1) …

Всё прошло успешно.

Deleted ()
Ответ на: комментарий от Deleted

Я бы так сделал. Скачал бы полный образ и поставил с нуля, если ничего ценного в системе нет. Хочешь попробуй разберись с проблемой, опыта заодно прибавится, но я что бы не парится поставил бы тупо с нуля.

karton1 ★★★★★ ()
Ответ на: комментарий от Deleted

XFCE, оно пофункциональней буде. С 1 Гб ОЗУ попробуй Zswap если процессор нормальный, если же все дохлое, то хоть ssd поставь чисто под файл подкачки, что бы не тормозило. lxde пилить под себя придется.

karton1 ★★★★★ ()

Мда... вывод терминала картинкой — ещё куда не шло, но видео?!

Массаракш, это текст, его копировать можно! Ты же делаешь это на видео. Нам что, вручную вывод ошибок перепичатывать?

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Хватит прогибаться под тупые машины, пусть по видео распознают.

anonymous ()

Похоже наступает эпоха видеоблогерров на лоре.

Deleted ()
Ответ на: комментарий от dhameoelin

Ну, попробуй так ssh brow.sh
Как по мне, так весьма неплохо, но требует доработок

sehellion ★★★★★ ()
Ответ на: комментарий от karton1

никаких шелл скриптов с сайта, при обновлении ядра отвалится у тебя видео и все.

с разморозкой. как там у вас в теплом ламповом ХХ веке?

dkms? не, не слышал

anonymous ()
Ответ на: комментарий от icefreeze

Ждать когда ответят на форуме кончено быстрее, чем пойти и самому посмотреть. Писц, ну что за поколение.

anonymous ()

нихерасе вас бомбит

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.