LINUX.ORG.RU

Ноутбук Dell не грузится, black screen после grub [РЕШЕНО]

 , , ,


2

2

В общем. Поменял Asus X200MA на Dell с N3710. Теперь фича: не грузится без nomodeset. С nomodeset не работает настройка яркости экрана. /sys/class/brightness пуст. Как заставить работать без nomodeset? Pentium N3710. Ах да. Не грузится - это черный экран сразу после Grub.

Update: задача решена! Действительно, компьютеры Dell не хотят грузиться в случае, если в UEFI режиме указан «Enable Legacy boot».

Для корректной работы Linux'a на Dell Inspiron 3452/3552 достаточно прописать acpi_osi=Linux (начинают работать все функциональные клавиши, а не только часть) и отключить Legacy boot. Кроме того, пытался обновить UEFI до последней версии, но это не помогло. Тем не менее, у меня сейчас последний UEFI на данный момент (сентябрьский, 2016 года).

И да, яркость регулируется с помощью intel_backlight, а не acpi_backlight=vendor. Поэтому последний не нужен. Он (dell_backlight) и не появится, если не указать acpi_backlight. Это не ASUS.

За решение спасибо тов. timdorohin.

Deleted

Тут толко 2 варианта:

  1. Shut up and hack!
  2. Поставить OS предписанную производителем.

Но так как на первое, похоже что, кишка тонка, а на второе религиозные предрассудки мешают, жрите, что дают и не нойте.

beastie ★★★★★ ()

А зачем nomodeset? Вроде современные графические direct rendering драйверы фатально несовместимы с этим режимом. Единственный смысл nomodeset, о котором я знаю - остаться в натуральной VGA-консоли и читать вывод процесса загрузки ядра в scrollback-буфере.

Andrey_Utkin ★★ ()
Ответ на: комментарий от beastie

Судя по интернетам, достаточно отключить функционал Legacy OS support. В момент, когда Legacy и UEFI поддерживаются вместе - не работает. С утра проверю.

Интересно, но это даже здесь написано: http://www.dell.com/support/article/ru/ru/rudhs1/SLN297060/en

Deleted ()
Ответ на: комментарий от Andrey_Utkin

Без него не грузится совсем. Black screen на момент старта Plumorth/ . То есть на момент, когда подгружается i915, насколько я понял.

Deleted ()

Почешите cвою репу своей левой пяткой. Очень помогает... :)

anonymous ()

Для регулировки яркости интернеты советуют acpi_backlight=vendor

ashot ★★★ ()
Ответ на: комментарий от ashot

Windows 8 игнорирует подсветку в ACPI, поэтому там часто нерабочий код.

i-rinat ★★★★★ ()
Ответ на: комментарий от ashot

мне в придачу к этому пришлось ещё и конфиг для Xorg готовить (ноут lenovo)

cat 20-intel.conf

Section "Device"
	Identifier  "card0"
	Driver      "intel"
	Option      "AccelMethod"     "sna"
	Option      "Backlight"       "intel_backlight"
	BusID       "PCI:0:2:0"
EndSection


... без него не работает.

SkyMaverick ★★ ()

beastie, Andrey_Utkin, ashot, i-rinat, SkyMaverick всем спасибо. Проблема решена. За решение спасибо timdorohin.

Оказалось, что Dell не дружит со смешанным режимом UEFI/Legacy boot. И, судя по данной ссылке от Dell проблема может затрагивать даже Dell XPS. В моём случае ноутбук Dell Inspiron 3552 (идентичен 3452, за исключением экрана).

Deleted ()
Ответ на: комментарий от SkyMaverick

Это в случае, если в /sys/class/backlight находится 2 и более вариантов подсветки (intel_backlight, acpi0_backlight, dell_backlight, и подобные). Так что может быть тебе стоит исключить acpi_backlight=vendor и установить только acpi_osi=Linux. Написал это и обнаружил, что подсветка перестала регулироваться. :D Пойду чинить.

Deleted ()
Последнее исправление: merhalak (всего исправлений: 1)

компьютеры Dell не хотят грузиться в случае, если в UEFI режиме указан «Enable Legacy boot»

Серьёзно? И как это мой Dell Inspiron 3721 грузится, интересно. Магия, не иначе.

sluggard ★★★★★ ()
Ответ на: комментарий от sluggard

Похоже, затрагивает не всех. Непонятно почему. Пусть висит, как вариант решения. Кто захочет - быстро найдет на форуме.

Deleted ()
Последнее исправление: merhalak (всего исправлений: 1)
Ответ на: комментарий от kostik87

Уже обновлен до последней версии был. Сделал первым шагом после обнаружения проблемы.

Deleted ()
Ответ на: комментарий от Deleted

только acpi_osi=Linux

Пробовал, не работает. Я тоже долго с подсветкой провозился (lenovo b570e), пока вот это решение придумалось (а потом нашлось в сети и сократилось в окончательный вариант).

Хорошо что проблема решилась, занесу топик в закладки.

SkyMaverick ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.