LINUX.ORG.RU

Dell Venue 11 Pro 7130. Не работает wifi

 , , ,


0

1

Собственно сабж. Ставил Убунту 14.04 и 15.10. В обоих случаях wifi-карта не видна. lspci вроде о ней вообще ничего не знает. В uefi все включено.

Карта в венде опознается как Dell Wireless 1537, by Qualcomm Atheros.

Девайс http://www.dell.com/ru/business/p/dell-venue-11-pro/pd вендовый «планшет» на core i5.

Гугл ничего вменяемого не дает. Наткнулся вот на такую тему: http://ubuntuforums.org/showthread.php?t=2230888

С английским у меня плохо, но насколько я понял, решения там не предложили.

Никто не сталкивался, куда копать? Если нужно, то вывод каких команд показать или какую еще информацию дать, чтобы было более понятно?

Пробовал ставить федору 23 lxde, но та вылетает в консоль на стадии запуска с какой-то ошибкой. Не стал разбираться, но если есть информация, что там работает, то попробую.

На всякий случай cast Dimez. Хоть ты и сказал, что такого девайса у тебя более нет, но вдруг чего вспомнится.

UPD:

В итоге помог совет анонимуса (или markone, написавшего из под анонимуса:) сменить модуль wi-fi: Dell Venue 11 Pro 7130. Не работает wifi (комментарий) Купил Intel Dual Band Wireless 7260NGW AN, встал без проблем, сразу подхватился. Запустить родной модуль Dell Wireless 1537, by Qualcomm Atheros я так и не осилил.

★★★★★

lspci вроде

Давай сюда вывод lspci -vknn

false ★★★★★ ()
Ответ на: комментарий от false

00:00.0 Host bridge [0600]: Intel Corporation Haswell-ULT DRAM Controller [8086:0a04] (rev 0b)
	Subsystem: Dell Device [1028:0604]
	Flags: bus master, fast devsel, latency 0
	Capabilities: <access denied>

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:0a1e] (rev 0b) (prog-if 00 [VGA controller])
	Subsystem: Dell Device [1028:0604]
	Flags: bus master, fast devsel, latency 0, IRQ 61
	Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at f000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915

00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
	Subsystem: Dell Device [1028:0604]
	Flags: bus master, fast devsel, latency 0, IRQ 62
	Memory at f7d14000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel

00:14.0 USB controller [0c03]: Intel Corporation Lynx Point-LP USB xHCI HC [8086:9c31] (rev 04) (prog-if 30 [XHCI])
	Subsystem: Dell Device [1028:0604]
	Flags: bus master, medium devsel, latency 0, IRQ 57
	Memory at f7d00000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: <access denied>
	Kernel driver in use: xhci_hcd

00:16.0 Communication controller [0780]: Intel Corporation Lynx Point-LP HECI #0 [8086:9c3a] (rev 04)
	Subsystem: Dell Device [1028:0604]
	Flags: bus master, fast devsel, latency 0, IRQ 59
	Memory at f7d1d000 (64-bit, non-prefetchable) [size=32]
	Capabilities: <access denied>
	Kernel driver in use: mei_me

00:1b.0 Audio device [0403]: Intel Corporation Lynx Point-LP HD Audio Controller [8086:9c20] (rev 04)
	Subsystem: Dell Device [1028:0604]
	Flags: bus master, fast devsel, latency 0, IRQ 60
	Memory at f7d10000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel

00:1c.0 PCI bridge [0604]: Intel Corporation Lynx Point-LP PCI Express Root Port 4 [8086:9c16] (rev e4) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	Memory behind bridge: f7c00000-f7cfffff
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:1f.0 ISA bridge [0601]: Intel Corporation Lynx Point-LP LPC Controller [8086:9c43] (rev 04)
	Subsystem: Dell Device [1028:0604]
	Flags: bus master, medium devsel, latency 0
	Capabilities: <access denied>
	Kernel driver in use: lpc_ich

00:1f.2 SATA controller [0106]: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] [8086:9c03] (rev 04) (prog-if 01 [AHCI 1.0])
	Subsystem: Dell Device [1028:0604]
	Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 58
	I/O ports at f0b0 [size=8]
	I/O ports at f0a0 [size=4]
	I/O ports at f090 [size=8]
	I/O ports at f080 [size=4]
	I/O ports at f060 [size=32]
	Memory at f7d1a000 (32-bit, non-prefetchable) [size=2K]
	Capabilities: <access denied>
	Kernel driver in use: ahci

00:1f.3 SMBus [0c05]: Intel Corporation Lynx Point-LP SMBus Controller [8086:9c22] (rev 04)
	Subsystem: Dell Device [1028:0604]
	Flags: medium devsel, IRQ 255
	Memory at f7d19000 (64-bit, non-prefetchable) [size=256]
	I/O ports at f040 [size=32]

01:00.0 SD Host controller [0805]: O2 Micro, Inc. Device [1217:8621] (rev 01) (prog-if 01)
	Subsystem: O2 Micro, Inc. Device [1217:0002]
	Flags: bus master, fast devsel, latency 0, IRQ 19
	Memory at f7c01000 (32-bit, non-prefetchable) [size=4K]
	Memory at f7c00000 (32-bit, non-prefetchable) [size=2K]
	Capabilities: <access denied>
	Kernel driver in use: sdhci-pci

another ★★★★★ ()
Ответ на: комментарий от false

Linux skiv-Venue-11-Pro-7130-MS 3.13.0-74-generic #118-Ubuntu SMP Thu Dec 17 22:52:10 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

another ★★★★★ ()
Ответ на: комментарий от another

Во-первых вот тебе проблема с ядром.

Пробуй арчи (Manjaro). Такие буки новые, значит и чипы тоже новые для них.

bookman900 ★★★★★ ()
Ответ на: комментарий от another

Там рычажков железных нет? Попробуй ядро новее, и выложи куда-нибудь вывод dmesg

false ★★★★★ ()
Ответ на: комментарий от another

Надыбал тут

https://applelife.ru/threads/dell-venue-11-pro.43525/

Также приложил отчет сделанный AIDA 64 и фото трёх m.2 NGFF разъемов в SSD и wi-fi. Фото http://storage9.static.itmages.ru/i/14/1001/h_1412175669_2226443_7ed5d42bcf.jpg По фото WiFi модуль Dell DW1537, он же Qualcomm-Atheros QCSNFA282

Идентификаторы из отчета AIDA 64: Dell Wireless 1537 802.11 a/g/n Adapter Аппаратный ID SD\VID_0271&PID_0419

По этим данным, чипсет Atheros AR6004: https://wikidevi.com/files/Atheros/specsheets/AR6004.pdf Использует шину SDIO. Поднять под OS X - невозможно.

Для точного ответа по замене, тут нужно проверять физически, есть ли в слоте сигналы шины PCI-Express. И если они там действительно есть, то можно использовать Broadcom BCM94352Z. Вот тут я подробно рассказывал: https://applelife.ru/threads/wi-fi-moduli-v-formate-pci-express-m-2-ngff.4192...

Вроде должен поддерживаться ath6kl

http://linuxwireless.org/en/users/Drivers/ath6kl/

false ★★★★★ ()
Ответ на: комментарий от false

Вроде должен поддерживаться ath6kl

Это его надо собрать из исходников самостоятельно или можно как-то вручную загрузить из имеющихся? я честно говоря в этом не очень понимаю. modprobe такой драйвер может загрузить (он его видит, кстати), или это при старте системы надо как-то что-то запускать?

another ★★★★★ ()
Ответ на: комментарий от another

Попробуй руками сначала: modprobe ath6kl, и посмотри что изменится

false ★★★★★ ()
Ответ на: комментарий от false

сделал sudo modprobe ath6kl_core потом sudo modprobe ath6kl_sdio

Вроде ничего не поменялось, wifi нет, lspci ничего не показывает.

another ★★★★★ ()
Последнее исправление: another (всего исправлений: 1)
Ответ на: комментарий от another

В lspci его не будет, он на другой шине висит. Смотри что в dmesg упало

false ★★★★★ ()
Ответ на: комментарий от another

А зачем modprobe ath6kl_core? Просто modprobe ath6kl не работает?

false ★★★★★ ()
Ответ на: комментарий от false

После запуска modprobe ath6kl_core вроде появляется вот такое:

[   52.698197] cfg80211: World regulatory domain updated:
[   52.698202] cfg80211:  DFS Master region: unset
[   52.698203] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   52.698206] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   52.698209] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   52.698210] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[   52.698212] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   52.698214] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)

После sudo modprobe ath6kl_sdio ничего не меняется. Есть еще sudo modprobe ath6kl_usb, но он наверное не имеет ко всему этому отношения.

another ★★★★★ ()
Ответ на: комментарий от false

Баш подставляет название имеющихся модулей, так что я через TAB выбираю. Если загружать ath6kl, то получается

modprobe: FATAL: Module ath6kl not found.

another ★★★★★ ()
Ответ на: комментарий от another

Покажи-ка вывод

find /lib/modules/`uname -r` -name 'ath6kl*'

false ★★★★★ ()
Ответ на: комментарий от another

Загрузи и usb тоже, я не встречал просто такого модуля (у меня гента и его там нет, да и комп выключен уже). dmesg после этого целиком залей опять на пастебин, из этого куска неясно

false ★★★★★ ()
Ответ на: комментарий от false
/lib/modules/4.3.3-040303-generic/kernel/drivers/net/wireless/ath/ath6kl
/lib/modules/4.3.3-040303-generic/kernel/drivers/net/wireless/ath/ath6kl/ath6kl_sdio.ko
/lib/modules/4.3.3-040303-generic/kernel/drivers/net/wireless/ath/ath6kl/ath6kl_usb.ko
/lib/modules/4.3.3-040303-generic/kernel/drivers/net/wireless/ath/ath6kl/ath6kl_core.ko

Может я туплю и как-то надо перезапустить нетворкменеджер? /etc/init.d/networking restart ничего вроде не дает.

another ★★★★★ ()
Ответ на: комментарий от another

Не, смотри в ifconfig -a, там интерфейс должен появиться в случае успеха. Прдгрузи еще и ath6kl_usb и dmesg перезалей

false ★★★★★ ()
Ответ на: комментарий от false

В ifconfig только eth0 и lo.

Спасибо за помощь, судя по всему пора заканчивать. На сегодня не судьба. :) Буду думать и гуглить дальше.

another ★★★★★ ()
Ответ на: комментарий от false
Bus 002 Device 002: ID 2109:0812  
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 114d:1000 Alpha Imaging Technology Corp. 
Bus 001 Device 005: ID 0bda:5751 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 006: ID 0b95:772b ASIX Electronics Corp. AX88772B
Bus 001 Device 004: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 2109:2812  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
another ★★★★★ ()
Ответ на: комментарий от another

Угу. Вообще странно, что он в dmesg даже не появляется.

false ★★★★★ ()
Ответ на: комментарий от false

Ты про usb? В dmesg вроде вот такое появляется:

[ 1186.343784] usbcore: registered new interface driver ath6kl_usb

В новом году попробую ядро 4.4RC7 накатить, посмотрю что будет, мало ли. Девайс не покупал, на работе дали «на поиграццо», ибо купили на пробу, а оказался не сильно нужен. Но всё равно немного обидно, хотел попробовать как она, офисная работа на линуксе.

PS: Кстати, если кто будет читать тему, то помимо wifi есть еще как минимум один глюк - после подключения мышки напрочь перестает работать сенсорный экран. Отключение мышки уже не помогает.

another ★★★★★ ()
Ответ на: комментарий от another

Нет, меня смущает то, что WiFi адаптер в dmesg не появляется, хотя он вроде должен отсвечивать

false ★★★★★ ()

У меня был более новый на core m... Тач с мышкой и клавиатурой работал одновременно. Цеплял через мониторный usb hub. Wifi подцепился сам даже в live flash, я даже не помню, какой он был.

Deleted ()
Ответ на: комментарий от Deleted

Тач с мышкой и клавиатурой работал одновременно

Ну это вряд ли от железа зависит, наверное какой-то безумный скрипт отрабатывает отключение тача при подключении мыши. Такое удобно для ноутов с тачпадом, чтобы последний не мешался при наборе текста.

another ★★★★★ ()
Ответ на: комментарий от false

А вот этот кусок dmesg что значит?

[   52.698197] cfg80211: World regulatory domain updated:
[   52.698202] cfg80211:  DFS Master region: unset
[   52.698203] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   52.698206] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   52.698209] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   52.698210] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[   52.698212] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   52.698214] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)

Именно эти записи появляются после загрузки ath6kl_core

PS: Апдейт ядра до 4.4 ничего не дал.

another ★★★★★ ()

блин, три звезды, а последнее ядро собрать со всеми сетевыми драйверами так и не догадался? ну, куда катится лор.
//хотя в федоре, кхех, это проблематично, ибо xconfig сломали, а гетека-интерфейс жутко геморный под конфигурирование ядра.

darkenshvein ★★★★★ ()
Ответ на: комментарий от false

Там есть пара патчей, можно попробовать собрать ядро с ними, но я бы не надеялся

Судя по дискуссии по ссылке всё очень невесело. Наверное попробую повозиться с патчами, пока время есть, хотя стопицот лет уже самостоятельно ядро не собирал. Спасибо за помощь.

another ★★★★★ ()
Ответ на: комментарий от darkenshvein

Ты слишком толст, тролль, тебе надо худеть.

another ★★★★★ ()
Ответ на: комментарий от another

теперь школьники вместо аргументации обзываются троллем?

darkenshvein ★★★★★ ()
Ответ на: комментарий от false

По ссылке чел пишет, что поменял Dell DW1537 на Broadcom BCM94352Z. Не сталкивался случаем с таким адаптером под линуксом? А то в сети мало информации, вроде про наличие драйверов информация есть, но про работоспособность особо ничего не говорится. Или в данном случае замена адаптера не поможет?

another ★★★★★ ()
Ответ на: комментарий от another

А он не может тупо отрубаться «биосом», если грузится не винда? Раньше сталкивался с таким, устройство тоже нигде никак не светилось, пришлось смотреть в биос, какой строки названия оси он ждёт для включения всего.

Deleted ()
Ответ на: комментарий от Deleted

На нем uefi просмотрел все настройки, ничего похожего не нашел.

another ★★★★★ ()
Ответ на: комментарий от another

нет, в настройках этого не увидишь, это зашито в биосы и уефы. Раньше для загрузки «правильных» настроек использовалась строка acpi_osi=«чеготамтвойбивисхочет» в grub. Поищи на эту тему, как дизасемблилось биос и посдсмотреть «правильное» название.

Но теперь, с секурбутом, всё ещё разнообразнее, если он отключен, тоже меняется поведение компьютера, может нет карточки и из-за этого. А если включен, не особо поиграешься с обманом имени оси. И ещё, если секурбут включен - обязательно грузиться с подписанным ядром, иначе опять попадаешь на обломы.

Я пока разбирался с рабочим ноутом такого начитался про мучения людей... Производителей судить надо, это же новая волна непускания линукса на десктопы! Поэтому себе покупал комп изначально без винды, чтобы точно не было косяков.

Удачи тебе в мучениях, хотя, возьми и отнеси комп обратно и поменяй на «такое же, только с перламутровыми пуговицами», так легче.

Deleted ()
Ответ на: комментарий от another

Чисто любопытно,а по пути /sys/bus/sdio/devices есть что? Выше уже спрашивал, но не ответил

false ★★★★★ ()
Ответ на: комментарий от false

Чет я как-то пропустил твой вопрос. Вот так оно выглядит:

ls /sys/bus/sdio/devices/
mmc0\:0001\:1

Это символическая ссылка

ls -l /sys/bus/sdio/devices/mmc0\:0001\:1
lrwxrwxrwx 1 root root 0 янв.   4 18:11 /sys/bus/sdio/devices/mmc0:0001:1 -> ../../../devices/pci0000:00/INT33C6:00/mmc_host/mmc0/mmc0:0001/mmc0:0001:1
another ★★★★★ ()
Ответ на: комментарий от Deleted

Но теперь, с секурбутом, всё ещё разнообразнее, если он отключен, тоже меняется поведение компьютера, может нет карточки и из-за этого.

Включил в uefi опцию secureboot. Ничего вроде не поменялось, убунта загрузилась без лишних вопросов, но все равно без wifi. Вот скорее всего правильный ответ выше по треду: Dell Venue 11 Pro 7130. Не работает wifi (комментарий)

Удачи тебе в мучениях, хотя, возьми и отнеси комп обратно и поменяй на «такое же, только с перламутровыми пуговицами», так легче.

Я его не покупал, взял на работе поиграться ради собственного удовольствия. Думал замену рабочему окружению венды сделать, а то на основном ноуте на работе это как-то не очень хорошо делать, там работать надо. А этот девайс пока бесхозный, можно дома повозиться.

another ★★★★★ ()
Ответ на: комментарий от another

Да, эти «рабочие» компы - срань последняя, их покупабт чтобы отстал :)

Мне купили ноут у которого вайфай (Broadcom bcm43142) вешает систему намертво при попытке что-то скачать. И в винде и в линуксе, я вспотел его ковырять, завтра пойду кину на стол директору, пусть сами с ним едренятся. А ещё на нём энергосбережение как-то странно настроено - каждую минуту отрубается usb, полностью, и там и там, при любых настройках. и в биосе (тоже уефайный секурбутный навороченый впердепланетный) отключил энергосбережение - а ему хоть бы хны, У меня, говорит, по расписанию обэд! И винда или виснет или выдаёт ошибку при копировании файла и тут же «обнаружено новое устройство»... срань колёсная...

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.