LINUX.ORG.RU

kde не грузится

 , ,


0

1

Всем привет! Помогите новичку.

Fedora 19, сидел себе никого не трогал, как тут бац - раб.стол в черный экран и на фоне работающая консоль, браузер и ошибка kde, которую по нелепости закрыл:( Теперь перезагружаюсь, появляется стандартный экран федоры, начинает грузится иконка жесткого диска и все..черный экран. Ничего. Но комп работает, дисковод шуршит.

Приходится сидеть через лайвсиди. Вот xorg.0.log http://pastebin.com/aCUALuG9

Пробовал переименовать ./kdе - не помогло.

Ctrl+Alt+F2 после загрузки, логинишься, настраиваешь сеть по мануалам, yum update, yum install что-надо, yum remove/install) Нового пользователя создаёшь. В общем, делаешь что хочешь, чинишь.

Либо с livecd, монтируешь файловую систему своей машины куда-нибудь, затем chroot /директория-куда-монтировал /bin/bash, копируешь извне внутрь свой /etc/resolv.conf. Затем обновляешь, удаляешь что-надо и создаёшь пльзователя для теста.

Y ★★ ()

enjoy your fedora

anonymous ()

сидел себе никого не трогал

Вы лукавите, либо вы сделали обновление системы, либо установили проприетарный драйвер.

Очистите (удалите) файл '~/.xsession-errors', после чего перезайдите в графическую оболочку, затем выложите содержимое этого файла на pastebin сервис, а ссылку сюда.

Но, скорее всего, вам нужно переустановить пакеты с mesa.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 2 )
Ответ на: комментарий от Ake

Вроде нет, все ок. Столько сколько и было. Место много

Pixasso ()

systemsettings --> Запуск и завершение --> Управление сеансами --> При входе в систему --> Начинать с пустого сеанса. Релогин.

Надеюсь, поможет. Мой libastral.so кагбэ подсказывает мне, что в первый раз упала плазма и по какой-то причине не стартовала заново, а «хитрая» kde-session запомнила это и в последующие сеансы загружала KDE уже без плазмы.

В случае успешного старта KDE указанную выше опцию можно вернуть в исходное положение.

carasin ★★★★★ ()
Последнее исправление: carasin (всего исправлений: 1 )
Ответ на: комментарий от carasin

Возможно libastral права, но прошу меня соориентировать, как мне это сделать находясь в лайвсиди? Как это сделать через консоль или иначе?

Pixasso ()
Ответ на: комментарий от Pixasso

Переместите все файлы с вашей профильной директории, начинающиеся с точки, и переименуйте директорию /var/tmp/kdecache-имя_вашего_пользователя.

После чего создайте директорию /var/tmp/kdecache-имя_вашего_пользователя и сделайте владельцем этой директории вашего пользователя.

kostik87 ★★★★★ ()
Ответ на: комментарий от Pixasso

Ctrl + Alt + F2 --> login: root@%{root_password} --> # X :1

Ctrl + Alt + F3 --> login: %{user_name}@%{user_password} --> $ xterm -display :1

Ctrl + Alt + F7 --> в необрамлённом окне xterm'а вбиваем systemsettings --> в появившемся окне KDE'шной программы настройки производим необходимые изменения, сохраняем их.

Ctrl + Alt + F3 --> Ctrl + C --> $ exit.

Ctrl + Alt + F2 --> Ctrl + C --> # init 3 && init 5.

Ctrl + Alt + F1 --> KDM ;)

carasin ★★★★★ ()
Ответ на: комментарий от kostik87

Сделал, не помогло. Только я перемещал только файлы:

Переместите все файлы с вашей профильной директории, начинающиеся с точки, и переименуйте директорию /var/tmp/kdecache-имя_вашего_пользователя.

каталоги не трогал. Надеюсь правильно понял.

Pixasso ()
Ответ на: комментарий от carasin

Спасибо), я имел ввиду, через лайв сиди все ок - я захожу через КДЕ и могу править системные настройки. Но мне ведь нужно изменить эти настройки для установленной на мой хард системы..если я правильно понимаю. А это руководство только для лайв сиди будет верным?

И еще такая маленькая поправка - у меня из-за особенности видеокарты терминал и ждущий режим не работает. Так что обхожу башем.

Как мне изменить эти настройки для установленной федоры чрз лайвсиди?

Pixasso ()

В

.kde4/share/config/kwinrc
[Compositing]
AnimationSpeed=3
Backend=OpenGL
Enabled=true <-
...
измени на «false», особенно если видео nvidia.

Попробуй.

Ksanch ()
Ответ на: комментарий от Pixasso

Через live-систему — ХЗ. Я писал именно для установленной системы. Но судя по тому, что с пустыми конфигами оно у Вас не заработало, мой рецепт тоже вряд ли поможет.

carasin ★★★★★ ()
Последнее исправление: carasin (всего исправлений: 1 )
Ответ на: комментарий от Pixasso

Какая у вас видео карта ? Intel ?

Судя потому, что у вас в итоге используется драйвер vesa (по логу xorg-server`а), а не intel, у вас проблемы с mesa, возможно.

Поищите среди установленных пакеты с mesa и переустановите их, если нет ни одного, то ищите просто в репозитории и ставьте.

Вы точно не ставили драйвер nvidia, а если ставили, то не ставили ли вы его в ручную, в обход менеджера пакетов ?

kostik87 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.