LINUX.ORG.RU

Debian&Ati закрытые драйвера.


0

1

Пишу ему, понимаешь:
sudo sh ati-driver-installer-10-6-x86.x86_64.run --buildpkg Debian/stable
А он мне и говорит человеческим голосом

Generating package: Debian/stable ./packages/Debian/ati-packager.sh: 177: dpkg-architecture: not found Error: unsupported architecture: Removing temporary directory: fglrx-install.oUNiLP

Хедеры ядра есть. Что я делаю не так?

Атишный блоб не поддерживает дебиан. Попробуй вместо «Debian/stable» помянуть похожую убунту. Видимо, 10.04

Manhunt ★★★★★ ()

А чем блоб fglrx из репов не подходит?

coldy ★★ ()

А зачем ставить такое старье? Есть же 11.2. Даже в репозитории Debian поновее есть дрова. И вообще советую просто поставить драйвер, а не выстраивать пакет, меньше мороки.

spoilt ★★★ ()
Ответ на: комментарий от coldy

Ты сдесь самый умный, да?
aure@zegapain:~/my_data/thenet/deb/drivers$ apt-cache search fglrx
xserver-xorg-video-radeon - X.Org X server — AMD/ATI Radeon display driver

darkshvein ☆☆ ()
Ответ на: комментарий от spoilt

>Есть же 11.2.
Сети нет нормальной

И вообще советую просто поставить драйвер,

Ну да, конечно. И потом переустанавливать систему. В последний раз вместо ускорения оно мне вообще угробило всё 3д. После удаления драйвера ускорение не работало даже с драйвером радеон.

darkshvein ☆☆ ()
Ответ на: комментарий от spoilt

11.2 сегфолтится при сборке у половины народе, лучше пока выбирать 10.9

coldy ★★ ()
Ответ на: комментарий от darkshvein

мы тут умы меряем или с драйверами разбираемся? поставьте 10.9

coldy ★★ ()
Ответ на: комментарий от darkshvein

Сети нет нормальной

Сочувствую. Кстати fglrx порубали в размере. Теперь в районе 80 Мб.

В последний раз вместо ускорения оно мне вообще угробило всё 3д.

Наверное этот ваш последний раз был хрен знает когда. Или вы не выполнили какой-то из шагов установки (типа aticonfig --initial -f). И вообще fglrx легко и без пыли удаляется с помощью *fglrx-uninstall.sh (/usr/share/ati). Дерзайте.

spoilt ★★★ ()
Ответ на: комментарий от coldy

Ну у себя не заметил, а вообще все правильно. Я сам просидел на 10.9 до посинения. Вот кстати 10.6 я забраковал, были глюки с композитингом.

spoilt ★★★ ()
Ответ на: комментарий от spoilt

>fglrx легко и без пыли удаляется с помощью *fglrx-uninstall.sh (/usr/share/ati).
Так и удалял, ога.

aticonfig --initial -f

Этот этап обязателен? Я думал он только правит xorg.conf

darkshvein ☆☆ ()
Ответ на: комментарий от darkshvein

Так и удалял, ога.

Прошу заметить, при этой процедуре не восстанавливается старый xorg.conf. Последствия предсказуемы.

Этот этап обязателен? Я думал он только правит xorg.conf

Если у вас уже стоит fglrx (с настроенным xorg.conf), то необязателен. Но если ранее fglrx не был раннее установлен или xorg.conf в системе вовсе не существует, то пунктик становится обязательным.

spoilt ★★★ ()
Ответ на: комментарий от spoilt

Но если ранее fglrx не был раннее установлен или xorg.conf в системе вовсе не существует, то пунктик становится обязательным

Вообще достаточно вручную заменить в xorg.conf radeon(vesa) на fglrx и все работает. Это скорее нужно для убунты , где xorg.conf по-умолчанию вообще нет

Loki13 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.