LINUX.ORG.RU

[debian][fglrx] Генерация deb catalyst'ом


0

1

Всё так просто: http://wiki.cchtml.com/index.php/Debian. Но:

$ ./ati-driver-installer-11-11-x86.x86_64.run --buildpkg Debian/testing
Created directory fglrx-install.RS9zNj
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-8.911...................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
 AMD Catalyst(TM) Proprietary Driver Installer/Packager 
=====================================================================
Generating package: Debian/testing
cp: cannot stat `/home/gag/Downloads/fglrx-install.RS9zNj/x710_64a/*': No such file or directory
Package build failed!
Package build utility output:

<skip>

dh_install: Compatibility levels before 5 are deprecated.
ldconfig -n usr/X11R6/lib/
make: ldconfig: Command not found
make: *** [binary] Error 127
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
$

И похоже оно уже так давно (по крайней мере видел сообщение от апреля сего года). Кроме как просто не использовать блоб, можно сгенерить пакет?

★★★★★

О, вот только что дебиановцы пакеты подготовили: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=639875. Хм, только обновить

dep: xserver-xorg-core (<< 2:1.10.99)
забыли. Сколько есть разных вариантов, но ни один не доделан.

gag ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Запускается, но выбирать имеют право только рэдхетовцы и зюсевцы. Остальным предлагают из командной строки.

Попробовал зюсе 12.1. Сказало всё ОК, но пакета в текущей директории я не обнаружил.

Тем временем, подправив зависимость, собрались дебиановские пакеты.

gag ★★★★★ ()

>> make: ldconfig: Command not found

Эм, fakeroot наверно не устанавливает $PATH, а по умолчанию у пользователей там нет /sbin и /usr/sbin

GotF ★★★★★ ()
Ответ на: комментарий от GotF

Наверное, да. Что ж там у атишников за продвинутая версия fakeroot'а или дебиановских пакетирующих утилит (или они тоже вызывают fakeroot?)?..

Тем временем, заменив

 xserver-xorg-core (<< 2:1.10.99),
на
 xserver-xorg-core (<< 2:1.11.2),
пакетики собрались, установились и оно работает! Вот только при простое где-то на 6-10 ватт больше потребляет, чем под виндой. Интересно, fglrx-atieventsd для чего нужен?

Кстати, проверил, десктоп заснул/проснулся.

gag ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.