LINUX.ORG.RU

[ССЗБ] Radeon 9550 + fglrx


0

2

dmitriy@neoretix:~$ sh ati-driver-installer-9-3-x86.x86_64.run
Created directory fglrx-install.D0M0f5
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593...
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.32-5-486; make sure that the version is being correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.D0M0f5

ЧЯДНТ? Как все-таки поставить драйвер?
Дистр - Debian Squeeze :]

dmitriy@neoretix:~$ uname -a
Linux neoretix 2.6.32-5-486 #1 Sat Jun 11 19:49:29 UTC 2011 i686 GNU/Linux

P.S. АХТУНГ! Карточка не HD серии так что свободных дров с 3D ускорением нет. И да, купить другую карточку не предлагать %)

> Карточка не HD серии так что свободных дров с 3D ускорением нет

А обычный, не HD-драйвер уже отменили?

YAR ★★★★★ ()
Ответ на: комментарий от x3al

> Это же r300, емнип.

Почти:

rain@acnote:~$ man radeon | grep 9550
RV350 Radeon 9600PRO/9600SE/9600/9550, M10/M11, FireGL T2

YAR ★★★★★ ()
Ответ на: комментарий от YAR

>А обычный, не HD-драйвер уже отменили?

Если бы мне его было достаточно, я бы тут топик не создавал, тебе не кажется? Он работает, но нужно 3D ускорение.

Neoretix ()
Ответ на: комментарий от x3al

Собрать пакеты и поставить их я и сам уже догадался. Нужно было собрать еще и модуль для ядра вручную. Мейк фейлился с ошибкой «невозможно найти цель для сборки».

Если надо, подробный вывод могу дать, но не суть же.

Neoretix ()
Ответ на: комментарий от Neoretix

>Если бы мне его было достаточно, я бы тут топик не создавал, тебе не кажется? Он работает, но нужно 3D ускорение.

Ну так оно есть у обычного драйвера, млин. Прочитай какую-нибудь вику, если нет по твоему дистрибутиву — то арчевую.

x3al ★★★★★ ()
Ответ на: комментарий от Neoretix

> Он работает, но нужно 3D ускорение.

На используемом мной не HD X700 3D работает, еще когда-то попадалась 9250, тоже все ок. Поддержка 9550 заявлена, пробуй.

YAR ★★★★★ ()
Ответ на: комментарий от redgremlin

Кстати, из репозитория надо ставить самый старый fglrx - 8.12, поддержку 9500+ выкинули в 10.2

redgremlin ★★★★★ ()
Ответ на: комментарий от YAR

Хорошая поддержка 3D только в достаточно свежих r300g/mesa/kernel dri, а у ТС демьян, так что ему, чтобы насладиться 3D в свободном драйвере, надо демьяна частично в слаку превратить :)

redgremlin ★★★★★ ()
Ответ на: комментарий от redgremlin

9250? Он r200, там проблем с галлиумом нет за отсутствием галлиума. 3D достаточно тормознутое, впрочем, оно есть.

x3al ★★★★★ ()

так что свободных дров с 3D ускорением нет
Поставьте Ubuntu или Sid.

RussianNeuroMancer ★★★★★ ()

>>P.S. АХТУНГ! Карточка не HD серии так что свободных дров с 3D ускорением нет.

Есть! Возможно тебе просто не повезло, или меса на твоем дистре древняя.

Не знаю какой по мощности твой комп, но можешь попробовать этот лайвСД на предмет работы твоей карты с более менее свежей меса.

http://gearsongallium.blog.com/

Тебе нужно пробовать r300 или r300g.

Behem0th ★★★★★ ()

Поставь ядро 2.6.28 и иксы не помню какие, на странице скачивания должно быть сказано.

anonymous ()

У меня такая же. Ставь более-менее старые иксы и ядро (Debian squeeze, Ubuntu 10.04) и все заработает из коробки.

свободных дров с 3D ускорением нет

карточка довольно старая, ничего особого тебе 3д-ускорение не даст

derlafff ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.