LINUX.ORG.RU

перестала запускаться ласька вне KDE


0

0

Перешел на Debian SID. Поставил лаську. В кедах работает на ура. Пытаюсь запустить в гноме/xfce/openbox - результат (в консольке):

>>[ERR] Unable to load plugin (qt-gui): /usr/local/lib/licq/licq_qt-gui.so: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога.

На www.licq.org прочитал об этом. Там предложили запускать таким образом:

>>licq -p qt-gui

Пробовал - результат совершенно не меняется. Установлены все плагины для ласькуи, какие есть в репозитории. Подскажите, что надо переустановить, чтобы нормально заработало? Или что вообще можно сделать... :(

Заранее спасибо

Re: перестала запускаться ласька вне KDE

export KDEDIR=

?

Sylvia ★★★★★ ()

Re: перестала запускаться ласька вне KDE

export KDEDIR=/usr

в Debian

Sylvia ★★★★★ ()

Re: перестала запускаться ласька вне KDE

в принципе еще совет - запустить что нибудь KDEшное в фон, перед загрузкой licq, пусть оно подгрузит sycoca, kded и прочее в память

хороший кандидат - yakuake

все равно терминал иногда нужен, ну и достаточно ненавязчивая консолька

Sylvia ★★★★★ ()
Ответ на: Re: перестала запускаться ласька вне KDE от Sylvia

Re: перестала запускаться ласька вне KDE

Все сделал.
$export KDEDIR=/usr
$yakuake &
[1] 4956
$licq
15:43:15: [ERR] Unable to load plugin (qt-gui): /usr/local/lib/licq/licq_qt-gui.so: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога.
15:43:15: [WRN] This usually happens when your plugin
is not kept in sync with the daemon.
Please try recompiling the plugin.
If you are still having problems, see
the FAQ at www.licq.org

vitroot ★★ ()
Ответ на: Re: перестала запускаться ласька вне KDE от vitroot

Re: перестала запускаться ласька вне KDE

М-м-м... А сам файл /usr/local/lib/licq/licq_qt-gui.so есть? Если его там нет, найти где он есть и создать симлинк на него...

А если попробовать $export KDEDIR=/usr не перед yakuake а непосредственно перед $licq ?

Ну и как варианты $export KDEDIR=/usr/local, $export KDEDIR=/opt/kde/

cPunk ★★ ()

Re: перестала запускаться ласька вне KDE

ldd /usr/local/lib/licq/licq_qt-gui.so покажи

лиська (licq), а не ласька.

Deleted ()

Re: перестала запускаться ласька вне KDE

Поставь licq-plugin-qt или licq-plugin-gtk, а то у тебя, видимо, только licq-plugin-kde стоит.

gaa ★★ ()
Ответ на: Re: перестала запускаться ласька вне KDE от cPunk

Re: перестала запускаться ласька вне KDE

сделал:

$sudo ln -s /usr/lib/licq/licq_qt-gui.so /usr/local/lib/licq/licq_qt-gui.so

после этого лИська запустилась, но ругается:

[ERR] Loading emoticons theme 'ccmathteam.com'

Ну и не может подгрузить иконки и смайлики

vitroot ★★ ()
Ответ на: Re: перестала запускаться ласька вне KDE от vitroot

Re: перестала запускаться ласька вне KDE

Все, проблему решил. За каким-то.. х... э.. б.. биллом корневуха лИськи стала в /usr/local/share/licq/, хотя до этого была в /usr/share/licq/. Пока что тупо слинковал старый путь на новый. Но все-таки не понимаю, с чего такие перестановки

vitroot ★★ ()
Ответ на: Re: перестала запускаться ласька вне KDE от vitroot

Re: перестала запускаться ласька вне KDE

Ну что тут можно сказать... Она походу все ресурсы (смайлы, локализации) ищет в каталогах /usr/local а они находятся в каталогах /usr

cPunk ★★ ()

Re: перестала запускаться ласька вне KDE

опять в SIDе что то наломали) в Ленни - нормально

Sylvia ★★★★★ ()
Ответ на: Re: перестала запускаться ласька вне KDE от anonymous

Re: перестала запускаться ласька вне KDE

ставил еще полгода назад это точно. На sid перешел примерно пару недель назад. Обновлял ее так же, как и все остальное:

$sudo apt-get upgrade

То есть все апдейты из репозитория.

vitroot ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.