LINUX.ORG.RU

проблема с установкой пакета libgtk2.0-dev


0

0

Для программки envy мне нужен пакет libgtk2.0-dev. Он в свою очередь имеет зависимость от пакета libpango1.0-dev который зависит от libcairo2-dev а он зависит от пакета и пытаясь его установить через apt-get install мне выдаётся следующее сообщение:

Пакеты, имеющие неудовлетворённые зависимости: libcairo2-dev: Зависит: libcairo2 (= 1.4.2-0ubuntu1) но 1.4.10-1turner3~feisty0.1 будет установлен E: Сломанные пакеты

Что делать в такой ситуации я незнаю. Спрашиваю совета у Вас.


Re: проблема с установкой пакета libgtk2.0-dev

использовать пакеты из официального репозитория: а не херню всякую turner3~feisty0.1

Begemoth ★★★★★ ()

Re: проблема с установкой пакета libgtk2.0-dev

тык я даж незнаю откуда он взялся. есть выход то из этой ситуации? как исправить?

m0zg ()

Re: проблема с установкой пакета libgtk2.0-dev

Затрудняюсь ответить. Я обнаружил эту херню с пакетом тогда когда не смок нормально заработать Envy. Посмотрел лог и там значился этот пакет.

m0zg ()

Re: проблема с установкой пакета libgtk2.0-dev

> ппц. походу безвыходно

Безвыходных ситуаций не бывает. Если уж совсем все плохо, то можно попробовать windows-way: снести все, что ломает зависимости, а затем поставить назад из репозитория. Это конечно не совсем правильно, но может помочь.

Belomor ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.