LINUX.ORG.RU

Убрать звук из колонок при подключении наушников

 ,


1

2

Ребята, вопрос:

Есть простая встроенная звуковуха (какая-то там Realtek ALC662 вроде). Есть Debian 9/10. Есть пульса, куда ж без нее.
Подключаю уши в переднюю панель корпуса компа. Звук есть, но он также есть и из колонок, которые подключены в заднюю панель.
Есть какой-то вариант заставить молчать колонки? Ткните, плиз. Благодарю заранее.

РЕШЕНИЕ:

Если у вас десктоп, то в биосе есть опция. Надо просто выбрать HD Audio вместо AC97.

★★★★★

Если мне память не изменяет в jack есть лопатка , когда втавляеш наушники лапатка отгибается и коротит контакт который сообщает кому-то там что мол я воткнулося и все остальные выводы мутятся софтово или хардварно. Может тебе подрыгать jack на передней панели попробовать, мало ли?

LINUX-ORG-RU ★★ ()
Ответ на: комментарий от Gonzo

вкладка «устройства вывода», порт у тебя что? у меня отдельно динамики, отдельно наушники. еще кнопки «связать громкости каналов», «set as fallback» // что-то у меня не получается добиться твоей ситуации

anonymous ()

Если я не ошибаюсь, то раньше передняя панель подключалась по-другому. Без автодетекта. Коннектор тот же, а распиновка другая. Соответственно, если корпус старый, то автомут работать не будет пока вручную не замкнешь нужные контакты.

P.S. У самого старый корпус и автомут не работает. Причем в оффтопике вообще вся переднняя панель не пашет, пока вручную в драйвере не включишь режим совместимости. Максимум что получилось добиться - это либо автоматом отправлять звук одновременно во все разъемы, либо через пульсу каждый раз руками выбирать нужный.

qtm ★★★ ()
Последнее исправление: qtm (всего исправлений: 1)
Ответ на: комментарий от qtm

Кстати, автомут вроде вообще выкинули отовсюду. Пока гуглил, пробовал всякое, так даже команды типа:

amixer -c NVidia sset 'Auto-Mute Mode' Enabled

не пашут. Пишет, что:

amixer: Unable to find simple control 'Auto-Mute Mode',0

Gonzo ★★★★★ ()
Ответ на: комментарий от ChekPuk

Да, пожалуйста, погугли еще. Дело в том, что твое решение давно устарело и оно для alsa внезапно. А вообще, забей, у меня проблема в распиновке и корпусе компа.

Gonzo ★★★★★ ()
Последнее исправление: Gonzo (всего исправлений: 1)
Ответ на: комментарий от Gonzo

Автомут - это новая фича. Если распиновка «по-новому», он будет работать из коробки.

А вообще я именно через алсамиксер и заставил морду работать. Достаточно просто выкрутить громкость на Headphones. По умолчанию они отключены. То есть, звук будет во всех разъемах сразу. И это решение лучше, чем перенаправлять через пульсу. Во-первых, гемора меньше, а во-вторых, звук почему-то громче.

qtm ★★★ ()
Ответ на: комментарий от Gonzo

Внезапно пульса работает поверх алсы.

«Причем в оффтопике вообще вся переднняя панель не пашет, пока вручную в драйвере не включишь режим совместимости.» это как раз о «в /etc/modprobe.d/alsa-base.conf (или какой там у тебя в дистре) пишешь options snd-hda-intel model=твой_вариант»

anonymous ()
Ответ на: комментарий от Gonzo

Громкость Headphones на нуле и не регулируется оттуда, хотя звук есть в ушах

У меня там есть шкала, просто громкость по нулям, надо выкрутить.

Можно подробнее, плиз? Интересно просто, хотелось бы проверить на офтопе.

Точно не скажу, я с семерки не пользовался виндой. Помню что где-то в реалтековских настройках есть пункт что-то вроде: «Включить определение гнезд на передней панели» и там надо либо поставить галочку, либо, наоборот, снять. Иначе звука не будет вообще.

Если у тебя звук есть на передней панели, то лучше ты ничего не сделаешь. Регулируй громкость колонок колесиком на колонках :-) Или, как вариант, запусти pacmd list-sinks там в конце должно быть что-то типа

ports:
      analog-output-lineout: Линейный выход
      analog-output-headphones: Наушники
                   
active port: <analog-output-lineout>

Активный порт - это туда куда идет звук. Его можно переключить на наушники так:

pacmd set-sink-port 0 analog-output-headphones

И наоборот, на колонки, соответственно, так:

pacmd set-sink-port 0 analog-output-lineout

Это все, что я пробовал. Больше ничего не могу посоветовать. В драйвера я не лазил. Суть в том, что если передняя панель подключается «по-старому», то комп тупо не может детектить включены в него наушники или нет. Там нет этих контактов физически. Соответственно либо врубить звук по умолчанию везде (в алсе), либо переключать вручную (через пульсу). Автоотключения колонок при подключении наушников ты не добьешься никак.

qtm ★★★ ()
Последнее исправление: qtm (всего исправлений: 3)
Ответ на: комментарий от qtm

pacmd set-sink-port 0 analog-output-headphones
pacmd set-sink-port 0 analog-output-lineout

Я это могу переключить и с помощью Connector в настройках звука.
Понятно, значит беда таки с распиновкой. В любом случае, спасибо тебе большое.

Gonzo ★★★★★ ()
Ответ на: комментарий от Gonzo

«в /etc/modprobe.d/alsa-base.conf (или какой там у тебя в дистре) пишешь options snd-hda-intel model=твой_вариант» выбираешь здесь https://www.kernel.org/doc/html/latest/sound/hd-audio/models.html Я так понимаю alc662-headset может помочь, а может и не помочь. Не забудь ‘sudo alsa force-reload’ или перезагрузиться.

anonymous ()
Ответ на: комментарий от qtm

Внезапно починил, лол. В Биосе есть опция, о которой бы никогда не подумал, что может так повлиять. Надо было просто выбрать HD Audio вместо AC97. Теперь колонки автоматом мутятся когда врубаешь наушники в переднюю панель.

Gonzo ★★★★★ ()