LINUX.ORG.RU

Firefox тянет ненужные драйвера

 , ,


1

1

Есть видеокарта gtx550ti, поддержка заявлена в 340, 390 версиях драйвера. Замаскировано всё что выше 390. Но при попытке -uNDav@ The following mask changes are necessary to proceed: (see «package.unmask» in the portage(5) man page for more details) required by media-libs/nv-codec-headers-8.1.24.2::gentoo required by media-video/ffmpeg-4.1.3::gentoo[video_cards_nvidia] required by virtual/ffmpeg-9-r2::gentoo[-libav] required by www-client/firefox-60.8.0::gentoo required by @selected required by @world (argument) /etc/portage/package.mask/nvidia: =x11-drivers/nvidia-drivers-435.21 Я как то плохо понимаю, почему медиакодеки и фурфокс тянут за собой свежие дрова. Что с этим делать та? даунгрейдить фурфокс, разать кодеки или что?

Это ffmpeg тянет nv-codec-headers который тянет современные дрова. В дереве есть 9 и 8 версия, если 8 не подойдёт, найди ебилд более старой и сделай себе пакет с нужной версией.

//сорян за дабл пост

anonymous ()
Ответ на: комментарий от anonymous

Хотя не, оно пишет

* dependency graph for media-libs/nv-codec-headers-9.0.18.1
 `--  media-libs/nv-codec-headers-9.0.18.1  ~amd64 
   `--  x11-drivers/nvidia-drivers-435.21  (>=x11-drivers/nvidia-drivers-390.25) amd64 

ты уверен что у тя 390? я из оп нихрена не понял

anonymous ()
Ответ на: комментарий от Swinec

equery g media-libs/nv-codec-headers

 ~ $ qfile equery
app-portage/gentoolkit: /usr/lib/python-exec/python2.7/equery
app-portage/gentoolkit: /usr/lib/python-exec/python3.6/equery
app-portage/gentoolkit: /usr/bin/equery
app-shells/gentoo-bashcomp: /usr/share/bash-completion/completions/equery
 ~ $ qfile qfile
app-portage/portage-utils: /usr/bin/qfile
anonymous ()

как уже анон написал, для media-libs/nv-codec-headers достаточно версии >=x11-drivers/nvidia-drivers-390.25, так что смотри, какая у тебя версия драйвера.

обрати внимание, что 390.25 больше, чем 390, а значит у тебя она замаскирована, но она должна подходить для твоей видеокарты

eternal_sorrow ★★★★★ ()