LINUX.ORG.RU

Не могу понять, чего от меня хочет mariadb

 , ,


0

1
[Gentoo chroot] valkeru-desktop / # emerge nvidia-drivers

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! The ebuild selected to satisfy "=dev-db/mariadb-10.0*[embedded=,minimal=,static=,static-libs=]" has unmet requirements.
- dev-db/mariadb-10.0.13::gentoo USE="community pam perl ssl xml -bindist -cluster -debug -embedded -extraengine -jemalloc -latin1 -max-idx-128 -minimal -odbc -oqgraph -profiling (-selinux) -sphinx -static -static-libs -systemtap -tcmalloc -test -tokudb" ABI_X86="64 -32 -x32"

  The following REQUIRED_USE flag constraints are unsatisfied:
    xml? ( extraengine )

  The above constraints are a subset of the following complete expression:
    odbc? ( extraengine !minimal ) xml? ( extraengine !minimal ) minimal? ( !oqgraph !sphinx ) tokudb? ( jemalloc ) tcmalloc? ( !jemalloc ) jemalloc? ( !tcmalloc ) minimal? ( !cluster !extraengine !embedded ) static? ( !ssl )

(dependency required by "virtual/mysql-5.6-r1" [ebuild])
(dependency required by "dev-qt/qtsql-4.8.5" [ebuild])
(dependency required by "dev-qt/qt3support-4.8.5" [ebuild])
(dependency required by "dev-qt/qtgui-4.8.5-r3[qt3support]" [ebuild])
(dependency required by "dev-qt/qtcore-4.8.5-r2[qt3support]" [ebuild])
(dependency required by "dev-util/cmake-2.8.12.2-r1[qt4]" [ebuild])
(dependency required by "media-gfx/graphite2-1.2.4-r1" [ebuild])
(dependency required by "media-libs/harfbuzz-0.9.28[graphite]" [ebuild])
(dependency required by "x11-libs/pango-1.36.5" [ebuild])
(dependency required by "x11-libs/gtk+-2.24.24" [ebuild])
(dependency required by "x11-drivers/nvidia-drivers-343.13-r1[tools]" [ebuild])
(dependency required by "x11-base/xorg-drivers-1.16[video_cards_nvidia]" [ebuild])
(dependency required by "x11-base/xorg-server-1.16.0[xorg]" [ebuild])
(dependency required by "x11-drivers/xf86-input-mouse-1.9.0" [ebuild])

make.conf:

[Gentoo chroot] valkeru-desktop / # cat /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe -mtune=native"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
#USE=""
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j7"
#Нам же нужна свежатинка?
ACCEPT_KEYWORDS="~amd64"
#Эти юзы не нужны
DENY="-gtk -gnome -systemd -semantic-desktop"
#Эти юзы нужны
ALLOW="qt4 kde X acpi mozilla plasma \
scanner ssl  xinerama X bluetooth cdr dbus dvd dvdr \
encode ffmpeg libnotify lm_sensors \
matroska mtp multilib networkmanager opengl \
pulseaudio alsa ogg mp3 openssl cddb cdr \
rar vlc x264 exif css djvu joystick multilib ogg \
pdf sound unicode upnp usb xvid bash-completion sse sse2 ssse3 sse4_1"
USE="${ALLOW} ${DENY}"

LINGUAS="ru ru_RU en"

VIDEO_CARDS="nvidia"

GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/"
SYNC="rsync://rsync2.ru.gentoo.org/gentoo-portage"
Чего же ему надо?

★★★★

  The following REQUIRED_USE flag constraints are unsatisfied:
    xml? ( extraengine )

Включи USE=«extraengine» у пакета mariadb в package.use
Или отключи USE=«xml» у него же

Pinkbyte ★★★★★ ()

echo «dev-db/mariadb extraengine » >> /etc/portage/package.use/mariadb
или отключи xml-флаг у него же.

takino ★★★★★ ()

У вас пакет dev-db/mariadb уже установлен?

А так она хочет, что бы

 The following REQUIRED_USE flag constraints are unsatisfied:
    xml? ( extraengine )
При активации флага xml был так же активирован флаг extraengine, это для начала.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

У вас пакет dev-db/mariadb уже установлен?

Нет, это я только-только систему ставлю...
Всем спасибо, процесс пошёл :)

Valkeru ★★★★ ()
Ответ на: комментарий от Valkeru

Нет, это я только-только систему ставлю...

Ну и зачем сразу на тестовую ветку?

ACCEPT_KEYWORDS=«~amd64»

Раз не умеешь решать такие простые ситуации?

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Люблю приключения... Ну а если серьёзно - пробовал как-то раз стабильную ветку - не очень понравилось, что софт малость с душком.

Valkeru ★★★★ ()
Последнее исправление: Valkeru (всего исправлений: 1)
Ответ на: комментарий от Valkeru

не очень понравилось, что софт малость с душком.

Для этого есть package.keywords, где ты размаскируешь только нужные тебе пакеты из тестовой ветки, оставаясь при этом на стабильной в целом.

kostik87 ★★★★★ ()
Ответ на: комментарий от Valkeru

не очень понравилось, что софт малость с душком.

Либо стабильность, либо свежак.

Я бы всё же советовал на серверах держать stable, а нужные пакеты размаскировать.

На десктопе можно быть и проще, но я всё равно стараюсь держать stable.

Pinkbyte ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.