LINUX.ORG.RU

[gentoo] phonon, gstreamer и qt-qt3support


0

2

Сегодня при обновлении ВНЕЗАПНО выдало следующее:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "media-libs/phonon[aqua=,gstreamer]".
!!! One of the following packages is required to complete your request:
- media-libs/phonon-4.5.0 (Change USE: +gstreamer)
(dependency required by "x11-libs/qt-qt3support-4.7.2" [ebuild])
(dependency required by "kde-base/plasma-workspace-4.6.3-r2" [ebuild])
(dependency required by "kde-base/kdeplasma-addons-4.6.3" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

После добавления в package.use: «x11-libs/qt-qt3support -phonon» сборка пошла. Но с чего бы это вдруг? зачем qt-qt3support вдруг понадобился gstreamer?

А что говорит emerge -pvO qt-qt3support?
Прибито ли гвоздями в ебилде требование +gstreamer у фонона, или можно отключить юз-флагом?
Если прибито гвоздями, то проще перекрыть в локальном оверлее и исправить.

Lumi ★★★★★ ()
Ответ на: комментарий от Lumi

прибито

DEPEND="
.......
        phonon? (
                !kde? ( || ( ~x11-libs/qt-phonon-${PV}[aqua=,debug=]
                        media-libs/phonon[aqua=,gstreamer] ) )
                kde? ( media-libs/phonon[aqua=,gstreamer] ) )"

Но оно же наверное не просто так для красоты прибито? Если исправить в оверлее, чем это может обернуться?

TheAnonymous ★★★★★ ()

Не знаю, как в Gentoo, но в SuSE kdebase4-runtime зачем-то собран с зависимостью от libcanberra, которая в свою очередь тянет libgstreamer. За такие вещи — надо в голову гвозди забивать.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.