LINUX.ORG.RU

А флаг «qt3support» в генте ещё кому-то нужен? Можно без него вообще целиком жить?


0

1

Пытаюсь сделать емерге ворлд, а получаю:

qwerty ~ # emerge --update --deep --with-bdeps=y @world
!!! Please use dos2unix to convert line endings in config file: '/etc/make.conf'
!!! Please use dos2unix to convert line endings in config file: '/etc/make.conf'

 * IMPORTANT: 21 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 5 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "~x11-libs/qt-sql-4.8.2[aqua=,c++0x=,debug=,qpa=,qt3support]".
!!! One of the following packages is required to complete your request:
- x11-libs/qt-sql-4.8.2::gentoo (Change USE: +qt3support)
(dependency required by "x11-libs/qt-qt3support-4.8.2" [ebuild])
(dependency required by "x11-libs/qt-gui-4.8.2[qt3support]" [ebuild])
(dependency required by "x11-libs/cairo-1.12.2-r3[qt4]" [ebuild])
(dependency required by "x11-libs/gtk+-2.24.10-r1" [ebuild])
(dependency required by "www-plugins/adobe-flash-11.2.202.236" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Рекомендую сделать -q3support в make.conf и x11-libs/cairo -qt4 в package.use, сам когда-то так делал. Но q3support требуется некоторым слоупочным пакетам, например, app-text/goldendict и x11-misc/vym.

anonymous ()

Странный ты человек. Portage тебе прямым текстом говорит, что без него не получится, а ты переспрашиваешь на форуме.

chelovek-bugurt ()

Попробуй удалить те пакеты, которые явно хотят +qt3support, если не снесёшь всё KDE, отпишись. :)

imul ★★★★★ ()
Ответ на: комментарий от Kroz

Почему x11-libs/cairo -qt4 ?

Потому что не нужно, очевидно же.

anonymous ()
Ответ на: комментарий от anonymous

Потому что не нужно, очевидно же.

Неочевидно. Раз есть флаг, значит иногда бывает нужно. Посему вопрос: когда нужно а когда нет.

Kroz ★★★★★ ()
Ответ на: комментарий от anonymous

[провокация дискача]

Не было нужно даже когда у меня красноглазика в генточке были кеды с их монструозными kdelibs, которые я, образумившись, к счастью для себя из генточки выкорчевал.

anonymous ()
Ответ на: комментарий от Kroz

Оно там нужно только для того, чтобы вызывать несварение у emerge.

anonymous ()

Почему-то qt3support у меня настоятельно просить разрешиться, когда я ставлю какой-либо софт. Приходится вручную указывать для него -qt4, чтобы собирался с настоящим Qt 3. Просто у меня KDE 3, и четвёртую версию на нетбук не хочется.

Вопрос: можно ли удалить Qt 3, и использовать вместо него Qt 4 с USE-флагом qt3support для моего KDE 3? И если нет, зачем этот USE-флаг вообще нужен, объясните мне? Упростить портирование на Qt 4?

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Вопрос: можно ли удалить Qt 3, и использовать вместо него Qt 4 с USE-флагом qt3support для моего KDE 3? И если нет, зачем этот USE-флаг вообще нужен, объясните мне?

Упростить портирование на Qt 4

Сам спросил, сам ответил.

anonymous ()

!!! Please use dos2unix to convert line endings in config file: '/etc/make.conf'

Чем вы вообще make.conf писали? Виндовым блокнотом?

AlexCones ★★★ ()

IMPORTANT: 21 news items need reading for repository 'gentoo'.

eselect news read, не?

science ★★☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.