LINUX.ORG.RU

teamviewer и куча либ x86_32

 , ,


0

1

здравствуйте, решил установить teamviewer на свою 64-битную систему, ну в итоге вот такой треш:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by x11-libs/libXfixes-5.0.3::gentoo
# required by x11-libs/libXdamage-1.1.4-r1::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=x11-proto/fixesproto-5.0-r1 abi_x86_32
# required by dev-qt/qtsql-4.8.7-r1::gentoo[sqlite]
# required by dev-qt/qt3support-4.8.7::gentoo
# required by dev-qt/qtgui-4.8.7::gentoo[qt3support]
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=dev-db/sqlite-3.20.1-r1 abi_x86_32
# required by x11-libs/libXrandr-1.5.1::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=x11-proto/renderproto-0.11.1-r1 abi_x86_32
# required by x11-libs/libXrandr-1.5.1::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=x11-proto/randrproto-1.5.0 abi_x86_32
# required by media-libs/freetype-2.8.1::gentoo[bzip2]
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=app-arch/bzip2-1.0.6-r8 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=x11-libs/libXcursor-1.1.14 abi_x86_32
# required by media-libs/fontconfig-2.12.6::gentoo
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/expat-2.2.4 abi_x86_32
# required by virtual/jpeg-0-r2::gentoo
# required by media-libs/lcms-2.8-r2::gentoo[jpeg]
# required by media-libs/libmng-2.0.3::gentoo[lcms]
# required by dev-qt/qtgui-4.8.7::gentoo[mng]
# required by dev-qt/qt3support-4.8.7::gentoo
>=media-libs/libjpeg-turbo-1.5.2 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo[qt3support]
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=dev-qt/qt3support-4.8.7 abi_x86_32
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=net-libs/gnutls-3.5.15 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=x11-libs/libICE-1.0.9-r1 abi_x86_32
# required by dev-libs/libverto-0.2.6::gentoo[libev]
# required by app-crypt/mit-krb5-1.15.2::gentoo
# required by virtual/krb5-0-r1::gentoo
# required by net-print/cups-2.2.4::gentoo[kerberos]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/libev-4.24 abi_x86_32
# required by net-nds/openldap-2.4.45::gentoo[gnutls,ssl]
# required by app-crypt/mit-krb5-1.15.2::gentoo[openldap]
# required by virtual/krb5-0-r1::gentoo
# required by net-print/cups-2.2.4::gentoo[kerberos]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/libgcrypt-1.8.1 abi_x86_32
# required by dev-qt/qtcore-4.8.7-r2::gentoo[iconv]
# required by dev-qt/qtxmlpatterns-4.8.7::gentoo
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=virtual/libiconv-0-r2 abi_x86_32
# required by x11-libs/libSM-1.2.2-r1::gentoo[uuid]
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=sys-apps/util-linux-2.30.2 abi_x86_32
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=x11-libs/libXtst-1.2.3 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo[mng]
# required by dev-qt/qt3support-4.8.7::gentoo
>=media-libs/libmng-2.0.3 abi_x86_32
# required by dev-libs/glib-2.52.3::gentoo
# required by dev-util/pkgconfig-0.29.2::gentoo[-internal-glib]
# required by virtual/pkgconfig-0-r1::gentoo
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=virtual/libffi-3.0.13-r1 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=x11-libs/libSM-1.2.2-r1 abi_x86_32
# required by virtual/krb5-0-r1::gentoo
# required by net-print/cups-2.2.4::gentoo[kerberos]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=app-crypt/mit-krb5-1.15.2 abi_x86_32
# required by dev-libs/glib-2.52.3::gentoo[xattr]
# required by dev-util/pkgconfig-0.29.2::gentoo[-internal-glib]
# required by virtual/pkgconfig-0-r1::gentoo
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=sys-apps/attr-2.4.47-r2 abi_x86_32
# required by net-print/cups-2.2.4::gentoo[dbus]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=sys-apps/dbus-1.10.24 abi_x86_32
# required by sys-libs/readline-7.0_p3::gentoo
# required by dev-libs/libpcre-8.41::gentoo[readline]
# required by dev-libs/glib-2.52.3::gentoo
# required by dev-util/pkgconfig-0.29.2::gentoo[-internal-glib]
# required by virtual/pkgconfig-0-r1::gentoo
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=sys-libs/ncurses-6.0-r1 abi_x86_32
# required by virtual/libffi-3.0.13-r1::gentoo
# required by dev-libs/glib-2.52.3::gentoo
# required by dev-util/pkgconfig-0.29.2::gentoo[-internal-glib]
# required by virtual/pkgconfig-0-r1::gentoo
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/libffi-3.2.1 abi_x86_32
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=dev-qt/qtxmlpatterns-4.8.7:4 abi_x86_32
# required by dev-qt/qtcore-4.8.7-r2::gentoo[glib]
# required by dev-qt/qtxmlpatterns-4.8.7::gentoo
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=dev-libs/glib-2.52.3 abi_x86_32
# required by app-crypt/mit-krb5-1.15.2::gentoo
# required by virtual/krb5-0-r1::gentoo
# required by net-print/cups-2.2.4::gentoo[kerberos]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/libverto-0.2.6 abi_x86_32
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/nettle-3.3-r2 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo[xv]
# required by dev-qt/qt3support-4.8.7::gentoo
>=x11-proto/videoproto-2.3.3 abi_x86_32
# required by media-libs/lcms-2.8-r2::gentoo[tiff]
# required by media-libs/libmng-2.0.3::gentoo[lcms]
# required by dev-qt/qtgui-4.8.7::gentoo[mng]
# required by dev-qt/qt3support-4.8.7::gentoo
>=media-libs/tiff-4.0.8 abi_x86_32
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/libtasn1-4.12-r1 abi_x86_32
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=media-libs/alsa-lib-1.1.4.1 abi_x86_32
# required by net-print/cups-2.2.4::gentoo[kerberos]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=virtual/krb5-0-r1 abi_x86_32
# required by media-libs/libmng-2.0.3::gentoo[lcms]
# required by dev-qt/qtgui-4.8.7::gentoo[mng]
# required by dev-qt/qt3support-4.8.7::gentoo
>=media-libs/lcms-2.8-r2 abi_x86_32
# required by net-misc/teamviewer-12.0.85001::gentoo[-system-wine]
# required by teamviewer (argument)
>=media-libs/libpng-1.2.57:1.2 abi_x86_32
# required by x11-libs/libXtst-1.2.3::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=x11-proto/recordproto-1.14.2-r1 abi_x86_32
# required by dev-libs/libgcrypt-1.8.1::gentoo
# required by net-nds/openldap-2.4.45::gentoo[gnutls,ssl]
# required by app-crypt/mit-krb5-1.15.2::gentoo[openldap]
# required by virtual/krb5-0-r1::gentoo
# required by net-print/cups-2.2.4::gentoo[kerberos]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/libgpg-error-1.27-r1 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=media-libs/freetype-2.8.1 abi_x86_32
# required by dev-qt/qtcore-4.8.7-r2::gentoo[ssl,-libressl]
# required by dev-qt/qtxmlpatterns-4.8.7::gentoo
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=dev-libs/openssl-1.0.2l abi_x86_32
# required by app-crypt/mit-krb5-1.15.2::gentoo[openldap]
# required by virtual/krb5-0-r1::gentoo
# required by net-print/cups-2.2.4::gentoo[kerberos]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=net-nds/openldap-2.4.45 abi_x86_32
# required by net-dns/libidn2-2.0.4::gentoo
# required by net-libs/gnutls-3.5.15::gentoo[idn]
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/libunistring-0.9.7 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-qt/qtcore-4.8.7-r2:4 abi_x86_32
# required by x11-libs/libXdamage-1.1.4-r1::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=x11-proto/damageproto-1.2.1-r1 abi_x86_32
# required by x11-libs/libXcursor-1.1.14::gentoo
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=x11-libs/libXfixes-5.0.3 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=media-libs/fontconfig-2.12.6 abi_x86_32
# required by dev-qt/qt3support-4.8.7::gentoo
# required by dev-qt/qtgui-4.8.7::gentoo[qt3support]
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=dev-qt/qtsql-4.8.7-r1:4 abi_x86_32
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=dev-qt/qtwebkit-4.8.7:4 abi_x86_32
# required by virtual/pkgconfig-0-r1::gentoo
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-util/pkgconfig-0.29.2 abi_x86_32
# required by media-libs/tiff-4.0.8::gentoo[jpeg]
# required by media-libs/lcms-2.8-r2::gentoo[tiff]
# required by media-libs/libmng-2.0.3::gentoo[lcms]
# required by dev-qt/qtgui-4.8.7::gentoo[mng]
# required by dev-qt/qt3support-4.8.7::gentoo
>=virtual/jpeg-0-r2:0 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo[xv]
# required by dev-qt/qt3support-4.8.7::gentoo
>=x11-libs/libXv-1.0.11 abi_x86_32
# required by dev-libs/glib-2.52.3::gentoo
# required by dev-util/pkgconfig-0.29.2::gentoo[-internal-glib]
# required by virtual/pkgconfig-0-r1::gentoo
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/libpcre-8.41 abi_x86_32
# required by x11-libs/libXtst-1.2.3::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=x11-libs/libXi-1.7.9 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=x11-libs/libXrandr-1.5.1 abi_x86_32
# required by x11-libs/libXrandr-1.5.1::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=x11-libs/libXrender-0.9.10 abi_x86_32
# required by app-crypt/mit-krb5-1.15.2::gentoo[keyutils]
# required by virtual/krb5-0-r1::gentoo
# required by net-print/cups-2.2.4::gentoo[kerberos]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=sys-apps/keyutils-1.5.10 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-qt/qtscript-4.8.7:4 abi_x86_32
# required by dev-db/sqlite-3.20.1-r1::gentoo[icu]
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=dev-libs/icu-58.2-r1 abi_x86_32
# required by dev-qt/qtcore-4.8.7-r2::gentoo[qt3support]
# required by dev-qt/qtxmlpatterns-4.8.7::gentoo
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=dev-qt/qtgui-4.8.7:4 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo
# required by dev-qt/qt3support-4.8.7::gentoo
>=media-libs/libpng-1.6.34 abi_x86_32
# required by dev-db/sqlite-3.20.1-r1::gentoo[readline]
# required by dev-qt/qtwebkit-4.8.7::gentoo
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=sys-libs/readline-7.0_p3 abi_x86_32
# required by dev-libs/glib-2.52.3::gentoo
# required by dev-util/pkgconfig-0.29.2::gentoo[-internal-glib]
# required by virtual/pkgconfig-0-r1::gentoo
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=virtual/libintl-0-r2 abi_x86_32
# required by dev-libs/nettle-3.3-r2::gentoo[gmp]
# required by net-libs/gnutls-3.5.15::gentoo
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=dev-libs/gmp-6.1.2 abi_x86_32
# required by net-print/cups-2.2.4::gentoo
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=virtual/pkgconfig-0-r1 abi_x86_32
# required by net-libs/gnutls-3.5.15::gentoo[idn]
# required by net-print/cups-2.2.4::gentoo[ssl]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=net-dns/libidn2-2.0.4 abi_x86_32
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=net-print/cups-2.2.4 abi_x86_32
# required by app-crypt/mit-krb5-1.15.2::gentoo
# required by virtual/krb5-0-r1::gentoo
# required by net-print/cups-2.2.4::gentoo[kerberos]
# required by dev-qt/qtgui-4.8.7::gentoo[cups]
# required by dev-qt/qt3support-4.8.7::gentoo
>=sys-libs/e2fsprogs-libs-1.43.6 abi_x86_32
# required by net-misc/teamviewer-12.0.85001::gentoo
# required by teamviewer (argument)
>=x11-libs/libXdamage-1.1.4-r1 abi_x86_32
честно говоря, ни разу не сталкивался с проблемами двоичного интерфейса... что тут нужно сделать? просто добавить в package.use флаги abi_x86_32 думаю обернется крахом кучи приложений... как вырулить? в гугле ничего дельного не нашел

teamviewer - 32-битное приложение, вот и вот

Deleted ()

просто добавить в package.use флаги abi_x86_32 думаю обернется крахом кучи приложений

Шта? Так это и делается. Ленивый способ это тупо добавить этот флаг глобально, чтоб всё собиралось по два раза.

anonymous ()
Ответ на: комментарий от anonymous

хм, разве добавление abi_x86_32 не пересоберет указанную либу в 32-битную версию и, в дальнейшем, только в нее?(т.е. x64 не будет больше собираться)

xperious ()
Ответ на: комментарий от xperious

Нет, мультилиб для того и придуман - добавление abi_x86_32 к пакету библиотеки будет собирать тебе 32-битную версию этой библиотеки вдобавок к той, которая у тебя по native abi стоит(64-битной в случае архитектуры amd64).

Подробнее можно прочитать тут

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

а как лучше: для конкретных атомов поставить x32(по типу >=x11-libs/libXcursor-1.1.14 abi_x86_32), либо для всех версий(по типу >=x11-libs/libXcursor-1 abi_x86_32)

xperious ()
Последнее исправление: xperious (всего исправлений: 3)
Ответ на: комментарий от xperious

Лично я ставлю для всех версий, так как от того, что версия сменится, надобность в 32-битной версии не пропадёт и всё равно придётся выставлять флаг

XMs ★★★★★ ()
Ответ на: комментарий от xperious

Для всех версий библиотеки:

x11-libs/libXcursor abi_x86_32

Глобально ставить не стоит - сборка всех либ, умеющих в мультилиб будет идти 2 раза. Хотя если лень возится с флагами и не лень ждать - пожалуйста...

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

хм, такая запись

x11-libs/libXcursor abi_x86_32

не прокатывает, дескать, невалидный атом, только с

x11-libs/libXcursor-1 abi_x86_32

...

да и вообще, думаю, сделать emerge --oneshot -av teamviewer, а аби_x32 только для определенных атомов, так же норм будет?

xperious ()
Ответ на: комментарий от xperious

не прокатывает, дескать, невалидный атом

ты уверен что указал атом верно? без знаков >, < или =? Потому что у меня это работает прекрасно.

Pinkbyte ★★★★★ ()
Ответ на: комментарий от xperious

Нормальный это атом, не надо. Всегда так делаю.

Сам качал тимвьюер для линукс с офсайта в zip, потом запустил один из бинарников внутри, он мне сказал, чего ему не хватает. Доустановил.

anonymous ()
Ответ на: комментарий от Pinkbyte

Глобально ставить не стоит

Чойта? Вайн требует кучу тридцатидвухбитных либ, сабж работает через вайн (ещё и требует рутовых прав, что совсем нехорошо). Единственное, что накладно при таком раскладе — шланг и меса. Как по мне, проще включить глобально и расставить в юзах/энвах исключения.

r3lgar ★★★★★ ()

в бинарном chrome есть apps, а там teamviewer

murmur ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.