LINUX.ORG.RU

Зачем package mask в gentoo, если он не работает?

 ,


0

2

Ну замаскировал я gtk3:

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by x11-themes/gtk-engines-unico-1.0.3_pre20140109::gentoo
# required by gnome-base/gsettings-desktop-schemas-3.20.0_p_p3_p01-r1::unity-gentoo
# required by net-libs/glib-networking-2.48.2::gentoo[gnome]
# required by net-libs/libsoup-2.54.1-r1::gentoo
# required by gnome-base/gvfs-1.28.3-r1::gentoo[http]
# required by x11-libs/libfm-1.2.3-r1::gentoo[automount,udisks]
# required by lxde-base/lxpanel-0.8.2::gentoo
# required by lxde-base/lxde-meta-0.5.5-r4::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/gtk3:
=x11-libs/gtk+-3.20.9_p_p1_p02-r1



Всё равно чтобы он нормально посчитал что ему не так, приходится сносить ебилды:
rm /usr/portage/x11-libs/gtk+/gtk+-3*.ebuild

Уже много лет это делаю после каждогй синхронизации дерева. Помогает.
А маски для чего? Чтобы людей злить?

★★★★★

Видимо кривой парсер портажа. У меня тоже иногда не срабатывает.

Deleted ()

Сделай глобально USE=-gtk3. А вообще, похоже что полностью выпилить гтк3 нельзя. Что-то от него все равно зависит. Поставь и забей, сколько он там места займёт. По теме: ну не все можно замаскировать. А вообще смотри внимательно, что зависит от гтк3 и сноси.

anonymous ()
Ответ на: комментарий от anonymous

Вполне можно. Как можно выпилить и весь gtk вообще. Но для этого приходится удалять ебилды т.к тупой portage не хочет меня слушать.
Ещё в некоторых ебилдах приписана ложная зависимость от gtk3

mittorn ★★★★★ ()

Очередной интересный кадр в портеже:

emerge: there are no ebuilds to satisfy "x11-themes/gnome-themes-standard".
(dependency required by "x11-libs/gtk+-2.24.31-r1::gentoo" [ebuild])

Есть альтернативные деревья, где не делают такого?

mittorn ★★★★★ ()

=x11-libs/gtk+-3.20.9_p_p1_p02-r1

это чё за такой 3.1415здец?

Deleted ()
Ответ на: комментарий от Deleted

это с оверлея, но суть оно не меняет - если есть хоть один ебилд для gtk+:3 - портеж считает что проще замаскировать чем выпилить то, что от него зависит. В этом месте просто основные ебилды я уже снёс, а оверлей забыл, это последнее что осталось в логе до полного выпила ебилдов.

mittorn ★★★★★ ()
Последнее исправление: mittorn (всего исправлений: 1)
Ответ на: комментарий от mittorn

честно говоря, не догоняю в чём проблема. ты заблокировал какую-то определённую версию пакета, но от неё может зависеть какой-то пакета, а от этого пакета другой пакет, и т.д. Вот тебе такой выхлоп и выдаётся.

Deleted ()
Ответ на: комментарий от mittorn

это с оверлея, но суть оно не меняет

Вообще-то меняет.

Ну замаскировал я gtk3:

Бывают иногда лишние зависимости, да, замечал.
Подправить ebuild, отослать патч - долго?

rm /usr/portage/x11-libs/gtk+/gtk+-3*.ebuild

Только потом не приходи и не говори что Гента кривая и ничего не работает.
Wait, oh shi....

Kroz ★★★★★ ()

и в чем проблема? У тебя есть пакеты, зависящие от gtk+-3, emerge находит самый простой способ разрешения зависимостей.

Могу предложить создать пакет-затычку, который будет конфликтовать с gtk3.

demidrol ★★★★★ ()

Приоритет всегда имеют явные желания пользователя. Если ты явно просишь установить то, что зависит от gtk3, то конечно он предложит размаскировать gtk3

В данной ситуации gtk+3 конкретно втягивает gnome-base/gsettings-desktop-schemas-3.20.0_p_p3_p01-r1::unity-gentoo из оверлея, потому что автор оверлея в зависимость добавил движок тем от гтк+

gnome-base/gsettings-desktop-schemas из дерева так не делает, но ты его видать удалил или замаскировал?

Вообще не надо умничать и ничего удалять из портежа, так ты дров наломаешь, а потом будешь ныть, какая гента кривая (чем ты собственно и занимаешься)

Gary ★★★★★ ()
Ответ на: комментарий от Kroz

Очень долго. Пока portage посчитает вариант с gtk3 и без, можно успеть сходить чай попить. И это мнжду прочим с ssd. И я говорю о проблемах до удаления ебилда_ а не после. Ибо в этот раз начальную сборку я осилил не удаляя ебилд (потратил сутки на перебор юз-флагов и фиксоа ебилдов разбирая тонны поноса)

mittorn ★★★★★ ()
Последнее исправление: mittorn (всего исправлений: 1)
Ответ на: комментарий от Gary

Нет, дело не в оверлее. Дело в завистмости gtk+ от гномовских тем.
А это лишь мусор с оверлея, который можно отключить ибо из него уже ничего не надо (поставил, поигрался с вяленным, снёс)

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

Нет, дело не в оверлее

Я тебе написал явно в чём причина того что у тебя в первом посте. Открой ебилд gnome-base/gsettings-desktop-schemas-3.20.0_p_p3_p01-r1::unity-gentoo и посмотри его зависимости.

Дело в завистмости gtk+ от гномовских тем.

Ты чего вообще пытаешься добиться? Поставить gtk+ без движка тем?

Gary ★★★★★ ()

Кто-нибудь отправьте человека перечитать handbook на тему package.provided. Маски - они немного для другого.

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Gary

gtk2 не нужен движок тем от gtk3, но в ебилде указано что нужен. В общем, после перевода дерева на git туда видимо коммиттят что попало.

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

gtk2 не нужен движок тем от gtk3, но в ебилде указано что нужен.

Багрепорт отправлять не пробовал?

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Нет, собрать бы систему. Когда есть свободный день и хочется обновить систему наконец (пускай даже до полугодовалого дерева), багрепорты оформлять некогда. К тому же за полгода баг могли и исправить.

mittorn ★★★★★ ()
Ответ на: комментарий от Gary

там версия только 3.x. в любом слусае оно вполне работает и рисуется правильно и без этого пакета

mittorn ★★★★★ ()
Последнее исправление: mittorn (всего исправлений: 1)
Ответ на: комментарий от mittorn

К тому же за полгода баг могли и исправить.

Вообще по твоему описанию, весь баг заключается в том что ставится ещё один пакет на 5 мегабайт, который ты не уверен что нужен. Это всё?

Gary ★★★★★ ()

Вполне себе замаскировал gtk+:3, в юзах указал глобально -gtk3. И всё ок - в дереве руками удалять ничего не надо (дикость вообще), установить не предлагает. Живу так уже который год.

Bfgeshka ★★★★★ ()
Ответ на: комментарий от Gary

Баг в сотне завимимостей, не работающих с мультилибом, которые мне не нужны

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

Скорее всего, ты просто не умеешь им пользоваться.

Выставьте мультил для нужных тебе приложений, раз сотня не нужны.

Не понял, почему у тебя замаскированная версия пакета из оверлея, а удаляешь ebuilds из portage?

Если тебя уж очень сильно смущает эта зависимость, то скопируй ebuild, где она прописана в локальный оверлей и удали эту зависимость из него. После ставь пакет из оверлея. Или описывал баг и жди, чтобы его кто-то ещё подтвердил, а потом вынес решение по нему. Но вариант с локальным оверлеем быстрее.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 2)

::unity-gentoo

...

Наставят говна, потом страдают

vasily_pupkin ★★★★★ ()

Тред весь прочитать не осилил ввиду прогрессирующего ФГМ у ТСа.

=x11-libs/gtk+-3.20.9_p_p1_p02-r1

достаточно лишь x11-libs/gtk+:3, не нужно каждую версию маскировать отдельно.

rm /usr/portage/x11-libs/gtk+/gtk+-3*.ebuild

а вот за это по рукам надо бить

eternal_sorrow ★★★★★ ()
Ответ на: комментарий от mittorn

У тебя история меняется от поста к посту, но в чём проблема ты описать так и не можешь. Мне, честно говоря, надоело тебя развлекать.

Gary ★★★★★ ()
Ответ на: комментарий от eternal_sorrow

У меня замаскированы все. Ещё раз бл...
Как мне сделать чтобы portage не предлагал мне размаскировать пакет считая это самым простым решением?

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

ты зачем учётку угнал, а?

Как мне сделать чтобы portage не предлагал мне размаскировать пакет считая это самым простым решением?

не ставь пакеты, требующие твой замаскированный пакет.

Deleted ()
Ответ на: комментарий от Deleted

А что если они не требовали до обновления? Вопрос в пересборке мира которую я последний раз смог довести до конца в 2015 году (да, я тоже удалял ебилды). После этого все попытки пересобрать мир обламывались и я накатывал систему с нуля т.к обсчёт зависимостей длится по 10 минут и выдаёт в итоге что я должен размаскировать gtk3

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

ну, пакеты-то обновляются, у них иногда появляются новые зависимости.

когда обновляешься часто, то всю эту фигню разруливать проще, чем разгребать авгиевы конюшни новых зависимостей, конфликтов и прочего хаоса, раз в год.

Deleted ()
Ответ на: комментарий от mittorn

Если установленному у тебя пакету или пакету, который ты хочешь установить, нужен gtk+3, то его нужно размаскировать. Что именно тебя удивляет? Маскировка нужна для маскировки определённых версий пакетов, а не зависимостей в целом.

Если ты не хочешь ставить необязательную зависимость, то это управляется отключением соответствующих USE-флагов, а не маскировками (с чего ты взял, что они для этого?). Если зависимость обязательная, то ты её не отключишь без правки ebuild-файла и делать это лучше поместив ebuild в локальный оверлей. Но как после этого будет работать приложение - на твоей совести.

anonymous ()
Ответ на: комментарий от mittorn

Поставить gentoolkit и выполнить

equery d имя_пакета_зависимости

Только ты в исходном сообщении и так написал какие установленные пакеты хотят gtk+3

grem ★★★★★ ()
Ответ на: комментарий от grem

там ещё около десятка. Т.е на получение зависимостей путём попытки избавления от них ушло полдня

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

Значит от gtk+:3 у тебя зависит кучка установленных программ

Пока непонятно, что ты в итоге хочешь. Больше на кривляние похоже. Если тебе не нужен gtk+3, то не ставь программы, которые от него зависят. Если хочешь узнать, какой софт зависит именно от него, то выполни

equery d x11-libs/gtk+:3

Отобразится не только спсиок зависящих от него пакетов, но и use-флаги из-за которых он стал зависимостью, если она опциональна.

Например, из строчки «media-gfx/darktable-2.2.5 (>=x11-libs/gtk+-3.14:3)» видно, что darktable жётстко привязан к gtk+3.

Т.е на получение зависимостей путём попытки избавления от них ушло полдня

Это ж ты так запустил систему.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от grem

Тут помогло бы нацти всех кто пишет кривые ебилды и поубивать их. Но уже поздно и еб лды написаны

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

ты сам поставил кривые ebuild'ы , только пока не ясно, с твоих слов, в чём их кривость

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от grem

Кривые ебилды в основном дереве. Зависимосьь gtk2 от gtk3шного движка это в дереве было.

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

Зависимосьь gtk2 от gtk3шного движка это в дереве было.

Где? Не вижу.

grem ★★★★★ ()

Сколько раз не ставил генту - так и не понял зачем она? И зачем вся эта возня с компиляцией и, главное, ручной сборкой/настройкой по сути всего и вся. Только ради выпиливания системд?

menangen ★★★★★ ()
Ответ на: комментарий от mittorn

Где там зависимость от gtk+3? Набор иконок - это не движок.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
# required by gnome-base/gsettings-desktop-schemas-3.20.0_p_p3_p01-r1::unity-gentoo

Тебе не кажется, что основное дерево тут ни при чём? ЕМНИП, Unity уже давненько использует GTK+ третьей ветки в некоторых местах (как минимум потому, что Canonical поставляют для этой DE патченные версии GTK+ обоих веток).

spijet ★★★ ()
Ответ на: комментарий от menangen

Зачем и как выпиливать то, что и так не установлено по умолчанию?

grem ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.