LINUX.ORG.RU

Проблема с обновлением Calculate

 ,


0

1

При попытке обновиться получаю вот такое:

The following keyword changes are necessary to proceed:
 (подробнее см. в разделе "package.accept_keywords" man-руководства portage(5))
# required by sys-libs/binutils-libs-2.25.1-r1::gentoo
# required by x11-libs/cairo-1.14.2-r1::gentoo
# required by www-client/firefox-bin-38.3.0::gentoo
# required by @selected
# необходим для @world (argument)
=sys-devel/binutils-config-5 ~amd64
# required by x11-libs/cairo-1.14.2-r1::gentoo
# required by www-client/firefox-bin-38.3.0::gentoo
# required by @selected
# необходим для @world (argument)
=sys-libs/binutils-libs-2.25.1-r1 ~amd64

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by x11-libs/cairo-1.14.2-r1::gentoo
# required by www-client/firefox-bin-38.3.0::gentoo
# required by @selected
# необходим для @world (argument)
>=sys-libs/binutils-libs-2.25.1-r1 abi_x86_32

Если я правильно это понимаю, то хочет обновиться firefox, который в свою очередь требует новую cairo, а та binutils-libs, которые у меня не установлены.

Пробую поставить отдельно binutils-libs:

calculate demas # emerge binutils-libs

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
[ebuild     U ~] sys-devel/binutils-config-5 [4-r2]
[ebuild  N    ~] sys-libs/binutils-libs-2.25.1-r1  USE="nls zlib -static-libs" ABI_X86="(64) -32 (-x32)" 
[blocks B      ] <app-admin/eselect-1.4.5 ("<app-admin/eselect-1.4.5" is blocking sys-devel/binutils-config-5)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-devel/binutils-config-5:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-devel/binutils-config-3 required by (sys-devel/binutils-2.25.1-r1:0/0::gentoo, installed)
    >=sys-devel/binutils-config-5 required by (sys-libs/binutils-libs-2.25.1-r1:0/2.25.1::gentoo, ebuild scheduled for merge)

  (app-admin/eselect-1.4.4:0/0::gentoo, installed) pulled in by
    >=app-admin/eselect-1.2.4 required by (app-eselect/eselect-mesa-0.0.10:0/0::gentoo, installed)
    >=app-admin/eselect-1.0.6 required by (app-eselect/eselect-vi-1.1.7-r1:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-java-0.1.0:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-infinality-1:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.4 required by (app-eselect/eselect-opengl-1.2.7:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-xvmc-0.4:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.4 required by (app-eselect/eselect-qtgraphicssystem-1.1.1:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-wxwidgets-20140423:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.3 required by (app-eselect/eselect-python-20111108:0/0::gentoo, installed)
    >=app-admin/eselect-1.0.2 required by (app-eselect/eselect-ruby-20131227:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.3 required by (app-eselect/eselect-ctags-1.18:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-lib-bin-symlink-0.1.1:0/0::gentoo, installed)
    >=app-admin/eselect-1.2 required by (sys-apps/portage-2.2.20.1:0/0::gentoo, installed)
    >=app-admin/eselect-1.2.3 required by (app-eselect/eselect-fontconfig-1.1:0/0::gentoo, installed)
    app-admin/eselect required by (app-eselect/eselect-lcdfilter-2:0/0::gentoo, installed)

Как я понимаю, проблема вот в этой строке:

[blocks B      ] <app-admin/eselect-1.4.5 ("<app-admin/eselect-1.4.5" is blocking sys-devel/binutils-config-5)

Но что дальше делать - не понятно. Подскажите, пожалуйста.

★★

Русским по белому написано, для каких пакетов нужно добавить keywords, а для каких добавить use

daemonpnz ★★★★★ ()

Хотя нет:

(sys-devel/binutils-config-5:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-devel/binutils-config-3 required by (sys-devel/binutils-2.25.1-r1:0/0::gentoo, installed)
    >=sys-devel/binutils-config-5 required by (sys-libs/binutils-libs-2.25.1-r1:0/2.25.1::gentoo, ebuild scheduled for merge)

Тут еще и binutils-config одновременно двух разных версий требуются...

lemas ★★ ()
Ответ на: комментарий от daemonpnz

Как я понимаю, у меня и то и другие размаскировано:

/etc/package/package.keywords/custom:

=sys-devel/binutils-config-5
=app-admin/eselect-1.4.5

Другое дело, что требуется одновременно две версии binutils-config, а что с этим делать пока не ясно.

lemas ★★ ()

echo «sys-libs/binutils-libs abi_x86_32» >> /etc/portage/package.use

Pinkbyte ★★★★★ ()
Ответ на: комментарий от lemas

требуется одновременно две версии binutils-config

нет, читаем выхлоп внимательнее. Требования разных версий - это следствие того, что одна из них не может быть установлена

Pinkbyte ★★★★★ ()
Ответ на: комментарий от lemas

Чувак, тебе бы матчасть подучить. Что такое keywords, что такое hard mask, что такое use.

daemonpnz ★★★★★ ()
Ответ на: комментарий от DeadEye

Ну уж ТСу точно хватит, учитывая, что он вообще на stable сидит.

daemonpnz ★★★★★ ()

sys-libs/binutils-libs-2.25.1-r1 abi_x86_32

У тебя, видимо, бинарный профиль и фаерфокс пытается подтянуть 32-битные варианты binutils. На кой это надо я не знаю, но очевидно это косяк разработчиков дистрибутива, т.к. ИМХО на бинарном stable профиле таких закидонов быть не должно.

Но что дальше делать - не понятно. Подскажите, пожалуйста

Ты лучше на форуме кальки пожалуйся, авось исправят.

Ну и ещё, как вариант, может у тебя калька уже давно, ещё со времён emul-linux, и ты как-то не очень плавно переехал на abi_x86_32?

no-such-file ★★★★★ ()
Последнее исправление: no-such-file (всего исправлений: 1)
Ответ на: комментарий от no-such-file

Ну и ещё, как вариант, может у тебя калька уже давно, ещё со времён emul-linux, и ты как-то не очень плавно переехал на abi_x86_32?

Около года. Другое дело, что она стоит второй системой параллельно Arch и я действительно плаваю в теоретических вопросах.

lemas ★★ ()
Последнее исправление: lemas (всего исправлений: 1)
Ответ на: комментарий от lemas

Привет!

Сам столкнулся с такой проблемой на Gentoo. По сути тут говорится, что любой eselect, версией ниже 1.4.5 будет блокировать binutils (обрати внимание на знак «<»). Поэтому первым делом нужно обновить eselect до той самой версии 1.4.5.

emerge -av1 =app-admin/eselect-1.4.5

Если вдруг ты используешь оверлей «science». То нужно замаскировать пакет eselect из этого оверлея. Делается это добавлением стоки

app-admin/eselect::science

В файл /etc/portage/package.mask/my.mask

Но это решит проблему только с блокированием пакетов. Keywords конечно нужно добавить в файл /etc/portage/make.conf. В ACCEPT_KEYWORDS= А useflags в файл /etc/portage/package.use/my.use

Надеюсь все получится.

P.S.

Чувак, тебе бы матчасть подучить. Что такое keywords, что такое hard mask, что такое use.

А вам, уважаемый товарищ знаток матчастей, я бы порекомендовал наконец перестать пользоваться фразой «учи матчасть». Выглядит избито, глупо и совсем не оригинально. Люди «учат матчасть» на таких вот форумах. Вам такой мысли в вашу светлую голову не приходило? Если не получается объяснить - лучше молчать.

anonymous ()
Ответ на: комментарий от anonymous

Спасибо. Решил уже, но, все равно, огромное спасибо за подробное объяснение.

lemas ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.