LINUX.ORG.RU

Установить PHP 5.3.29 на Ubuntu 16.04

 , , ,


0

1

Доброго времени суток! Так уж сложилось, что у провайдера сменилась Ubuntu с 12.04 на 16.04. PHP там стала 7.0.33, а мне нужно 5.3.хх. В принципе любая версия от 5.0 до 5.4. На 5.4 не будут работать скрипты. Желательно 5.3.xx

Скачал с сайта PHP архив 5.3.29, установил, а как его привести в действие - не знаю, как запустить его.

Делаю так:

  • Вроде, всё проходит на ура, а как запустить, не знаю. Подскажите, пожалуйста.

Более правильно и проще вам будет переписать скрипты.

А так, нужно не просто выполнить configure и make, а нужно собрать php с поддержкой модуля для используемого вами web сервера и так же включить нужные вам прочие модули.

В целом сборка и установка программ из исходников в бинарном дистрибутиве это неправильно.

Вам нужно просто выполнять скрипты или всё же в браузере?

infomeh ★★ ()
Ответ на: комментарий от infomeh

Переписать - не вариант, т. к. у нас очень много скриптов, много сайтов, а программист находится в другом месте, у него просто нет такой возможности.

У нас сайты, причём авторские, с авторскими скриптами. Всё уникальное. Это просто нереально.

saliery ()
Ответ на: комментарий от CaHbl4

Установил, но это временный вариант. Хотелось бы оригинальный образ собрать от PHP, а не от каких-то людей, где в phpinfo выдаёт автора этой сборки. Такого мой начальник не разрешит, временно лишь.

saliery ()
Ответ на: комментарий от saliery

В устаревшем и неподдерживаемом php есть дыры безопасности, поэтому лучше все равно это все переписать.

И я сомневаюсь, что у вас перестал работать весь код php скриптов.

Нужно взять и переписать то, что не работает.

infomeh ★★ ()
Ответ на: комментарий от infomeh

так кто этим будет заниматься? я же говорю, программист в другом месте сейчас находится совершенно нет возможности этим заниматься ещё раз говорю, там авторская система один человек разработал CMS от начала и до конца, сайтов кучу написал... не так всё просто плюс есть сайты, на которых целая методика обучения выложена иностранному языку. я вам серьёзно говорю, это нереально.

saliery ()
Ответ на: комментарий от saliery

общем, я сделал так: - удалил PHP 7.x:

sudo /etc/init.d/apache2 stop
sudo apt-get purge php7.*
sudo apt-get purge php.*
sudo apt-get remove --purge `dpkg -l | grep php | grep -w 7.* | awk '{print $2}' | xargs`

- установил PHP 5.3.29 через репозиторий ~sergey-dryabzhinsky:

sudo add-apt-repository ppa:sergey-dryabzhinsky/php53
sudo apt-get update
sudo apt-get install php5 apache2 libapache2-mod-php5
sudo a2enmod php53
sudo service apache2 start

- записал пакеты, которые в процессе установки шли - скачал их - переустановил Ubuntu - поставил эти пакеты в том порядке, в котором они ставились: (запускать каждую строку по отдельности, всё сразу не копировать):

sudo dpkg -i /1/exim4-config_4.86.2-2ubuntu2.3_all.deb
sudo dpkg -i /1/exim4-base_4.86.2-2ubuntu2.3_amd64.deb
sudo dpkg -i /1/exim4-daemon-light_4.86.2-2ubuntu2.3_amd64.deb
sudo dpkg -i /1/exim4_4.86.2-2ubuntu2.3_all.deb
sudo dpkg -i /1/s-nail_14.8.6-1_amd64.deb
sudo dpkg -i /1/php53-common_5.3.29-1sergeyd14.4~xenial1_all.deb
sudo dpkg -i /1/php53-cli_5.3.29-1sergeyd14.4~xenial1_amd64.deb
sudo dpkg -i /1/php53p-cli_5.3.29-1sergeyd14.4~xenial1_all.deb
sudo dpkg -i /1/php53-mod-pcntl_5.3.29-1sergeyd14.4~xenial1_amd64.deb
sudo dpkg -i /1/libapache2-mod-php53_5.3.29-1sergeyd14.4~xenial1_amd64.deb

Терминал:

sudo a2enmod php53
sudo service apache2 start

- То, что мне нужно заработало (MySQL и прочее не проверял).

Теперь удалить PHP 5.3.29 можно так:

sudo dpkg -r php или sudo dpkg -r php53

saliery ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.