LINUX.ORG.RU

Я реально не понимаю, почему софт в Ubuntu годами не обновляется

 , , , ,


0

2

В системе на ubuntu 14.04 стоит Virtualbox 4.3.36 и выше не обновляется. Это версия (внимание!) - 18 января 2016 года!

Т.е. 2 года одна из наиболее важных и нужных программ в Linux не обновляется вообще. В стандартных репозиториях ubuntu. То ли я лох, то ли они считают, что эта косячная версия Virtualbox настолько стабильная, что больше обновлять ее не нужно. Вы можете представить? 2 года, парни, 2 года!!! Почему пользователь одной из самых мейнстримовых систем должен страдать? Назовите мне хоть одну адекватную причину, почему они не обновляют Virtualbox? Они там все охренели.

Назовите мне хоть одну адекватную причину, почему они не обновляют Virtualbox?

Им пофиг на проблемы пользователей некроверсий дистрибутива, даже если это LTS. Вот тебе адекватная причина.

Khnazile ★★★★★ ()
Ответ на: комментарий от Khnazile

Им пофиг на проблемы пользователей некроверсий дистрибутива, даже если это LTS. Вот тебе адекватная причина.

Каких нахрен некроверсий? Ну ты набросил, чувак. Я бы еще согласился, если бы ты так про 12.04 сказал, но 14.04 это нифига не некроверсия.

lineager ()

Это версия (внимание!) - 18 января 2016 года!
ubuntu 14.04

Это система (внимание!) — 17 апреля 2014 года!

massimus ★★★ ()

Негрософт что с них взять то. Что хотят то и воротят как и все, Некрософт с Яблом не лучше.

Ramil ★★★ ()

жди появления flatpak в ubuntu, чё. хотя хз, как с модулем ядра там...

cetjs2 ★★★★★ ()

Тебе ради циферок новую версию? Если конкретная причина, ты же осилишь нужный ppa?

peregrine ★★★★★ ()
Ответ на: комментарий от massimus

Это система (внимание!) — 17 апреля 2014 года!

Это релиз (внимание!) с 5-летним сроком поддержки. В чем тогда по-твоему заключается эта поддержка? В глючном неолитовском софте?

lineager ()

Открою секрет, есть ppa и сами разработчики и разработчики вагранда рекомендуют ставить из ppa. На 14.04 и 16.04 так уже делаю давно и проблем не знаю. А то что она не обновляется, так это норм, я отношусь к LTS как срезу. Нужно что-то поновее что ищу ппа.

krasoffski ()
Ответ на: комментарий от peregrine

Тебе ради циферок новую версию?

Мне ради багфиксов, как и любому нормальному человеку.

Если конкретная причина, ты же осилишь нужный ppa?

Можно. Но вопрос был другой:

Почему пользователь одной из самых мейнстримовых систем должен страдать? Назовите мне хоть одну адекватную причину, почему они не обновляют Virtualbox?

Не обновляют 2 года, в системе с 5-летним сроком поддержки, который закончится аж в 2019 году.

lineager ()
Ответ на: комментарий от lineager

Почитай что входит в эту тех. поддержку.

В кратце, после выхода релиза версии софта в нём не обновляются, а в них лишь исправляются ошибки.

Если тебе нужна новая версия VirtualBox в старом дистрибутиве, то подключи репозиторий oracle.

Вот здесь всё расписано: https://www.virtualbox.org/wiki/Linux_Downloads

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от krasoffski

Открою секрет, есть ppa и сами разработчики и разработчики вагранда рекомендуют ставить из ppa. На 14.04 и 16.04 так уже делаю давно и проблем не знаю. А то что она не обновляется, так это норм, я отношусь к LTS как срезу. Нужно что-то поновее что ищу ппа.

Да 100 раз ставил сторонние ppa, просто сегодня я реально охренел. Это просто рекорд - 2 года, народ, ну 2 года не обновлять такое ПО, ну как так можно?

lineager ()
Ответ на: комментарий от lineager

Мне ради багфиксов

Если постоянно обновлять софт - получишь пачку новых багов, возможно критичных. А смысл LTS в том, чтоб минимизировать поломку уже работающего, пусть, например, и с некоторыми известными багами.

anonymous ()
Ответ на: комментарий от lineager

Не набросил. Если никто не подал официальную жалобу на проблему в дистрибутиве, значит никакой проблемы нет. Искать проблемы за вас в устаревшей версии дистрибутива никто не будет. Не потому, что это правильно, а потому что так всегда было.

Khnazile ★★★★★ ()
Ответ на: комментарий от lineager

На твоё возмущение всем по. Если тебя что-то возмущает, то сходи в начале и почитай подробно об этом, а потом уже думай прав ты или нет.

Удачи.

kostik87 ★★★★★ ()
Ответ на: комментарий от lineager

Мне ради багфиксов

Фиксы одних багов порождают на свет другие.

peregrine ★★★★★ ()
Ответ на: комментарий от lineager

мое возмущение все-равно никуда не делось.

LOL, ты хоть копейку им задонатил или поддержку купил, создал реквест и получил отказ в грубой форме, чтоб иметь право возмущаться? Или то, что ты пользуешься их дистром, - большая для них честь?

anonymous ()
Ответ на: комментарий от anonymous

Если постоянно обновлять софт - получишь пачку новых багов, возможно критичных. А смысл LTS в том, чтоб минимизировать поломку уже работающего, пусть, например, и с некоторыми известными багами.

Если гадать на кофейной гуще, чего может быть и не может, то работа с места не сдвинется. Мне мешают конкретные баги, из-за которых kubuntu 16.04 в виртуалке просто трясет от каждого клика, какая уж тут работа. Я такого никогда не видел на физическом железе, в системе просто невозможно работать. Если это ты называешь стабильностью, то извиняй.

lineager ()
Ответ на: комментарий от peregrine

Фиксы одних багов порождают на свет другие.

Да ты просто дзен выдал, что тут скажешь. Все зависит от того, какие баги мешают конкретно твоей работе. Но в любом случае, после того релиза выходило немало стабильных версий Virtualbox. Это Oracle маркирует версии своего ПО как stable и unstable. Почему какие-то дилетанты из Ubuntu решают, что «Все, хватит обновлять этот Virtualbox! Версии 2016 года хватит всем»? Здесь нихрена не пахнет профессионализмом, это дилетанство чистой воды. Почему они заставляют пользователя добавлять отдельный ppa для закачки стабильных версий, которых после 4.3.36 вышло аж несколько штук?

lineager ()

Они были заняты пилением велосипедов. Теперь велосипеды выкинуты и будет больше времени на систему.

entefeed ☆☆☆ ()
Ответ на: комментарий от lineager

Мне мешают конкретные баги, из-за которых kubuntu 16.04 в виртуалке просто трясет от каждого клика, какая уж тут работа

Ты guest additions хотя бы туда поставил? С чего ты взял, что проблема в virtualbox? С чего ты взял, что новая версия тебе поможет? Ты вообще пытался разобраться в этой проблеме? Пытался найти простое обходное решение, например, сменить DE/WM? Ты запостил репорт в багтрекеры vbox и ubuntu с детальными описаниями проблемы? Я не говорю уж про то, чтоб найти причину, исправить и отослать людям готовый патч. А так у тебя такие запросы, будто ты им кучу денег отвалил, массу писем отослал, а никто не реагирует. Ну и если тебе нужен всегда свежий софт - ставь федору, арч или генту и получай удовольствие.

anonymous ()
Ответ на: комментарий от anonymous

LOL, ты хоть копейку им задонатил или поддержку купил, создал реквест и получил отказ в грубой форме, чтоб иметь право возмущаться? Или то, что ты пользуешься их дистром, - большая для них честь?

Задонатил и активно покупал в их магазине диски, футболочки и даже Ubuntu mouse как-то купил (были давно такие фирменные плоские мышки от Canonical). И так донатил, еще когда Ubuntu только появилась. Но опять же, я смотрю на все это и понимаю, в отличии от тебя, что от донатов ничего не зависит. Политика компании не меняется годами. В промежуточных версиях, которые глючные и нерабочие, и поддерживаются пол года, мы можем найти свежий софт. Но зачем он там, если сама системы нестабильна? И наоборот, в релизах с 5-летней поддержкой лежит глючный софт, который не обновляется по 2 года - ну и куда это годится? Где здесь логика, зачем эти крайности? Почему нельзя в стабильной системе иметь последние версии стабильного ПО? Я что-то охрененно сказочное сказал?

lineager ()
Ответ на: комментарий от lineager

Да ты просто дзен выдал, что тут скажешь.

Я вот сегодня код фиксил, который давал незначительное отклонение в некоторой модели от того, каким оно должно быть по идее (ну ошибка в формуле была в одном знаке, вместо + стоял -). А после этого фикса вылез другой баг, который давал огромные отклонения, но компенсировался первым багом. А всё потому, что вторая формула подгонялась под первую на живую, т.к. «это просто» и результат был очень похоже на правильный.

Здесь нихрена не пахнет профессионализмом

LTS это не про свежий софт и не про софт в котором закрыли баги в какой-то момент времени, а про предсказуемый софт, в котором все баги известны.

peregrine ★★★★★ ()
Последнее исправление: peregrine (всего исправлений: 1)

Вот уж с Virtualbox никогда не было проблем , скачал и поставил, вот тебе и причина - репы не нужны.

ilovewindows ★★★★★ ()
Ответ на: комментарий от lineager

Задонатил и активно покупал в их магазине диски, футболочки и даже Ubuntu mouse как-то купил

Ну так зарепорть баг и попроси решить его побыстрее.

Где здесь логика, зачем эти крайности? Почему нельзя в стабильной системе иметь последние версии стабильного ПО?

Потому-что стабильная версия не означает, что у тебя нахрен все не сломается при обновлении. Это может быть даже из-за обновления одной библиотеки. И если ты посмотришь на RHEL и Debian Stable как ближайшие аналоги, то увидишь ровно тоже самое.

anonymous ()
Ответ на: комментарий от anonymous

Ты guest additions хотя бы туда поставил?

Ага, поставил. После чего сломалось даже то что работало.

Kubuntu 16.04 падает в виртуалбоксе от каждого чиха (комментарий)

С чего ты взял, что проблема в virtualbox? С чего ты взял, что новая версия тебе поможет? Ты вообще пытался разобраться в этой проблеме?

С того что у меня десятки виртуалок, в т.ч. с другими системами, в т.ч. другими версиями ubuntu, на которых таких проблем нет. С того что релиз 16.04 является стабильным, и на физическом железе не будет падать каждую минуту (в прямом смысле) от простых кликов по папкам и табам браузера. Здесь на лицо косяк Virtualbox. И да, я много чего пытался, осталось только обновить сам Virtualbox.

lineager ()
Ответ на: комментарий от lineager

Ага, поставил. После чего сломалось даже то что работало.

Cудя по описанию они либо не поставились (и это можно было в логах почитать), либо это косяк VirtualBox, что хост и клиент не срослись из-за разных версий, хотя я видел такое только один раз и то на маке.

anonymous ()
Ответ на: комментарий от anonymous

Ну так зарепорть баг и попроси решить его побыстрее.

Непонятно куда репортить. Если последний дебиан и ubuntu 14.04 нормально вертится в Virtualbox, то возможно косяк Virtualbox. А если так, то шанс что тебе ответят почти нулевой, это же Oracle.

Потому-что стабильная версия не означает, что у тебя нахрен все не сломается при обновлении. Это может быть даже из-за обновления одной библиотеки. И если ты посмотришь на RHEL и Debian Stable как ближайшие аналоги, то увидишь ровно тоже самое.

Ну вопрос мой был в том, почему в какой-то момент ребята решили, что все, пора прекращать обновления? Т.е. год они обновляли Virtualbox, а потом решили, что следующие 4 года обновлений для этой программы не будет? Ну ты реально считаешь это нормальным?

lineager ()

А почему должна обновляться? Это же LTS, где нет мажорных обновлений, как и задумано. Единственная претензия, это почему они не обновили ее до 4.3.40

admucher ()
Ответ на: комментарий от lineager

год они обновляли Virtualbox, а потом решили, что следующие 4 года обновлений для этой программы не будет? Ну ты реально считаешь это нормальным?

Я считаю, что у них просто не хватает на все времени, особенно на то, что никто не просит. И так не только у них. У разработчиков чего-то «длинного» (в том числе дистрибутивов) всегда есть огромное кол-во задач, не бывает такого, что они сидят и не знают, что бы еще им сделать. И всегда приходится на что-то забивать. Потому когда есть задача, которую тебя попросили сделать, да еще клиент, который заносит деньги, да еще попросил и напомнил, то вероятность решения этой задачи на порядки выше чем внеплановое обновление чего-то там.

anonymous ()
Ответ на: комментарий от admucher

Послушай, вот просто послушай меня. Почему тогда LibreOffice, Firefox и десятки других программ обновляются каждый месяц в Ubuntu 14.04, вот скажи? Почему только на Virtualbox забили, да так жирно, что уже 2 года уже не апдейтится? Я же спросил, назовите хотя-бы одну АДЕКВАТНУЮ причину такой маргиналии. Никто не назвал.

Я знаю еще несколько больших программ, которые на Ubuntu не обновляются ну по 3 месяца, по 6 месяцев. Но 2 года это рекорд. Мне вот эта избирательность на форе LibreOffice/Firefox и т.д. непонятна. Хотите сказать в новых версиях LibreOffice и Firefox нет мощных багов? Ну да, конечно.

lineager ()

В системе на ubuntu 14.04 стоит Virtualbox 4.3.36

Я не люблю ярлыки. Но это уже о многом говорит о тебе.
14.04 - слишком старая, чтобы ее использовать.
Virtualbox - просто не нужен, когда есть KVM
Потом тебе лень добавить репозиторий с официальной страницы, а вместо этого ты пришел возмущаться на лор, когда ответ на вопрос и так очевиден, потому что Virtualbox в multiverse.

anonymous_sama ★★★★★ ()
Ответ на: комментарий от anonymous

Я считаю, что у них просто не хватает на все времени, особенно на то, что никто не просит. И так не только у них. У разработчиков чего-то «длинного» (в том числе дистрибутивов) всегда есть огромное кол-во задач, не бывает такого, что они сидят и не знают, что бы еще им сделать. И всегда приходится на что-то забивать. Потому когда есть задача, которую тебя попросили сделать, да еще клиент, который заносит деньги, да еще попросил и напомнил, то вероятность решения этой задачи на порядки выше чем внеплановое обновление чего-то там.

Я это все понимаю, но почему Virtualbox? Это же сродни WINE, который стоит у каждого 2го пользователя Linux (и обновляется всяко чаще). Virtualbox из той же оперы, очень нужный инструмент, которым пользуется множество людей. В чем прикол не обновлять по несколько лет именно его?

lineager ()
Ответ на: комментарий от lineager

Это релиз (внимание!) с 5-летним сроком поддержки. В чем тогда по-твоему заключается эта поддержка? В глючном неолитовском софте?

Именно! Это же «стабильность» а ля дебиан. Поддержка в в фиксах совсем уж критичных багов и уязвимостей.

anonymous ()

Это всё порочная схема распространения через репозитории - она на самом деле благославение и проклятие линукса.
Мак в этом отношении более удобная unix-система.

Exmor_RS ★★ ()
Ответ на: комментарий от lineager

Потому что:

1) файрфокс пытается угнаться за постоянно развивающимся вебом и если файрфокс будет старым, то сайты в нем будут превращаться со временем в тыкву

2) виртуалка - это критически важный инструмент, в котором если что-то поменяется, то может сломаться «гость», чего в лтс релизах допускать нельзя.

ЛТС на то и рассчитан, чтобы его поставить в продакшн и забыть на 5 день

admucher ()
Ответ на: комментарий от anonymous_sama

Я не люблю ярлыки. Но это уже о многом говорит о тебе.

А я сразу вижу дилетанта, хотя-бы по вот таким высказываниям:

14.04 - слишком старая, чтобы ее использовать.

И правда, зачем нужна стабильная система, которая просто работает, и вдобавок получает обновления безопасности вплоть до 2019 года. Давай ставить релиз ради релиза. Давай менять ОС каждые 2 года, это ведь так весело.

Virtualbox - просто не нужен, когда есть KVM

Вот и ненужнаторы пожаловали. Что кому нужно, каждый определяет сам. Каждый инструмент заточен под определенный ряд задач. Если я использую Virtualbox, значит меня устраивает Virtualbox. И вообще-то тема не про это, а про наплевательское, крайне странное и избирательное отношение Canonical к обновлениям ПО.

lineager ()

Вот поэтому virtualbox из Debian вообще выкинули.

Polugnom ★★★★★ ()
Ответ на: комментарий от Exmor_RS

Это всё порочная схема распространения через репозитории - она на самом деле благославение и проклятие линукса.

Я так понимаю, что закончится все тем, что весь софт повально перейдет на Appimage, и будет все как в Windows, только в изолированных контейнерах. Потому что я, честно говоря, уже устал от этих репозиториев и постоянных глюков с зависимостями, поломками APT, проблемах добавления разных версий одной программы через sourcelist, в т.ч. из непроверенных источников (но в которых иногда лежат самые свежие версии нужного софта). Лучше закачивать Appimage с официального сайта, не добавляя ничего в sourcelist, не ломая ничего в системе, как частенько бывает. Уже год пользуюсь софтом в Appimage-контейнерах, и не зняю проблем. Когда уже все начнут предоставлять Appimage для своих программ, сколько лет должно пройти. Почему так долго доходит до людей, что это просто удобно?

lineager ()
Ответ на: комментарий от lineager

Почему так долго доходит до людей, что это просто удобно?

Удобно - это подключить официальную репу из:

https://www.virtualbox.org/wiki/Linux_Downloads

А VirtualBox в AppImage не запихнуть, т.к. нужна сборка модуля ядра.

anonymous ()
Ответ на: комментарий от lineager

Разберись для начала чем отличается main oт multiverse, а multiverse от partner, например. Стыдно таких вещей не знать, ведь это базовые вещи с которыми знакомишься в самом начале, когда начинаешь работать с дистрибутивом.
В multiverse софт обновляется только если в нем проблемы безопасности (и чаще всего критические), тогда «приходит» security-team и обновляет.
Если что, можешь посмотреть каждую причину обновления пакета.
https://packages.ubuntu.com/search?keywords=virtualbox&searchon=names&amp...

И правда, зачем нужна стабильная система, которая просто работает

И правда, ведь совсем не нужна. Trusty устарел чуть более чем полностью, там даже systemd нет, и в ядре namespace'ы нормально не работают, не Qt5 более-менее не тухлой версии, нет. До 18.04 осталось совсем недолго, так как только она выйдет, вскоре с launchpad выбросят 14.04, а держатели PPA будут от этого только рады, потому-что поддержка trusty создает лишние проблемы.

anonymous_sama ★★★★★ ()
Последнее исправление: anonymous_sama (всего исправлений: 1)

А вообще, тред жирный. Тут афтору написали простыней, а он все не успокоится

admucher ()
Ответ на: комментарий от lineager

Virtualbox сродни WINE, который стоит у каждого 2го пользователя Linux

Правда? А зачем?

И вообще-то тема не про это, а про наплевательское, крайне странное и избирательное отношение Canonical к обновлениям ПО.

Тебе ничего не обещали и никто не обязан. Решений куча, все они очевидны и просты.

ddidwyll ★★ ()
Ответ на: комментарий от anonymous

А VirtualBox в AppImage не запихнуть, т.к. нужна сборка модуля ядра.

Понятно, жаль конечно. Appimage хорош тем, что его не получится случайно обновить. Часто обновления что-то ломают, и здесь иметь несколько независимых версий программы - большое преимущество.

lineager ()
Ответ на: комментарий от admucher

А вообще, тред жирный. Тут афтору написали простыней, а он все не успокоится

Да я спокоен, уже успокоился, подключил репозиторий и пошел обновлять... Как только разберусь с гостевыми дополнениями, которые поломали мне разрешение экрана. :(

lineager ()
Ответ на: комментарий от lineager

дополнениями, которые поломали мне разрешение

А вот и всплыло то, о чем я писал выше

admucher ()
Ответ на: комментарий от lineager

Проблема курицы и яйца вестимо. В маке есть няшный homebrew в котором есть нужный софт, при этом ещё и .dmg с .pkg – линуксу тоже надо стремиться к такой компактной базовой системе.
Как в Windows не будет, опять же повторюсь будет скорее как в маке и это хорошо.
У меня-то ничего в системе не ломалось, а вот новый софт поставить это такая адская мука и боль (+ слепые фанатики говорящие «не ганись за номером версии») – а на той же винде/маке народ без задней мысли накатывает свежий релиз в день выхода без танцев вокруг .tar.gz и компиляции – это и отпугивает большинство нормальных людей.
Хакер васян с гентой думает, что все вокруг быдло/мышевозы – а им просто хочется потратить своё время на что-то другое, кроме сборки новой версии ПО и использовать его в день выхода (как например есть нормальное человеческое желание посмотреть фильм в первую неделю премьеры).

Exmor_RS ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.