LINUX.ORG.RU

KDE 5, при запуске автоматически выбрать наушники

 , , , ,


0

1

В общем, вот какая проблема. Вставил наушники в переднюю панель, а звука нет. Пришлось лазить по настройкам, переключать вручную. Можно ли сделать это при запуске автоматом? Мне просто неудобно втыкать наушники в заднюю панель. В случае с задней панелью всё просто, достаточно вставить наушники и звук появится. Впрочем, оффтоп 7 вообще не видит переднюю панель. Мне говорили, что надо какие-то перемычки на материнке переключать, какие - я не знаю/не помню.

Забыл написать, что система думает, что наушники не подключены. Но если в регуляторе громкости выбрать наушники и сделать их по умолчанию, то после перезагрузки всё сбросится.

Мне говорили, что надо какие-то перемычки на материнке переключать

Сколько их видел — никакими перемычками там не пахнет. Если у тебя что-то такое есть — кури мануал.

WereFox ★☆ ()
Ответ на: комментарий от WereFox

Честно не знаю. У меня древняя (относительно) материнка Biostar A770E3. Я не знаю даже, есть ли эти перемычки на ней, не исследовал материнку.

ozz_is_here ()

Попробуй посмотреть инструкцию к своей материнской плате. Обычно её можно найти на сайте производителя.

PeKar ()

А в регуляторе громкости передние наушники видятся как отдельное устройство? Значит его можно сделать главным, нажав на ключик напротив этого устройства. А если на наушники надо переключать профиль, то оно же потом должно запомнить это и всегда использовать с этим профилем.

А вообще, надоел ты с тупыми темами, весь лор засрал «какую мне палку выбрать, красную илитолстую?».

Deleted ()
Ответ на: комментарий от ozz_is_here

Погоди, может проблема в том, что он думает, что оно не подключено? Поэтому и не запоминает этот профиль? Тогда ой.

А ключик - это в самом регуляторе громкости, раньше kmix был, теперь хрен знает как называется. Нажимаешь на динамик в лотке, всплывает окошко с громкостями, если устройств несколько, то на нужном нажимаешь ключик и выбираешь «Default». Тогда все приложения будут через него воспроизводиться. Но у тебя проблема именно с переключением профиля, как я понял. Вот это можно было написать сразу.

Deleted ()
Ответ на: комментарий от Deleted

Да, прошу прощения, забыл указать в посте, что система думает, что наушники не подключены. Просто после каждой перезагрузки переключается на заднюю панель. А прямо сейчас наушники таки стоят Default, смотрел в

самом регуляторе громкости

ozz_is_here ()
Ответ на: комментарий от ozz_is_here

Да, тогда тебе или джамперы переключать, или играться с опциями модуля твоей звуковухи или...

А в alsamixer копался? Загружаешь комп, в пульсе никаких изменений не делаешь, сразу alsamixer, в нём находишь свою карту, копаешься в настройках, добиваешься того, чтобы пульса увидела, что подключены наушники, закрываешь миксер и делаешь sudo alsactl store. В чём плюс (если получится), фактически ты не нарушаешь работу системы, просто изменяешь настройки. Все остальные варианты будут слишком узкозаточенными.

Deleted ()
Ответ на: комментарий от Deleted

Попробовал покопаться. Есть только два устройства - HDA ATI SB и HDA ATI HDMI. При этом ни тот и ни тот не встроенная звуковуха.

Пробовал в биосе копаться, но там только включение и отключение встроенной звуковухи (причем если выключить её, то внешняя перестанет работать). Короче говоря, когда буду в следующий раз обновлять десктоп, буду выбирать материнку тщательнее (а то эта материнка была выбрана по принципу «увидел на ютубе бюджетный игровой ПК и решил себе такой же собрать»).

ozz_is_here ()
Ответ на: комментарий от ozz_is_here

ни тот не встроенная звуковуха

Не верю. Вот не верю и всё. такого просто не может быть. Проверь ещё раз и сверься с alsaplay -l

Deleted ()
Ответ на: комментарий от Deleted

Вот еще нубовопрос: а что указать в --device, если

[ozzee@localhost ~] $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

[ozzee@localhost ~] $ ls /dev/snd/
by-path    controlC1  hwC1D0    pcmC0D0p  pcmC0D2c   pcmC1D3p  pcmC1D8p  seq
controlC0  hwC0D2     pcmC0D0c  pcmC0D1p  pcmC1D10p  pcmC1D7p  pcmC1D9p  timer

ozz_is_here ()
Ответ на: комментарий от ozz_is_here

card 0: SB [HDA ATI SB], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]

Вот этот я уже пробовал указывать в скайпе, звука в наушниках не было. Правда в новом скайпе проблема еще и с микрофоном, так что.

ozz_is_here ()
Ответ на: комментарий от ozz_is_here

Запускаешь музыку, запускаешь alsamixer, выбираешь карточку с помощью f6, таскаешь ползунки и слушаешь. Если звук изменяется, значит та звуковуха. Не?

Я за тебя определить звуковуху не смогу, и всех ползунков и опций твоей звуковухи тоже не знаю.

НАЙДИ правильную звуковуху, НАЙДИ переключатель на передние наушники в опциях и крутилках в альсамиксере, за тебя это никто не сделает. Если не в состоянии, я ничем не помогу.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.