LINUX.ORG.RU

Ошибки в логе Xorg

 


0

1

имеется арч, i3wm, в логе xorg есть следующие ошибки (три последние):

--> grep -E 'WW|EE' /var/log/Xorg.0.log    
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   142.110] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   142.110] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   142.110] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   142.110] (WW) Disabling Keyboard0
[   142.110] (WW) Disabling Mouse0
[   142.114] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  1269.302] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
[  1269.302] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
[  1269.302] (WW) xf86CloseConsole: VT_ACTIVATE failed: Input/output error

поиск ничего дельного не дает. в чем собственно ошибки? как их (три последние) исправить?

★★

Перестроить индексные файлы шрифтов в указанных каталогах.man mkfontdir.

yars068 ★★★★
()
Ответ на: комментарий от Zubok

я просто не пойму, какие пичали несут енти ошибки? вроде все норма роббит, но мб можно лучше если бы без них? на чо они влияют?

safocl ★★
() автор топика
Ответ на: комментарий от safocl

Откуда мне знать, какие печали. :) Ты же написал про ошибки. Я заключил, что у тебя что-то не работает и вылетает сервер. Сейчас ты говоришь, что все работает. Тогда и не парься. :) Ищи в у nvidia, что это значит. То есть понятно что: он не может в tty записать через ioctl. Почему - вопрос.

Zubok ★★★★★
()
Ответ на: комментарий от Zubok

Я заключил, что у тебя что-то не работает и вылетает сервер

аа не, просто проверяю периодически логи, вот увидил после какой то обновы дров или месы енти ошибки)))

safocl ★★
() автор топика
Ответ на: комментарий от safocl

Это, скорее всего, появляется, когда ты переходишь в консоль при помощи Ctrl-Alt-F<n> или назад когда переходишь. Первый ioctl - KDSETMODE - как раз должен поменять режим консоли с текстовой на графическую или наоборот. Ему не удается - I/O error. Раз xf86CloseConsole, то, наверное, после перехода из консоли в графику. Я предположил, что это из-за прав.

Попробуй глянуть из графического режиму - эти строчки уже есть в логе сразу или появляются после переключения в консоль?

Zubok ★★★★★
()
Последнее исправление: Zubok (всего исправлений: 3)
Ответ на: комментарий от mandala

ну хз, мб и мешается... откудаж я знаю чо енто все означает и на че влияет.

safocl ★★
() автор топика
Ответ на: комментарий от Zubok

о кстати ентот пост натолкнул меня на мысль...

недавно поставил zsh как основной командный интерпритатор, мб енто из-за него?

кстати, почему то в tty через zsh экран криво прокручивается (не до самого низу), т.е. если экран однажды заполнился, то строка с вводом находится ниже нижнего края монитора и ее соответственно не видно

safocl ★★
() автор топика
Последнее исправление: safocl (всего исправлений: 1)
Ответ на: комментарий от safocl

Ты поясняй: речь идет об эмуляторе терминала или консоли? Вот этот вот скрин ты сделал, похоже, из консоли (догадываюсь по правам на tty1, хотя если у тебя systemd/logind, то, может быть из эмулятора):

Ошибки в логе Xorg (комментарий)

Так? То есть видно, что переключился из иксов в консоль, залогинился юзером и снял выхлоп.

кстати, почему то в tty через zsh экран криво прокручивается (не до самого низу),

А вот сейчас ты про что рассказываешь: консоль или эмулятор? Проблема только в консоли или в эмуляторе тоже?

Zubok ★★★★★
()
Последнее исправление: Zubok (всего исправлений: 4)
Ответ на: комментарий от Zubok

Так? То есть видно, что переключился из иксов в консоль, залогинился юзером и снял выхлоп.

тут с эмулятора...

ну консоль енто ж ведь и есть tty, я его так и называю...

А вот сейчас ты про что рассказываешь: консоль или эмулятор? Проблема только в консоли или в эмуляторе тоже?

тут про консоль... в эмуляторе все норма.

safocl ★★
() автор топика
Ответ на: комментарий от safocl

тут про консоль... в эмуляторе все норма.

Это все означает, скорее всего, что в консоли установлено неправильное разрешение, и экран уходит за нижнюю границу. Я пока так предполагаю, так как не вижу, как проблема выглядит. И ворнинги иксов могут быть связаны с этим как-то. Мне сейчас трудно сказать. Я все же думаю, что проблема где-то в проприетарном драйвере. Посмотри dmesg и syslog на предмет разрешения консоли (или что там в systemd смотрят - не знаю. Журнал).

И еще можно проверить такое: загрузиться без иксов, посмотреть, какое разрешение выставлено в консоли, убегает ли нижняя строчка, потом запустить иксы, вернуться в консоль и глянуть, на месте ли разрешение или оно поменялось.

Zubok ★★★★★
()
Последнее исправление: Zubok (всего исправлений: 1)

В общем, это проблемы какие-то с правами на tty и тем, как ты заходишь. Как ты инициализируешь иксы? Самостоятельно? То есть ты логинишься в консоль, а из консоли запускаешь иксы (xinit, stratx) или как? У тебя ArchLinux и, значит, systemd. Насколько я помню, в системах с systemd иксы от пользователя должны запускаться из того терминала, в котором ты залогинился, то есть в этом же терминале. Если ты залогинился в vt1, а иксы запускаешь в vt2, то там какие-то проблемы есть, насколько я помню.

Вот тебе тред как раз, который имеет отношение. Проблема с доступом tty, но в твоем случае это ворнинг. У некоторых это ошибка. https://bugs.archlinux.org/task/41257

Zubok ★★★★★
()
Ответ на: комментарий от Zubok

Как ты инициализируешь иксы?

инициализация через автозапуск startx в zprofile

--> cat .zprofile    
[[ -f ~/.zshrc ]] && . ~/.zshrc
[[ -z $DISPLAY && $XDG_VTNR -eq 1 ]] && exec startx
у меня автологин настроен без ДМ, через systemd, а при загрузке оболочки выполняется старт иксов

safocl ★★
() автор топика
Последнее исправление: safocl (всего исправлений: 1)
Ответ на: комментарий от Zubok

в общем, проблема с улетающими строками в TTY решена...

как то я решил создать вручную файл конфига граб... оказывается без опции «set gfxpayload=keep» вот такая фигня и тварится, сравнил сча стандартный конфиг граба и свой и добавил в свой данную опцию и все пошло нормально, но ошибки остались.

safocl ★★
() автор топика
Ответ на: комментарий от safocl

у меня автологин настроен без ДМ, через systemd, а при загрузке оболочки выполняется старт иксов

Ну а на каком vt запускаются иксы? Насколько я помню, иксы по умолчанию запускаются на первом доступном vt. То есть если у тебя vt1 занят, то они автоматом на втором, например, запустятся.

       vtXX    XX specifies the Virtual Terminal device number which Xorg will
               use.  Without this option, Xorg will pick the  first  available
               Virtual  Terminal that it can locate.  This option applies only
               to platforms that have virtual terminal support, such as Linux,
               BSD, OpenSolaris, SVR3, and SVR4.

А именно этот момент в systemd имеет значение: запуск иксов происходит из vt1, а они запускаются на vt2. Соответсветтно, проблема прав на tty всплывает. Попробуй запустить иксы типа startx -- vt1

Zubok ★★★★★
()
Последнее исправление: Zubok (всего исправлений: 2)
Ответ на: комментарий от safocl

система находится на ctrl+alt+F1.

Да перебери тупо ctrl+alt+F<N>. Где у тебя zsh сейчас и где иксы запустились.

Zubok ★★★★★
()
Ответ на: комментарий от safocl

на ctrl+alt+F1.

Раз так, то права на tty1 вроде правильные (safff — это же ты?) — tty1 твой:

crw------- 1 safff tty  4,  1 мар  2 15:41 /dev/tty1

Теряюсь в догадках. Может быть, что просто баг какой-то, а мы сидим и думаем, что не так. Но раз не фатальный... Может быть, в момент запуска графики, терминал другие права имеет? Например принадлежит root.

Zubok ★★★★★
()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Zubok

эххх вот енто я облажался... оказывается:

--> ls -l /var/log/Xorg.*    
-rw-r--r-- 1 root users 20308 ноя 18 01:22 /var/log/Xorg.0.log
-rw-r--r-- 1 root users 20308 ноя 17 20:04 /var/log/Xorg.0.log.old
-rw-r--r-- 1 root root      0 июл 16  2016 /var/log/Xorg.pid-369.log
чото меня вот дата смущает...

зато:

--> ls -l ~/.local/share/xorg/Xorg.*    
-rw-r--r-- 1 safff users 19371 мар  7 17:03 /home/safff/.local/share/xorg/Xorg.0.log
-rw-r--r-- 1 safff users 20837 мар  7 12:58 /home/safff/.local/share/xorg/Xorg.0.log.old
-rw-r--r-- 1 safff users 20513 авг 12  2016 /home/safff/.local/share/xorg/Xorg.1.log
-rw-r--r-- 1 safff users 20291 авг 11  2016 /home/safff/.local/share/xorg/Xorg.1.log.old

safocl ★★
() автор топика
Ответ на: комментарий от safocl

соответственно:

--> grep -e{WW,EE} .local/share/xorg/Xorg.0.log
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    15.488] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    15.489] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    15.489] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    15.489] (WW) Disabling Keyboard0
[    15.489] (WW) Disabling Mouse0
[    15.492] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    15.958] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support

safocl ★★
() автор топика
Ответ на: комментарий от safocl

Тогда что? Подзравляю! Никакого Warning, значит, и нет. :) Логи в /var/log/, я полагаю, сохранялись, когда иксы запускались от root. А вот в ~/.local, я так понимаю, складываются логи иксов, запущенных от пользователя.

Zubok ★★★★★
()
Ответ на: комментарий от Zubok

ага, только я хз када иксы запускались от рута... раньше они запускались от рута? по тому, что раньше нельзя было не от рута завершить иксы.

safocl ★★
() автор топика
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.