LINUX.ORG.RU

@#$%-цкий апт!

 , ,


1

2
sudo aptitude install python-dolfin
<!> .aptitude вместо aptitude? ([Y]es/[N]o/[E]dit/[A]bort) n
The following NEW packages will be installed:
  comerr-dev{ab} hdf5-helpers{a} krb5-multidev{a} libarmadillo-dev{a} libarmadillo4{a} libarpack2{a} libarpack2-dev{a} 
  libavcodec-dev{a} libavformat-dev{a} libavutil-dev{a} libblacs-mpi-dev{a} libblacs-mpi1{a} libboost-chrono-dev{a} 
  libboost-filesystem-dev{a} libboost-iostreams-dev{a} libboost-math-dev{a} libboost-mpi-dev{a} libboost-mpi1.54-dev{a} 
  libboost-mpi1.54.0{a} libboost-program-options-dev{a} libboost-serialization-dev{a} libboost-system-dev{a} libboost-timer-dev{a} 
  libbtf1.2.0{a} libcf0{a} libcgal-dev{a} libcgal10{a} libcr0{a} libcsparse3.1.2{a} libcxsparse3.1.2{a} libdolfin1.3{a} 
  libdolfin1.3-dev{a} libdrm-dev{ab} libeigen3-dev{a} libfftw3-mpi-dev{a} libfftw3-mpi3{a} libfontconfig1-dev{a} libgl1-mesa-dev{a} 
  libgl1-mesa-dri{a} libgl1-mesa-glx{ab} libgl2ps-dev{a} libgl2ps0{a} libglapi-mesa{a} libglu1-mesa-dev{a} libgmp-dev{a} 
  libgmpxx4ldbl{a} libgssrpc4{a} libhdf5-mpi-dev{a} libhdf5-openmpi-7{a} libhdf5-openmpi-dev{a} libhwloc-dev{a} libhwloc-plugins{a} 
  libhwloc5{a} libhypre-2.8.0b{a} libhypre-dev{a} libibverbs-dev{a} libibverbs1{a} libice-dev{a} libjbig-dev{a} libjpeg-dev{a} 
  libjpeg-turbo8-dev{a} libjpeg8-dev{a} libkadm5clnt-mit9{a} libkadm5srv-mit9{a} libkdb5-7{a} libklu1.2.1{a} libldl2.1.0{a} 
  libllvm3.4{a} liblzma-dev{a} libmpfr-dev{a} libmumps-4.10.0{a} libmumps-dev{a} libnetcdf-dev{a} libnetcdfc++4{a} libnetcdfc7{a} 
  libnetcdff5{a} libopenmpi-dev{a} libopenmpi1.6{a} libparpack2{a} libpci-dev{ab} libpetsc3.4.2{a} libpetsc3.4.2-dev{a} libpq-dev{a} 
  libpq5{a} libpthread-stubs0-dev{a} libptscotch-5.1{a} libptscotch-dev{a} libscalapack-mpi-dev{a} libscalapack-mpi1{a} 
  libscotch-5.1{a} libscotch-dev{a} libslepc3.4.2{a} libslepc3.4.2-dev{a} libsm-dev{a} libspooles-dev{a} libspooles2.2{a} 
  libspqr1.3.1{a} libssl-dev{a} libssl-doc{a} libsuitesparse-dev{a} libsuperlu3{a} libsuperlu3-dev{a} libswscale-dev{a} 
  libtiff5-dev{a} libtiffxx5{a} libtorque2{a} libvtk5-dev{a} libvtk5-qt4-dev{a} libvtk5.8{a} libvtk5.8-qt4{a} libx11-dev{a} 
  libx11-doc{a} libx11-xcb-dev{a} libxau-dev{a} libxcb-dri2-0-dev{a} libxcb-dri3-dev{a} libxcb-glx0-dev{a} libxcb-present-dev{a} 
  libxcb-randr0-dev{a} libxcb-render0-dev{a} libxcb-shape0-dev{a} libxcb-sync-dev{a} libxcb-xfixes0-dev{a} libxcb1-dev{a} 
  libxdamage-dev{a} libxdmcp-dev{a} libxext-dev{a} libxfixes-dev{a} libxft-dev{a} libxml2-dev{a} libxrender-dev{a} 
  libxshmfence-dev{a} libxss-dev{a} libxt-dev{a} libxxf86vm-dev{a} mesa-common-dev{a} mpi-default-bin{a} mpi-default-dev{a} 
  openmpi-bin{a} openmpi-common{a} pyro{a} python-dolfin python-ffc{a} python-fiat{a} python-instant{a} python-netcdf{a} 
  python-ply{a} python-scientific{a} python-ufc{a} python-ufl{a} swig{a} swig2.0{a} tcl8.6-dev{a} tk8.6-dev{a} ufc{a} 
  x11proto-core-dev{a} x11proto-damage-dev{a} x11proto-dri2-dev{a} x11proto-fixes-dev{a} x11proto-gl-dev{a} x11proto-input-dev{a} 
  x11proto-kb-dev{a} x11proto-render-dev{a} x11proto-scrnsaver-dev{a} x11proto-xext-dev{a} x11proto-xf86vidmode-dev{a} 
  xorg-sgml-doctools{a} xtrans-dev{a} 
0 packages upgraded, 168 newly installed, 0 to remove and 1 not upgraded.
Need to get 80.3 MB of archives. After unpacking 487 MB will be used.
The following packages have unmet dependencies:
 libdrm-dev : Depends: libdrm2 (= 2.4.56-1~ubuntu2) but 2.4.64-1~ubuntu14.04.1 is installed.
              Depends: libdrm-intel1 (= 2.4.56-1~ubuntu2) but 2.4.64-1~ubuntu14.04.1 is installed.
              Depends: libdrm-radeon1 (= 2.4.56-1~ubuntu2) but 2.4.64-1~ubuntu14.04.1 is installed.
              Depends: libdrm-nouveau2 (= 2.4.56-1~ubuntu2) but 2.4.64-1~ubuntu14.04.1 is installed.
 xserver-xorg-lts-wily : Conflicts: libgl1-mesa-dri (>= 0~) but 10.1.0-4ubuntu5 is to be installed.
                         Conflicts: libgl1-mesa-glx (>= 0~) but 10.1.0-4ubuntu5 is to be installed.
                         Conflicts: libglapi-mesa (>= 0~) but 10.1.0-4ubuntu5 is to be installed.
 libpci-dev : Depends: libpci3 (= 1:3.2.1-1ubuntu5) but 1:3.2.1-1ubuntu5.1 is installed.
 libgl1-mesa-glx-lts-wily : Conflicts: libgl1 which is a virtual package.
                            Conflicts: libgl1-mesa-glx but 10.1.0-4ubuntu5 is to be installed.
 libglapi-mesa-lts-wily : Conflicts: libglapi-mesa but 10.1.0-4ubuntu5 is to be installed.
 libgl1-mesa-glx : Conflicts: libgl1 which is a virtual package.
 libgl1-mesa-dri-lts-wily : Conflicts: libgl1-mesa-dri but 10.1.0-4ubuntu5 is to be installed.
 comerr-dev : Depends: libcomerr2 (= 1.42.9-3ubuntu1.2) but 1.42.9-3ubuntu1.3 is installed.
The following actions will resolve these dependencies:

и так со многими -dev пакетами. Как отловить гадину, что апт ломает? apt-get install -f, естественно, не делает вообще ничего. А поломалось оно, если память не изменяет, когда электричество вырубило во время установки, и там что то не доустановилось...

★★★★★

Ответ на: комментарий от thunar

ну тогда все что могу посоветовать - идти в tui аптитуда и решать зависимости руками, я только так умею

ii343hbka ★★★ ()

Если серьезно поломались пакетные базы, то удали списки пакетов и сделай aptitude update снова. Они перегенерятся.

Удали содержимое /var/lib/apt/lists/*

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 2)

Понавключал сторонних репозитариев, да?

anonymous ()

Это да, не то, что в арче.

anonymous ()
Ответ на: комментарий от mandala

offtopic

 # aptitude --help

...
тут вывод подсказки
...

                  Эта версия aptitude не имеет коровьей СУПЕРСИЛЫ.

Вот я и не юзаю его. :)

mandala ★★★★ ()
Ответ на: комментарий от mandala

ну аптитуд хоть какую условно полезную инфу выдаёт, апт просто пишет про held пакеты, причём dpkg --get-selections их не видит..

thunar ★★★★★ ()

с таким трешом переходи на портаж, будешь чувствовать себя как дома!

slon ()

Хотя собсно вот:

The following packages have unmet dependencies:
 libdrm-dev : Depends: libdrm2 (= 2.4.56-1~ubuntu2) but 2.4.64-1~ubuntu14.04.1 is installed.


Вы устанавливаете нечто, в зависимостях которого более старые версии того, что установлено. Так не получится, «фарш невозможно провернуть назад». Либо ищите этот python-dolfin, уже собранный под свой дистрибутив, либо пересобирайте сами.

akk ★★★★★ ()
Ответ на: комментарий от akk

Да что вот. Он там уже раза два всё переломал, наверное.

mandala ★★★★ ()
Ответ на: комментарий от akk

Жесть какая-то, попробовал на другой системе — а там такой же треш, или в бубунту опять дерьма завезли, или оно из partner притекло. Блин, в какое же кривое дерьмо превратили линакс, скоро придётся как в венде все программы вручную ставить — в репах плошной dephell.

thunar ★★★★★ ()

А поломалось оно, если память не изменяет, когда электричество вырубило во время установки, и там что то не доустановилось...

БД aptitude сломалось, т.к. журнал ФС вернулся в состояние до отключения питания на участке, в который что-то записывалось при отрубе электричества. Купи ИБП и настрой в правилах, чтобы гибернейтилось при низком заряде. Так ты не повредишь систему. Ядро зафиксирует момент системы при ее обновлении и уйдет в спячку. Обратно выйдет из режима и ты дообновишь систему. На генте я такое часто проворачивал с emerge.

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)
Ответ на: комментарий от Deleted

в бубунту опять дерьма завезли

дело было не в бабине, #$%&@!$ сидел в кабине.

robotron5 ()

Переустановка системы должна помочь.

Lavos ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.