LINUX.ORG.RU

Не ставится libgl1-mesa-dev.

 , , ,


0

2

Недавно переехал на ubuntu 16.04 (до этого был Минт 17). Вроде обжился, нормально. Дошло дело до проекта на Qt Quick, и тут вылезла проблема. При сборке проекта получаю сообщение

cannot find -lGL
Погуглил, вроде пишут, что нужно поставить пакет libgl1-mesa-dev. Пытаюсь:
#apt install libgl1-mesa-dev
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libgl1-mesa-dev : Зависит: mesa-common-dev (= 11.2.0-1ubuntu2) но он не будет установлен
                   Зависит: libgl1-mesa-glx (= 11.2.0-1ubuntu2) но 11.2.0-1ubuntu2.1 будет установлен
                   Зависит: libdrm-dev (>= 2.4.65) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Поискал про такие ошибки, везде пишут, что это от PPA. PPA у меня нет ни одного. Откуда взялся в моей системе 11.2.0-1ubuntu2.1 вместо 11.2.0-1ubuntu2 - не знаю. apt update -f не помог. Попробовал aptitude, тот развил бурную деятельность:
aptitude install libgl1-mesa-dev
Следующие НОВЫЕ пакеты будут установлены:     
  libdrm-dev{ab} libgl1-mesa-dev{b} libx11-xcb-dev{a} libxcb-dri2-0-dev{a} libxcb-dri3-dev{a} libxcb-glx0-dev{a} 
  libxcb-present-dev{a} libxcb-randr0-dev{a} libxcb-render0-dev{a} libxcb-shape0-dev{a} libxcb-sync-dev{a} 
  libxcb-xfixes0-dev{a} libxdamage-dev{a} libxext-dev{a} libxfixes-dev{a} libxshmfence-dev{a} libxxf86vm-dev{a} 
  mesa-common-dev{a} x11proto-damage-dev{a} x11proto-dri2-dev{a} x11proto-fixes-dev{a} x11proto-gl-dev{a} 
  x11proto-xext-dev{a} x11proto-xf86vidmode-dev{a} 
0 пакетов обновлено, 24 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 1 177 kБ архивов. После распаковки 7 400 kБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libgl1-mesa-dev : Зависит: libgl1-mesa-glx (= 11.2.0-1ubuntu2) но установлен 11.2.0-1ubuntu2.1.
 libdrm-dev : Зависит: libdrm2 (= 2.4.67-1) но установлен 2.4.67-1ubuntu0.16.04.1.
              Зависит: libdrm-intel1 (= 2.4.67-1) но установлен 2.4.67-1ubuntu0.16.04.1.
              Зависит: libdrm-radeon1 (= 2.4.67-1) но установлен 2.4.67-1ubuntu0.16.04.1.
              Зависит: libdrm-nouveau2 (= 2.4.67-1) но установлен 2.4.67-1ubuntu0.16.04.1.
              Зависит: libdrm-amdgpu1 (= 2.4.67-1) но установлен 2.4.67-1ubuntu0.16.04.1.
Следующие действия разрешат зависимости:

     Оставить для следующих пакетов их текущие версии:
1)     libdrm-dev [Не установлен]                     
2)     libgl1-mesa-dev [Не установлен]                
3)     mesa-common-dev [Не установлен]                

Принять данное решение? [Y/n/q/?] q
Я, честно говоря, не особо понял, что он предложил сделать, и решил сначала спросить совета. Я не против того, чтобы оставить текущие версии пакетов. Но не вылезет ли потом это боком? И вообще, отчего такое могло случиться?


Ответ на: комментарий от EXL
Пакеты, имеющие неудовлетворённые зависимости:
 mesa-common-dev : Зависит: libdrm-dev (>= 2.4.65) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Beewek ()
Ответ на: комментарий от EXL

Уф. Сделал от безысходности ещё раз

sudo apt update && sudo apt upgrade
, пришли какие-то обновления, и всё починилось:-) Видимо, исправили. Спасибо за помощь.

Beewek ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.