LINUX.ORG.RU

openSUSE 42.1 + Plasma 5 + Phonon GStreamer = где звук?

 , ,


0

1

Всех с наступившим! Имею проблемы со свежеустановленной openSUSE: звук работает в регуляторе и в проверке динамиков, но ни Amarok аудиофайлы не воспроизводит, ни настройка Phonon не звучит. Хорошие, плохие и злые кодеки установлены из Packman'а, backend-gstreamer стоИт и выбран в настройках, звуковая карта автоматически настроена YaST'ом, куда копать дальше?


в Дженте поставил без фонона, а звук есть. Никогда не догонял, для чего он таки нужен, акромя самого КДЕ.

Deleted ()
Последнее исправление: Lifun (всего исправлений: 1)

Доустановила VLC-backend'ы. Если их выставить приоритетными, то после перезапуска конфигуратора Phonon в 1-й раз тестовое аудио воспроизводится, а во 2+-й — выдаётся «Ошибка установки выбранного устройства воспроизведения звука». Amarok воспроизводит FLAC. MP3 — тоже, но без звука. Куда копать дальше?

Pepsi ()

проверь, все ли потроха gstreamer`а переведены на пакмановские версии. часть м.б. установлена из дефолтной репы и конфликтует с пакманом

registrant ★★★★★ ()
Ответ на: комментарий от registrant

Вот это возможно. Подскажите, что не так:

zypper search -iv gstreamer
С | Имя                              | Тип         | Версия     | Архитектура | Репозиторий               
--+----------------------------------+-------------+------------+-------------+---------------------------
i | GStreamer Multimedia Codecs      | application |            | noarch      | (Системные пакеты)        
    name: application:GStreamer Multimedia Codecs
i | gstreamer                        | package     | 1.6.1-61.3 | x86_64      | packman                   
    name: gstreamer
i | gstreamer                        | package     | 1.6.1-61.3 | x86_64      | (Системные пакеты)        
    name: gstreamer
i | gstreamer-fluendo-mp3            | package     | 21-1.2     | x86_64      | openSUSE:Leap:42.1:NonFree
    name: gstreamer-fluendo-mp3
i | gstreamer-fluendo-mp3            | package     | 21-1.2     | x86_64      | (Системные пакеты)        
    name: gstreamer-fluendo-mp3
i | gstreamer-lang                   | package     | 1.6.1-61.3 | noarch      | packman                   
    name: gstreamer-lang
i | gstreamer-lang                   | package     | 1.6.1-61.3 | noarch      | (Системные пакеты)        
    name: gstreamer-lang
i | gstreamer-plugins-bad            | package     | 1.6.1-91.1 | x86_64      | packman                   
    name: gstreamer-plugins-bad
i | gstreamer-plugins-bad            | package     | 1.6.1-91.1 | x86_64      | (Системные пакеты)        
    name: gstreamer-plugins-bad
i | gstreamer-plugins-bad-orig-addon | package     | 1.6.1-91.1 | x86_64      | packman                   
    name: gstreamer-plugins-bad-orig-addon
i | gstreamer-plugins-bad-orig-addon | package     | 1.6.1-91.1 | x86_64      | (Системные пакеты)        
    name: gstreamer-plugins-bad-orig-addon
i | gstreamer-plugins-base           | package     | 1.6.1-56.2 | x86_64      | packman                   
    name: gstreamer-plugins-base
i | gstreamer-plugins-base           | package     | 1.6.1-56.2 | x86_64      | (Системные пакеты)        
    name: gstreamer-plugins-base
i | gstreamer-plugins-base-doc       | package     | 1.6.1-56.2 | x86_64      | packman                   
    name: gstreamer-plugins-base-doc
i | gstreamer-plugins-base-doc       | package     | 1.6.1-56.2 | x86_64      | (Системные пакеты)        
    name: gstreamer-plugins-base-doc
i | gstreamer-plugins-base-lang      | package     | 1.6.1-56.2 | noarch      | packman                   
    name: gstreamer-plugins-base-lang
i | gstreamer-plugins-base-lang      | package     | 1.6.1-56.2 | noarch      | (Системные пакеты)        
    name: gstreamer-plugins-base-lang
i | gstreamer-plugins-good           | package     | 1.6.1-67.1 | x86_64      | packman                   
    name: gstreamer-plugins-good
i | gstreamer-plugins-good           | package     | 1.6.1-67.1 | x86_64      | (Системные пакеты)        
    name: gstreamer-plugins-good
i | gstreamer-plugins-good-doc       | package     | 1.6.1-67.1 | x86_64      | packman                   
    name: gstreamer-plugins-good-doc
i | gstreamer-plugins-good-doc       | package     | 1.6.1-67.1 | x86_64      | (Системные пакеты)        
    name: gstreamer-plugins-good-doc
i | gstreamer-plugins-good-extra     | package     | 1.6.1-67.1 | x86_64      | packman                   
    name: gstreamer-plugins-good-extra
i | gstreamer-plugins-good-extra     | package     | 1.6.1-67.1 | x86_64      | (Системные пакеты)        
    name: gstreamer-plugins-good-extra
i | gstreamer-plugins-good-lang      | package     | 1.6.1-67.1 | noarch      | packman                   
    name: gstreamer-plugins-good-lang
i | gstreamer-plugins-good-lang      | package     | 1.6.1-67.1 | noarch      | (Системные пакеты)        
    name: gstreamer-plugins-good-lang
i | gstreamer-plugins-libav          | package     | 1.6.1-2.1  | x86_64      | packman                   
    name: gstreamer-plugins-libav
i | gstreamer-plugins-libav          | package     | 1.6.1-2.1  | x86_64      | (Системные пакеты)        
    name: gstreamer-plugins-libav
i | gstreamer-plugins-ugly           | package     | 1.6.1-54.1 | x86_64      | packman                   
    name: gstreamer-plugins-ugly
i | gstreamer-plugins-ugly           | package     | 1.6.1-54.1 | x86_64      | (Системные пакеты)        
    name: gstreamer-plugins-ugly
i | libgstreamer-1_0-0               | package     | 1.6.1-61.3 | x86_64      | packman                   
    name: libgstreamer-1_0-0
i | libgstreamer-1_0-0               | package     | 1.6.1-61.3 | x86_64      | (Системные пакеты)        
    name: libgstreamer-1_0-0
i | phonon-backend-gstreamer         | package     | 4.8.2-1.2  | x86_64      | openSUSE_Leap_42.1_OSS    
    name: phonon-backend-gstreamer
i | phonon-backend-gstreamer         | package     | 4.8.2-1.2  | x86_64      | (Системные пакеты)        
    name: phonon-backend-gstreamer
i | phonon4qt5-backend-gstreamer     | package     | 4.8.2-2.4  | x86_64      | openSUSE_Leap_42.1_OSS    
    name: phonon4qt5-backend-gstreamer
i | phonon4qt5-backend-gstreamer     | package     | 4.8.2-2.4  | x86_64      | (Системные пакеты)        
    name: phonon4qt5-backend-gstreamer
Pepsi ()
Ответ на: комментарий от registrant

С пакетами вроде всё то же самое.

В настройках Phonon в Amarok вообще никакие устройства не видны. Если backend — VLC, то FLAC воспроизводится, а MP3 — беззвучно. Если backedn — GStreamer, то ничего не играется (даже ползунок неподвижен).

Pepsi ()

Проблему удалось детализировать. Phonon работает с backend-gstreamer, если кодеки установлены из штатных репозиториев, но перестаёт, если поставить кодеки из Packman'а. Что с этим делать?

Pepsi ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.